summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-04-22 03:36:45 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-04-22 03:36:45 +0000
commit03f5ed3591fd363050999df5a686c4b3f6647cdb (patch)
treed39ae36d16a1efce648492b1b80c69935f91e40f /dev-lang
parentbetter discriptions... (diff)
downloadgentoo-2-03f5ed3591fd363050999df5a686c4b3f6647cdb.tar.gz
gentoo-2-03f5ed3591fd363050999df5a686c4b3f6647cdb.tar.bz2
gentoo-2-03f5ed3591fd363050999df5a686c4b3f6647cdb.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/hy/ChangeLog7
-rw-r--r--dev-lang/hy/hy-0.10.0.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-lang/hy/ChangeLog b/dev-lang/hy/ChangeLog
index d915bbafa868..2ac69bf24880 100644
--- a/dev-lang/hy/ChangeLog
+++ b/dev-lang/hy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/hy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/hy/ChangeLog,v 1.3 2014/04/10 18:06:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hy/ChangeLog,v 1.4 2014/04/22 03:36:45 patrick Exp $
+
+*hy-0.10.0 (22 Apr 2014)
+
+ 22 Apr 2014; Patrick Lauer <patrick@gentoo.org> +hy-0.10.0.ebuild:
+ Bump
10 Apr 2014; Michał Górny <mgorny@gentoo.org> hy-0.9.12.ebuild:
Add a lot of missing ${PYTHON_USEDEP}.
diff --git a/dev-lang/hy/hy-0.10.0.ebuild b/dev-lang/hy/hy-0.10.0.ebuild
new file mode 100644
index 000000000000..36004805df34
--- /dev/null
+++ b/dev-lang/hy/hy-0.10.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hy/hy-0.10.0.ebuild,v 1.1 2014/04/22 03:36:45 patrick Exp $
+
+EAPI=5
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python2_7 python3_3)
+
+inherit distutils-r1
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
+ dev-python/astor[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}