summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-08-28 11:20:50 +0000
committerMichał Górny <mgorny@gentoo.org>2014-08-28 11:20:50 +0000
commit05940618fe211b35601dfdaaefc5c623c748cab8 (patch)
tree0b6f39d78c038e232aa7748a686da9694fdaecb8 /dev-lang
parentRemove mistakenly left USE=bash-completion. (diff)
downloadgentoo-2-05940618fe211b35601dfdaaefc5c623c748cab8.tar.gz
gentoo-2-05940618fe211b35601dfdaaefc5c623c748cab8.tar.bz2
gentoo-2-05940618fe211b35601dfdaaefc5c623c748cab8.zip
Remove USE=bash-completion, install the completion file unconditionally following the Council decision.
(Portage version: 2.2.11_p165/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog6
-rw-r--r--dev-lang/go/go-1.3.1.ebuild11
2 files changed, 9 insertions, 8 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 0231ca1b88ca..4dc130afb66e 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.45 2014/08/15 00:33:15 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.46 2014/08/28 11:20:50 mgorny Exp $
+
+ 28 Aug 2014; Michał Górny <mgorny@gentoo.org> go-1.3.1.ebuild:
+ Remove USE=bash-completion, install the completion file unconditionally
+ following the Council decision.
15 Aug 2014; William Hubbs <williamh@gentoo.org> go-9999.ebuild:
sync live ebuild
diff --git a/dev-lang/go/go-1.3.1.ebuild b/dev-lang/go/go-1.3.1.ebuild
index eb1df00250e7..0067f40863b4 100644
--- a/dev-lang/go/go-1.3.1.ebuild
+++ b/dev-lang/go/go-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.3.1.ebuild,v 1.1 2014/08/15 00:26:17 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.3.1.ebuild,v 1.2 2014/08/28 11:20:50 mgorny Exp $
EAPI=5
@@ -22,11 +22,10 @@ HOMEPAGE="http://www.golang.org"
LICENSE="BSD"
SLOT="0"
-IUSE="bash-completion emacs vim-syntax zsh-completion"
+IUSE="emacs vim-syntax zsh-completion"
DEPEND=""
-RDEPEND="bash-completion? ( app-shells/bash-completion )
- emacs? ( virtual/emacs )
+RDEPEND="emacs? ( virtual/emacs )
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
zsh-completion? ( app-shells/zsh-completion )"
@@ -89,9 +88,7 @@ src_install()
# [1] http://code.google.com/p/go/issues/detail?id=2775
doins -r doc include lib pkg src
- if use bash-completion; then
- dobashcomp misc/bash/go
- fi
+ dobashcomp misc/bash/go
if use emacs; then
elisp-install ${PN} misc/emacs/*.el misc/emacs/*.elc