summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-01-18 13:12:48 +0000
committerMark Wright <gienah@gentoo.org>2014-01-18 13:12:48 +0000
commit09abaf3c4b08f137b43d6e90299587e7e4f9b7c2 (patch)
tree1241131007de5b32333e6f5e58c49e6180ac1ea2 /dev-lang
parentversion bump (diff)
downloadgentoo-2-09abaf3c4b08f137b43d6e90299587e7e4f9b7c2.tar.gz
gentoo-2-09abaf3c4b08f137b43d6e90299587e7e4f9b7c2.tar.bz2
gentoo-2-09abaf3c4b08f137b43d6e90299587e7e4f9b7c2.zip
Fix bug #459512 - dev-lang/ocaml with sys-libs/ncurses[tinfo] - .../work/ocaml-4.00.1/byterun/terminfo.c:54: undefined reference to 'tgetent', thanks to Reinis Danne for reporting (patch by me). Add virtual/pkg-config to DEPEND as the ocaml configure script calls pkg-config. Apply patch from upstream for upstream bug http://caml.inria.fr/mantis/view.php?id=5237 to ocaml-3.11.2.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog13
-rw-r--r--dev-lang/ocaml/files/ocaml-3.11.2-Fix-ocamlopt-w.r.t.-binutils-2.21.patch66
-rw-r--r--dev-lang/ocaml/files/ocaml-4.01.0-pkg-config-ncurses.patch15
-rw-r--r--dev-lang/ocaml/ocaml-3.11.2.ebuild13
-rw-r--r--dev-lang/ocaml/ocaml-3.12.1.ebuild11
-rw-r--r--dev-lang/ocaml/ocaml-4.00.1-r1.ebuild11
-rw-r--r--dev-lang/ocaml/ocaml-4.01.0.ebuild9
7 files changed, 122 insertions, 16 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index ea6f683a4fb8..acfe078fcb8d 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-lang/ocaml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.218 2014/01/15 22:05:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.219 2014/01/18 13:12:48 gienah Exp $
+
+ 18 Jan 2014; Mark Wright <gienah@gentoo.org>
+ +files/ocaml-3.11.2-Fix-ocamlopt-w.r.t.-binutils-2.21.patch,
+ +files/ocaml-4.01.0-pkg-config-ncurses.patch, ocaml-3.11.2.ebuild,
+ ocaml-3.12.1.ebuild, ocaml-4.00.1-r1.ebuild, ocaml-4.01.0.ebuild:
+ Fix bug #459512 - dev-lang/ocaml with sys-libs/ncurses[tinfo] -
+ .../work/ocaml-4.00.1/byterun/terminfo.c:54: undefined reference to 'tgetent',
+ thanks to Reinis Danne for reporting (patch by me). Add virtual/pkg-config to
+ DEPEND as the ocaml configure script calls pkg-config. Apply patch from
+ upstream for upstream bug http://caml.inria.fr/mantis/view.php?id=5237 to
+ ocaml-3.11.2.
15 Jan 2014; Sébastien Fabbro <bicatali@gentoo.org> ocaml-4.01.0.ebuild:
Prefixified and keyworded amd64-linux, x86-linux
diff --git a/dev-lang/ocaml/files/ocaml-3.11.2-Fix-ocamlopt-w.r.t.-binutils-2.21.patch b/dev-lang/ocaml/files/ocaml-3.11.2-Fix-ocamlopt-w.r.t.-binutils-2.21.patch
new file mode 100644
index 000000000000..fa7664cecc98
--- /dev/null
+++ b/dev-lang/ocaml/files/ocaml-3.11.2-Fix-ocamlopt-w.r.t.-binutils-2.21.patch
@@ -0,0 +1,66 @@
+From: Stephane Glondu <steph@glondu.net>
+Date: Tue, 8 Mar 2011 21:17:40 +0100
+Subject: [PATCH] Fix ocamlopt w.r.t. binutils 2.21
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Bug: http://caml.inria.fr/mantis/view.php?id=5237
+Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=617404
+Authors: Eric Cooper, spiralvoice
+Reviewed-by: Stéphane Glondu <steph@glondu.net>
+---
+ asmcomp/amd64/emit.mlp | 13 +++++++------
+ asmcomp/i386/emit.mlp | 6 +++---
+ 2 files changed, 10 insertions(+), 9 deletions(-)
+
+diff --git a/asmcomp/amd64/emit.mlp b/asmcomp/amd64/emit.mlp
+index 4a3f844..525c6e6 100644
+--- a/asmcomp/amd64/emit.mlp
++++ b/asmcomp/amd64/emit.mlp
+@@ -679,17 +679,18 @@ let fundecl fundecl =
+ emit_all true fundecl.fun_body;
+ List.iter emit_call_gc !call_gc_sites;
+ emit_call_bound_errors ();
++ begin match Config.system with
++ "linux" | "gnu" ->
++ ` .type {emit_symbol fundecl.fun_name},@function\n`;
++ ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
++ | _ -> ()
++ end;
+ if !float_constants <> [] then begin
+ if macosx
+ then ` .literal8\n`
+ else ` .section .rodata.cst8,\"a\",@progbits\n`;
+ List.iter emit_float_constant !float_constants
+- end;
+- match Config.system with
+- "linux" | "gnu" ->
+- ` .type {emit_symbol fundecl.fun_name},@function\n`;
+- ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
+- | _ -> ()
++ end
+
+ (* Emission of data *)
+
+diff --git a/asmcomp/i386/emit.mlp b/asmcomp/i386/emit.mlp
+index 2992f29..0b1252c 100644
+--- a/asmcomp/i386/emit.mlp
++++ b/asmcomp/i386/emit.mlp
+@@ -905,12 +905,12 @@ let fundecl fundecl =
+ emit_all true fundecl.fun_body;
+ List.iter emit_call_gc !call_gc_sites;
+ emit_call_bound_errors ();
+- List.iter emit_float_constant !float_constants;
+- match Config.system with
++ begin match Config.system with
+ "linux_elf" | "bsd_elf" | "gnu" ->
+ ` .type {emit_symbol fundecl.fun_name},@function\n`;
+ ` .size {emit_symbol fundecl.fun_name},.-{emit_symbol fundecl.fun_name}\n`
+- | _ -> ()
++ | _ -> () end;
++ List.iter emit_float_constant !float_constants
+
+
+ (* Emission of data *)
+--
diff --git a/dev-lang/ocaml/files/ocaml-4.01.0-pkg-config-ncurses.patch b/dev-lang/ocaml/files/ocaml-4.01.0-pkg-config-ncurses.patch
new file mode 100644
index 000000000000..b9fa750ff07d
--- /dev/null
+++ b/dev-lang/ocaml/files/ocaml-4.01.0-pkg-config-ncurses.patch
@@ -0,0 +1,15 @@
+--- ocaml-4.01.0-orig/configure 2013-08-23 16:22:36.000000000 +1000
++++ ocaml-4.01.0/configure 2014-01-18 20:06:50.669644267 +1100
+@@ -892,7 +892,11 @@
+ # For the terminfo module
+
+ if test "$withcurses" = "yes"; then
+- for libs in "" "-lcurses" "-ltermcap" "-lcurses -ltermcap" "-lncurses"; do
++ ncurseslibs=""
++ if pkg-config --exists ncurses 2>/dev/null; then
++ ncurseslibs=`pkg-config --libs ncurses`
++ fi
++ for libs in "${ncurseslibs}" "-lcurses" "-ltermcap" "-lcurses -ltermcap" "-lncurses"; do
+ if sh ./hasgot $libs tgetent tgetstr tgetnum tputs; then
+ echo "termcap functions found (with libraries '$libs')"
+ echo "#define HAS_TERMCAP" >> s.h
diff --git a/dev-lang/ocaml/ocaml-3.11.2.ebuild b/dev-lang/ocaml/ocaml-3.11.2.ebuild
index 856a34d4b388..be4f08812d90 100644
--- a/dev-lang/ocaml/ocaml-3.11.2.ebuild
+++ b/dev-lang/ocaml/ocaml-3.11.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.2.ebuild,v 1.8 2011/01/22 22:58:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.2.ebuild,v 1.9 2014/01/18 13:12:48 gienah Exp $
EAPI="1"
@@ -18,11 +18,12 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="emacs gdbm latex ncurses +ocamlopt tk X xemacs"
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
+RDEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
X? ( x11-libs/libX11 x11-proto/xproto )
gdbm? ( sys-libs/gdbm )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
@@ -43,6 +44,10 @@ src_unpack() {
unpack ${A}
cd "${S}"
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ # Bug #459512
+ epatch "${FILESDIR}/${PN}-4.01.0-pkg-config-ncurses.patch"
+ # Upstream bug: http://caml.inria.fr/mantis/view.php?id=5237
+ epatch "${FILESDIR}/${PN}-3.11.2-Fix-ocamlopt-w.r.t.-binutils-2.21.patch"
}
src_compile() {
diff --git a/dev-lang/ocaml/ocaml-3.12.1.ebuild b/dev-lang/ocaml/ocaml-3.12.1.ebuild
index e85ed46aafef..88f14d8112b9 100644
--- a/dev-lang/ocaml/ocaml-3.12.1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.12.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.12.1.ebuild,v 1.11 2012/05/24 10:47:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.12.1.ebuild,v 1.12 2014/01/18 13:12:48 gienah Exp $
EAPI="1"
@@ -18,11 +18,12 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
IUSE="emacs gdbm latex ncurses +ocamlopt tk X xemacs"
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
+RDEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
X? ( x11-libs/libX11 x11-proto/xproto )
gdbm? ( sys-libs/gdbm )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
@@ -43,6 +44,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ # Bug #459512
+ epatch "${FILESDIR}/${PN}-4.01.0-pkg-config-ncurses.patch"
}
src_compile() {
diff --git a/dev-lang/ocaml/ocaml-4.00.1-r1.ebuild b/dev-lang/ocaml/ocaml-4.00.1-r1.ebuild
index 24fd69cf4484..88e738b8ed86 100644
--- a/dev-lang/ocaml/ocaml-4.00.1-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-4.00.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.00.1-r1.ebuild,v 1.2 2013/06/19 03:19:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.00.1-r1.ebuild,v 1.3 2014/01/18 13:12:48 gienah Exp $
EAPI="5"
@@ -20,10 +20,11 @@ SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="emacs latex ncurses +ocamlopt tk X xemacs"
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
+RDEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
X? ( x11-libs/libX11 x11-proto/xproto )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
@@ -42,6 +43,8 @@ pkg_setup() {
src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ # Bug #459512
+ epatch "${FILESDIR}/${PN}-4.01.0-pkg-config-ncurses.patch"
}
src_configure() {
diff --git a/dev-lang/ocaml/ocaml-4.01.0.ebuild b/dev-lang/ocaml/ocaml-4.01.0.ebuild
index 078dd4744ec0..d6276db555ae 100644
--- a/dev-lang/ocaml/ocaml-4.01.0.ebuild
+++ b/dev-lang/ocaml/ocaml-4.01.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.01.0.ebuild,v 1.2 2014/01/15 22:05:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.01.0.ebuild,v 1.3 2014/01/18 13:12:48 gienah Exp $
EAPI="5"
@@ -20,10 +20,11 @@ SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux"
IUSE="emacs latex ncurses +ocamlopt tk X xemacs"
-DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
+RDEPEND="tk? ( >=dev-lang/tk-3.3.3 )
ncurses? ( sys-libs/ncurses )
X? ( x11-libs/libX11 x11-proto/xproto )"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
PDEPEND="emacs? ( app-emacs/ocaml-mode )
xemacs? ( app-xemacs/ocaml )"
@@ -42,6 +43,8 @@ pkg_setup() {
src_prepare() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ # Bug #459512
+ epatch "${FILESDIR}/${PN}-4.01.0-pkg-config-ncurses.patch"
}
src_configure() {