summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-01-15 22:05:46 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-01-15 22:05:46 +0000
commit24b76a2b72bdfce0dab2170cd24e6b4ad4213fd3 (patch)
tree57f32421773ae82ed69f6658d220368fe67bd34f /dev-lang
parentVersion bump (diff)
downloadgentoo-2-24b76a2b72bdfce0dab2170cd24e6b4ad4213fd3.tar.gz
gentoo-2-24b76a2b72bdfce0dab2170cd24e6b4ad4213fd3.tar.bz2
gentoo-2-24b76a2b72bdfce0dab2170cd24e6b4ad4213fd3.zip
Prefixified and keyworded amd64-linux, x86-linux
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog7
-rw-r--r--dev-lang/ocaml/ocaml-4.01.0.ebuild24
2 files changed, 17 insertions, 14 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 2b0b56880b6a..ea6f683a4fb8 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ocaml
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.217 2013/09/14 22:52:42 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.218 2014/01/15 22:05:46 bicatali Exp $
+
+ 15 Jan 2014; Sébastien Fabbro <bicatali@gentoo.org> ocaml-4.01.0.ebuild:
+ Prefixified and keyworded amd64-linux, x86-linux
14 Sep 2013; Alexis Ballier <aballier@gentoo.org> -ocaml-4.00.0.ebuild,
-ocaml-4.00.1.ebuild, -ocaml-4.01.0_beta1.ebuild, -ocaml-4.01.0_rc1.ebuild:
diff --git a/dev-lang/ocaml/ocaml-4.01.0.ebuild b/dev-lang/ocaml/ocaml-4.01.0.ebuild
index a3b0ffe9ad32..078dd4744ec0 100644
--- a/dev-lang/ocaml/ocaml-4.01.0.ebuild
+++ b/dev-lang/ocaml/ocaml-4.01.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.01.0.ebuild,v 1.1 2013/09/14 22:49:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-4.01.0.ebuild,v 1.2 2014/01/15 22:05:46 bicatali Exp $
EAPI="5"
@@ -17,7 +17,7 @@ LICENSE="QPL-1.0 LGPL-2"
# Everytime ocaml is updated to a new version, everything ocaml must be rebuilt,
# so here we go with the subslot.
SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-fbsd ~x86-linux"
IUSE="emacs latex ncurses +ocamlopt tk X xemacs"
DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
@@ -62,10 +62,10 @@ src_configure() {
use X || myconf="${myconf} -no-graph"
# ocaml uses a home-brewn configure script, preventing it to use econf.
- RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
- --bindir /usr/bin \
- --libdir /usr/$(get_libdir)/ocaml \
- --mandir /usr/share/man \
+ RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix "${EPREFIX}"/usr \
+ --bindir "${EPREFIX}"/usr/bin \
+ --libdir "${EPREFIX}"/usr/$(get_libdir)/ocaml \
+ --mandir "${EPREFIX}"/usr/share/man \
-host "${CHOST}" \
-cc "$(tc-getCC)" \
-as "$(tc-getAS)" \
@@ -89,9 +89,9 @@ src_compile() {
}
src_install() {
- make BINDIR="${D}"/usr/bin \
- LIBDIR="${D}"/usr/$(get_libdir)/ocaml \
- MANDIR="${D}"/usr/share/man \
+ make BINDIR="${ED}"/usr/bin \
+ LIBDIR="${ED}"/usr/$(get_libdir)/ocaml \
+ MANDIR="${ED}"/usr/share/man \
install
# Symlink the headers to the right place
@@ -102,7 +102,7 @@ src_install() {
# Create and envd entry for latex input files
if use latex ; then
- echo "TEXINPUTS=/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
+ echo "TEXINPUTS=${EPREFIX}/usr/$(get_libdir)/ocaml/ocamldoc:" > "${T}"/99ocamldoc
doenvd "${T}"/99ocamldoc
fi
@@ -119,7 +119,7 @@ pkg_postinst() {
if has_version '>=sys-apps/portage-2.2' ; then
ewarn "emerge @ocaml-rebuild"
else
- ewarn "emerge -1 /usr/$(get_libdir)/ocaml"
+ ewarn "emerge -1 ${EROOT%/}/usr/$(get_libdir)/ocaml"
fi
echo
}