summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-06 17:50:22 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-06 17:50:22 +0000
commit24c1f153a432cacd61c34afd0327d14c0b577af9 (patch)
treeafb7bdb6909f67476a555898e48e822d159d4d0c /dev-lang
parent[sys-apps/gdisk] Fix header (diff)
downloadgentoo-2-24c1f153a432cacd61c34afd0327d14c0b577af9.tar.gz
gentoo-2-24c1f153a432cacd61c34afd0327d14c0b577af9.tar.bz2
gentoo-2-24c1f153a432cacd61c34afd0327d14c0b577af9.zip
Remove "ucs2" USE flag and add "wide-unicode" USE flag (bug #293135).
(Portage version: 14950-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/metadata.xml6
-rw-r--r--dev-lang/python/python-2.4.6.ebuild6
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild6
-rw-r--r--dev-lang/python/python-2.6.2-r1.ebuild10
-rw-r--r--dev-lang/python/python-2.6.2-r2.ebuild6
-rw-r--r--dev-lang/python/python-2.6.3.ebuild6
-rw-r--r--dev-lang/python/python-2.6.4.ebuild6
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild6
9 files changed, 33 insertions, 27 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 5c871b79ad78..227b99a2d096 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.434 2009/12/04 16:07:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.435 2009/12/06 17:50:22 arfrever Exp $
+
+ 06 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-2.4.6.ebuild, python-2.5.4-r3.ebuild, python-2.6.2-r1.ebuild,
+ python-2.6.2-r2.ebuild, python-2.6.3.ebuild, python-2.6.4.ebuild,
+ python-3.1.1-r1.ebuild, metadata.xml:
+ Remove "ucs2" USE flag and add "wide-unicode" USE flag (bug #293135).
04 Dec 2009; Jeroen Roovers <jer@gentoo.org> python-2.6.4.ebuild:
Stable for HPPA (bug #295066).
diff --git a/dev-lang/python/metadata.xml b/dev-lang/python/metadata.xml
index f21e5485ccde..51a9e80800ad 100644
--- a/dev-lang/python/metadata.xml
+++ b/dev-lang/python/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>python</herd>
<use>
- <flag name="threads">Enable threading support (DON'T DISABLE THIS UNLESS YOU KNOW WHAT YOU'RE DOING)</flag>
- <flag name="ucs2">Enable byte size 2 unicode (DON'T USE THIS UNLESS YOU KNOW WHAT YOU'RE DOING)</flag>
- <flag name="wininst">Install required Windows executables to create an executable installer for MS Windows.</flag>
+ <flag name="threads">Enable threading support. (DON'T DISABLE THIS UNLESS YOU KNOW WHAT YOU'RE DOING)</flag>
+ <flag name="wide-unicode">Enable wide Unicode implementation which uses 4-byte Unicode characters. Switching of this USE flag changes ABI of Python and requires reinstallation of many Python modules. (DON'T DISABLE THIS UNLESS YOU KNOW WHAT YOU'RE DOING)</flag>
+ <flag name="wininst">Install Windows executables required to create an executable installer for MS Windows.</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 61b95222a825..44981d9d511e 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.23 2009/10/30 11:45:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.24 2009/12/06 17:50:22 arfrever Exp $
EAPI="1"
@@ -24,7 +24,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline ssl +threads tk ucs2 wininst +xml"
+IUSE="-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline ssl +threads tk +wide-unicode wininst +xml"
RDEPEND=">=app-admin/eselect-python-20090606
>=sys-libs/zlib-1.1.3
@@ -166,7 +166,7 @@ src_configure() {
--enable-shared \
$(use_enable ipv6) \
$(use_with threads) \
- $(use ucs2 && echo "--enable-unicode=ucs2" || echo "--enable-unicode=ucs4") \
+ $(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
--with-libc='' \
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index b19f081bff8c..8c679676428e 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.26 2009/10/30 11:45:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.27 2009/12/06 17:50:22 arfrever Exp $
EAPI="1"
@@ -24,7 +24,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.5"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk ucs2 wininst +xml"
+IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes}
# do not conflict with the ones in python proper. - liquidx
@@ -171,7 +171,7 @@ src_configure() {
--enable-shared \
$(use_enable ipv6) \
$(use_with threads) \
- $(use ucs2 && echo "--enable-unicode=ucs2" || echo "--enable-unicode=ucs4") \
+ $(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
--with-libc=''
diff --git a/dev-lang/python/python-2.6.2-r1.ebuild b/dev-lang/python/python-2.6.2-r1.ebuild
index f9865aa3fbdd..8f03d6b63abe 100644
--- a/dev-lang/python/python-2.6.2-r1.ebuild
+++ b/dev-lang/python/python-2.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r1.ebuild,v 1.19 2009/10/19 16:02:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r1.ebuild,v 1.20 2009/12/06 17:50:22 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -29,7 +29,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.6"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 ncurses readline sqlite ssl +threads tk ucs2 wininst +xml"
+IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 ncurses readline sqlite ssl +threads tk +wide-unicode wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes}
# do not conflict with the ones in python proper. - liquidx
@@ -147,9 +147,9 @@ src_configure() {
# Super-secret switch. Don't use this unless you know what you're
# doing. Enabling UCS2 support will break your existing python
# modules
- use ucs2 \
- && myconf="${myconf} --enable-unicode=ucs2" \
- || myconf="${myconf} --enable-unicode=ucs4"
+ use wide-unicode \
+ && myconf="${myconf} --enable-unicode=ucs4" \
+ || myconf="${myconf} --enable-unicode=ucs2"
filter-flags -malign-double
diff --git a/dev-lang/python/python-2.6.2-r2.ebuild b/dev-lang/python/python-2.6.2-r2.ebuild
index ef8115f8c17d..883373c24403 100644
--- a/dev-lang/python/python-2.6.2-r2.ebuild
+++ b/dev-lang/python/python-2.6.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r2.ebuild,v 1.11 2009/10/03 17:09:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r2.ebuild,v 1.12 2009/12/06 17:50:22 arfrever Exp $
EAPI="2"
@@ -24,7 +24,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.6"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk ucs2 wininst +xml"
+IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes}
# do not conflict with the ones in python proper. - liquidx
@@ -180,7 +180,7 @@ src_configure() {
--enable-shared \
$(use_enable ipv6) \
$(use_with threads) \
- $(use ucs2 && echo "--enable-unicode=ucs2" || echo "--enable-unicode=ucs4") \
+ $(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
--with-libc='' \
diff --git a/dev-lang/python/python-2.6.3.ebuild b/dev-lang/python/python-2.6.3.ebuild
index 33eda82398b6..f4a7f785dc5b 100644
--- a/dev-lang/python/python-2.6.3.ebuild
+++ b/dev-lang/python/python-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.3.ebuild,v 1.7 2009/10/24 14:35:31 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.3.ebuild,v 1.8 2009/12/06 17:50:22 arfrever Exp $
EAPI="2"
@@ -24,7 +24,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.6"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk ucs2 wininst +xml"
+IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes}
# do not conflict with the ones in python proper. - liquidx
@@ -184,7 +184,7 @@ src_configure() {
--enable-shared \
$(use_enable ipv6) \
$(use_with threads) \
- $(use ucs2 && echo "--enable-unicode=ucs2" || echo "--enable-unicode=ucs4") \
+ $(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
--with-libc='' \
diff --git a/dev-lang/python/python-2.6.4.ebuild b/dev-lang/python/python-2.6.4.ebuild
index 8ce9b1f6e5a9..8112e229092c 100644
--- a/dev-lang/python/python-2.6.4.ebuild
+++ b/dev-lang/python/python-2.6.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4.ebuild,v 1.4 2009/12/04 16:07:28 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4.ebuild,v 1.5 2009/12/06 17:50:22 arfrever Exp $
EAPI="2"
@@ -24,7 +24,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.6"
KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk ucs2 wininst +xml"
+IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
# NOTE: dev-python/{elementtree,celementtree,pysqlite,ctypes}
# do not conflict with the ones in python proper. - liquidx
@@ -182,7 +182,7 @@ src_configure() {
--enable-shared \
$(use_enable ipv6) \
$(use_with threads) \
- $(use ucs2 && echo "--enable-unicode=ucs2" || echo "--enable-unicode=ucs4") \
+ $(use wide-unicode && echo "--enable-unicode=ucs4" || echo "--enable-unicode=ucs2") \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
--with-libc='' \
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 5769d8bdb54a..9bf9bec1b253 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.18 2009/11/29 15:29:21 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.19 2009/12/06 17:50:22 arfrever Exp $
EAPI="2"
@@ -24,7 +24,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="3.1"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk ucs2 wininst +xml"
+IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +threads tk +wide-unicode wininst +xml"
RDEPEND=">=app-admin/eselect-python-20090606
>=sys-libs/zlib-1.1.3
@@ -158,7 +158,7 @@ src_configure() {
--enable-shared \
$(use_enable ipv6) \
$(use_with threads) \
- $(use_with !ucs2 wide-unicode) \
+ $(use_with wide-unicode) \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
--with-dbmliborder=${dbmliborder} \