summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2015-01-31 15:53:57 +0000
committerMikle Kolyada <zlogene@gentoo.org>2015-01-31 15:53:57 +0000
commit40a5ad967c4c0e765f8955fc4a22c9f5476cedb7 (patch)
tree03c517cecb01a1371df1032169d2bf56b71b4d94 /dev-lang
parentDrop old (diff)
downloadgentoo-2-40a5ad967c4c0e765f8955fc4a22c9f5476cedb7.tar.gz
gentoo-2-40a5ad967c4c0e765f8955fc4a22c9f5476cedb7.tar.bz2
gentoo-2-40a5ad967c4c0e765f8955fc4a22c9f5476cedb7.zip
Drop old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xC42EB5D6)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nqp/ChangeLog7
-rw-r--r--dev-lang/nqp/nqp-2014.07.ebuild61
-rw-r--r--dev-lang/nqp/nqp-2014.08.ebuild61
-rw-r--r--dev-lang/nqp/nqp-2014.09.ebuild61
-rw-r--r--dev-lang/nqp/nqp-2014.10.ebuild61
-rw-r--r--dev-lang/nqp/nqp-2014.11-r1.ebuild65
6 files changed, 6 insertions, 310 deletions
diff --git a/dev-lang/nqp/ChangeLog b/dev-lang/nqp/ChangeLog
index e517daa8b459..74080b7f6ee3 100644
--- a/dev-lang/nqp/ChangeLog
+++ b/dev-lang/nqp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nqp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.60 2015/01/26 04:14:32 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.61 2015/01/31 15:53:57 zlogene Exp $
+
+ 31 Jan 2015; Mikle Kolyada <zlogene@gentoo.org> -nqp-2014.07.ebuild,
+ -nqp-2014.08.ebuild, -nqp-2014.09.ebuild, -nqp-2014.10.ebuild,
+ -nqp-2014.11-r1.ebuild:
+ Drop old
26 Jan 2015; Patrick Lauer <patrick@gentoo.org> nqp-2014.12.ebuild,
nqp-2015.01.ebuild:
diff --git a/dev-lang/nqp/nqp-2014.07.ebuild b/dev-lang/nqp/nqp-2014.07.ebuild
deleted file mode 100644
index ffedcfae73e5..000000000000
--- a/dev-lang/nqp/nqp-2014.07.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.07.ebuild,v 1.2 2014/10/16 01:10:08 patrick Exp $
-
-EAPI=5
-
-inherit eutils multilib
-
-# hrm, doesn't look happy
-RESTRICT="test"
-
-GITCRAP=e4be039
-PARROT_VERSION="6.2.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( ~dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2014.08.ebuild b/dev-lang/nqp/nqp-2014.08.ebuild
deleted file mode 100644
index 7fb12f73d795..000000000000
--- a/dev-lang/nqp/nqp-2014.08.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.08.ebuild,v 1.1 2014/08/25 05:51:51 patrick Exp $
-
-EAPI=5
-
-inherit eutils multilib
-
-# hrm, doesn't look happy
-RESTRICT="test"
-
-GITCRAP=43fcd85
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2014.09.ebuild b/dev-lang/nqp/nqp-2014.09.ebuild
deleted file mode 100644
index 7630f18d1731..000000000000
--- a/dev-lang/nqp/nqp-2014.09.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.09.ebuild,v 1.1 2014/09/19 06:28:27 patrick Exp $
-
-EAPI=5
-
-inherit eutils multilib
-
-# hrm, doesn't look happy
-RESTRICT="test"
-
-GITCRAP=a09a4e9
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2014.10.ebuild b/dev-lang/nqp/nqp-2014.10.ebuild
deleted file mode 100644
index 7cb3cd562d11..000000000000
--- a/dev-lang/nqp/nqp-2014.10.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.10.ebuild,v 1.1 2014/10/25 03:13:27 patrick Exp $
-
-EAPI=5
-
-inherit eutils multilib
-
-# hrm, doesn't look happy
-RESTRICT="test"
-
-GITCRAP=e69a814
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}
diff --git a/dev-lang/nqp/nqp-2014.11-r1.ebuild b/dev-lang/nqp/nqp-2014.11-r1.ebuild
deleted file mode 100644
index ff23cbc05197..000000000000
--- a/dev-lang/nqp/nqp-2014.11-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.11-r1.ebuild,v 1.1 2014/11/25 04:10:34 patrick Exp $
-
-EAPI=5
-
-# still not working
-RESTRICT="test"
-
-inherit eutils multilib
-
-GITCRAP=b842b0d
-PARROT_VERSION="6.7.0"
-
-DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
-HOMEPAGE="http://rakudo.org/"
-SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="doc +parrot java moar"
-REQUIRED_USE="|| ( parrot java moar )"
-
-RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
- java? ( >=virtual/jre-1.7 )
- moar? ( =dev-lang/moarvm-${PV} )"
-DEPEND="${RDEPEND}
- java? ( >=virtual/jdk-1.7 )
- dev-lang/perl"
-
-S=${WORKDIR}/perl6-nqp-${GITCRAP}
-
-src_configure() {
- use java && myconf+="jvm,"
- use parrot && myconf+="parrot,"
- use moar && myconf+="moar,"
- perl Configure.pl --backend=${myconf} --prefix=/usr || die
- # dirty hack to make dyncall not fail
- sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
- sed -i -e 's/-Werror=missing-declarations//' Makefile || die
- sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
-
- # more dirty hack to allow building with newer gcc
- sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
- sed -i -e 's/-Werror=nested-externs//' Makefile || die
-}
-
-src_compile() {
- emake -j1 || die
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake DESTDIR="${ED}" install || die
-
- dodoc CREDITS README.pod || die
-
- if use doc; then
- dodoc -r docs/* || die
- fi
-}