summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-04 10:37:10 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-04 10:37:10 +0000
commit48d3998b1ef4f3c9713727d94d02013554197992 (patch)
treeea630f81e16fee08dadf0efc4bf9feb50a5c1c6c /dev-lang
parentarm/s390 stable (diff)
downloadgentoo-2-48d3998b1ef4f3c9713727d94d02013554197992.tar.gz
gentoo-2-48d3998b1ef4f3c9713727d94d02013554197992.tar.bz2
gentoo-2-48d3998b1ef4f3c9713727d94d02013554197992.zip
arm/s390/sh stable
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ruby-1.8.5-r2.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-lang/ruby/ruby-1.8.5-r2.ebuild b/dev-lang/ruby/ruby-1.8.5-r2.ebuild
index dd6679953e4a..28301b0e8071 100644
--- a/dev-lang/ruby/ruby-1.8.5-r2.ebuild
+++ b/dev-lang/ruby/ruby-1.8.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5-r2.ebuild,v 1.6 2006/10/20 21:00:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5-r2.ebuild,v 1.7 2006/11/04 10:37:10 vapier Exp $
ONIGURUMA="onigd2_5_4"
@@ -13,12 +13,11 @@ SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${P}.tar.gz
LICENSE="Ruby"
SLOT="1.8"
-KEYWORDS="alpha ~amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="alpha ~amd64 arm ~hppa ia64 ~mips ~ppc ~ppc-macos ~ppc64 s390 sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
IUSE="debug socks5 tk cjk doc threads examples ipv6"
RESTRICT="confcache"
-RDEPEND="virtual/libc
- >=sys-libs/gdbm-1.8.0
+RDEPEND=">=sys-libs/gdbm-1.8.0
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
socks5? ( >=net-proxy/dante-1.1.13 )
@@ -27,7 +26,6 @@ RDEPEND="virtual/libc
!=dev-lang/ruby-cvs-1.8*
!dev-ruby/rdoc
!dev-ruby/rexml"
-
DEPEND="${RDEPEND}"
PROVIDE="virtual/ruby"
@@ -59,7 +57,7 @@ src_compile() {
filter-flags -fomit-frame-pointer
# Socks support via dante
- if use socks5; then
+ if use socks5 ; then
# Socks support can't be disabled as long as SOCKS_SERVER is
# set and socks library is present, so need to unset
# SOCKS_SERVER in that case.
@@ -71,11 +69,6 @@ src_compile() {
append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
fi
- # On ia64 we need to build without optimization #48824
- if use ia64; then
- replace-flags '-O*' -O0
- fi
-
econf --program-suffix=${SLOT/./} --enable-shared \
$(use_enable socks5 socks) \
$(use_enable doc install-doc) \