summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-04-13 19:01:18 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-04-13 19:01:18 +0000
commit58b427cec9d665e7ec1c02f54a25a26a1fb22335 (patch)
tree5bcc8ff15d9c0bc54f78688e03c65fe3293d3503 /dev-lang
parentMove EAPI assignment to top of ebuild, bug 411875. (diff)
downloadgentoo-2-58b427cec9d665e7ec1c02f54a25a26a1fb22335.tar.gz
gentoo-2-58b427cec9d665e7ec1c02f54a25a26a1fb22335.tar.bz2
gentoo-2-58b427cec9d665e7ec1c02f54a25a26a1fb22335.zip
Disable parallel make due to build system failures: bug #409631 by Anton Kochkov, bug #409873 by Todd Goodman.
(Portage version: 2.2.0_alpha96_p5/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog7
-rw-r--r--dev-lang/ghc/ghc-6.10.4-r1.ebuild6
-rw-r--r--dev-lang/ghc/ghc-6.12.3-r2.ebuild4
-rw-r--r--dev-lang/ghc/ghc-6.12.3.ebuild6
-rw-r--r--dev-lang/ghc/ghc-7.4.1.ebuild5
5 files changed, 17 insertions, 11 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 79af65694cff..eeae8008734f 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.217 2012/04/04 18:21:27 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.218 2012/04/13 19:01:18 slyfox Exp $
+
+ 13 Apr 2012; Sergei Trofimovich <slyfox@gentoo.org> ghc-6.10.4-r1.ebuild,
+ ghc-6.12.3-r2.ebuild, ghc-6.12.3.ebuild, ghc-7.4.1.ebuild:
+ Disable parallel make due to build system failures: bug #409631 by Anton
+ Kochkov, bug #409873 by Todd Goodman.
04 Apr 2012; Sergei Trofimovich <slyfox@gentoo.org> ghc-6.12.3-r2.ebuild:
alpha/ia64/ppc/ppc64/sparc stable wrt bug #407835
diff --git a/dev-lang/ghc/ghc-6.10.4-r1.ebuild b/dev-lang/ghc/ghc-6.10.4-r1.ebuild
index eb0cd852b6f2..a34dc420a49b 100644
--- a/dev-lang/ghc/ghc-6.10.4-r1.ebuild
+++ b/dev-lang/ghc/ghc-6.10.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4-r1.ebuild,v 1.12 2010/11/06 20:28:25 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4-r1.ebuild,v 1.13 2012/04/13 19:01:18 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -279,7 +279,7 @@ src_compile() {
# LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
# bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
- LC_ALL=C emake all || die "make failed"
+ LC_ALL=C emake -j1 all || die "make failed"
fi # ! use binary
}
diff --git a/dev-lang/ghc/ghc-6.12.3-r2.ebuild b/dev-lang/ghc/ghc-6.12.3-r2.ebuild
index cb3a968a9c19..5d28f3f8ff12 100644
--- a/dev-lang/ghc/ghc-6.12.3-r2.ebuild
+++ b/dev-lang/ghc/ghc-6.12.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3-r2.ebuild,v 1.6 2012/04/04 18:21:27 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3-r2.ebuild,v 1.7 2012/04/13 19:01:18 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -459,7 +459,7 @@ src_compile() {
if ! use binary; then
# LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
# bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
- LC_ALL=C emake all || die "make failed"
+ LC_ALL=C emake -j1 all || die "make failed"
fi # ! use binary
}
diff --git a/dev-lang/ghc/ghc-6.12.3.ebuild b/dev-lang/ghc/ghc-6.12.3.ebuild
index ffaed03744c5..c959d816d6fd 100644
--- a/dev-lang/ghc/ghc-6.12.3.ebuild
+++ b/dev-lang/ghc/ghc-6.12.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3.ebuild,v 1.22 2011/07/05 18:30:32 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.12.3.ebuild,v 1.23 2012/04/13 19:01:18 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -313,7 +313,7 @@ src_compile() {
# LC_ALL needs to workaround ghc's ParseCmm failure on some (es) locales
# bug #202212 / http://hackage.haskell.org/trac/ghc/ticket/4207
- LC_ALL=C emake all || die "make failed"
+ LC_ALL=C emake -j1 all || die "make failed"
fi # ! use binary
}
diff --git a/dev-lang/ghc/ghc-7.4.1.ebuild b/dev-lang/ghc/ghc-7.4.1.ebuild
index e9dc1c56f3a1..dfca51ec41a9 100644
--- a/dev-lang/ghc/ghc-7.4.1.ebuild
+++ b/dev-lang/ghc/ghc-7.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.4.1.ebuild,v 1.3 2012/03/11 18:43:38 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-7.4.1.ebuild,v 1.4 2012/04/13 19:01:18 slyfox Exp $
# Brief explanation of the bootstrap logic:
#
@@ -470,7 +470,8 @@ src_configure() {
src_compile() {
if ! use binary; then
- emake all || die "make failed"
+ # ghc massively parallel make: #409631, #409873
+ emake -j1 all || die "make failed"
fi # ! use binary
}