summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-01-05 01:22:39 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-01-05 01:22:39 +0000
commit5cb3f33700734216c224b2d8b92503b111a0fab9 (patch)
tree3e5195574bd5509307cfafc8612c49499785f0a5 /dev-lang
parentCleanup debug useflag description, as in most cases it *doesn't* set the CFLA... (diff)
downloadgentoo-2-5cb3f33700734216c224b2d8b92503b111a0fab9.tar.gz
gentoo-2-5cb3f33700734216c224b2d8b92503b111a0fab9.tar.bz2
gentoo-2-5cb3f33700734216c224b2d8b92503b111a0fab9.zip
Bug 59328, features=noman support
(Portage version: 2.1.2_rc4-r3)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog7
-rw-r--r--dev-lang/perl/perl-5.8.8-r2.ebuild35
2 files changed, 32 insertions, 10 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index a874b7bc9cb4..ab528cbc4e2e 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/perl
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.234 2006/11/19 19:31:18 mcummings Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.235 2007/01/05 01:22:39 mcummings Exp $
+
+ 05 Jan 2007; Michael Cummings <mcummings@gentoo.org> perl-5.8.8-r2.ebuild:
+ Bug 59328, features=noman support
19 Nov 2006; Michael Cummings <mcummings@gentoo.org>
+files/perl-5.8.8-gcc42-command-line.patch, perl-5.8.8-r2.ebuild:
diff --git a/dev-lang/perl/perl-5.8.8-r2.ebuild b/dev-lang/perl/perl-5.8.8-r2.ebuild
index 3e7e14a8a8be..5683b205427b 100644
--- a/dev-lang/perl/perl-5.8.8-r2.ebuild
+++ b/dev-lang/perl/perl-5.8.8-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r2.ebuild,v 1.24 2006/11/19 19:31:18 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.8-r2.ebuild,v 1.25 2007/01/05 01:22:38 mcummings Exp $
inherit eutils flag-o-matic toolchain-funcs multilib
@@ -236,6 +236,31 @@ src_configure() {
myconf "-Dlibpth=/usr/local/$(get_libdir) /$(get_libdir) /usr/$(get_libdir)"
fi
+ if has noman ${FEATURES} ; then
+ myconf "-Dinstallman1dir='' \
+ -Dinstallman3dir='' \
+ -Dinstallsiteman1dir='' \
+ -Dinstallsiteman3dir='' \
+ -Dinstallvendorman1dir='' \
+ -Dinstallvendorman3dir='' \
+ -Dman1dir='' \
+ -Dman1direxp='' \
+ -Dman1ext='0' \
+ -Dman3dir='' \
+ -Dman3direxp='' \
+ -Dman3ext='0' \
+ -Dsiteman1dir='' \
+ -Dsiteman1direxp='' \
+ -Dsiteman3dir='' \
+ -Dsiteman3direxp='' \
+ -Dsysman='' \
+ -Dvendorman1dir='' \
+ -Dvendorman1direxp='' \
+ -Dvendorman3dir='' \
+ -Dvendorman3direxp=''
+ "
+ fi
+
sh Configure -des \
-Darchname="${myarch}" \
-Dcccdlflags='-fPIC' \
@@ -249,12 +274,6 @@ src_configure() {
-Duselargefiles \
-Dd_semctl_semun \
-Dscriptdir=/usr/bin \
- -Dman1dir=/usr/share/man/man1 \
- -Dman3dir=/usr/share/man/man3 \
- -Dinstallman1dir=/usr/share/man/man1 \
- -Dinstallman3dir=/usr/share/man/man3 \
- -Dman1ext='1' \
- -Dman3ext='3pm' \
-Dinc_version_list="$inclist" \
-Dcf_by='Gentoo' \
-Ud_csh \