summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-05-26 19:05:10 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-05-26 19:05:10 +0000
commit605a87ba24dba3ab29a75afa8ac4e94144f4befa (patch)
treeb72f5e2488e56792c6503080858a522f72dd77c0 /dev-lang
parent~amd64, dont install COPYING, quote directory variables (diff)
downloadgentoo-2-605a87ba24dba3ab29a75afa8ac4e94144f4befa.tar.gz
gentoo-2-605a87ba24dba3ab29a75afa8ac4e94144f4befa.tar.bz2
gentoo-2-605a87ba24dba3ab29a75afa8ac4e94144f4befa.zip
Add no-relax to LDFLAGS for alpha, and keyword latest version ~alpha
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.09.3-r1.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-3.10.0.ebuild7
3 files changed, 14 insertions, 4 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 8f1a0fb2c15f..e9a4a297fccb 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.114 2007/05/26 16:41:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.115 2007/05/26 19:05:10 armin76 Exp $
+
+ 26 May 2007; Raúl Porcel <armin76@gentoo.org> ocaml-3.09.3-r1.ebuild,
+ ocaml-3.10.0.ebuild:
+ Add no-relax to LDFLAGS for alpha, and keyword latest version ~alpha
26 May 2007; Raúl Porcel <armin76@gentoo.org> ocaml-3.09.3-r1.ebuild:
Readd ~alpha wrt #178256
diff --git a/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild b/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
index f20dab11efac..85c5388c4464 100644
--- a/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild,v 1.14 2007/05/26 16:41:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild,v 1.15 2007/05/26 19:05:10 armin76 Exp $
inherit flag-o-matic eutils multilib pax-utils versionator toolchain-funcs
@@ -80,6 +80,9 @@ src_compile() {
strip-flags
replace-flags "-O?" -O2
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
use tk || myconf="${myconf} -no-tk"
use ncurses || myconf="${myconf} -no-curses"
use X || myconf="${myconf} -no-graph"
diff --git a/dev-lang/ocaml/ocaml-3.10.0.ebuild b/dev-lang/ocaml/ocaml-3.10.0.ebuild
index 50c99105ce02..5dd3f612a63e 100644
--- a/dev-lang/ocaml/ocaml-3.10.0.ebuild
+++ b/dev-lang/ocaml/ocaml-3.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.0.ebuild,v 1.2 2007/05/26 13:36:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.10.0.ebuild,v 1.3 2007/05/26 19:05:10 armin76 Exp $
inherit flag-o-matic eutils multilib pax-utils versionator toolchain-funcs
@@ -10,7 +10,7 @@ SRC_URI="http://caml.inria.fr/distrib/ocaml-$( get_version_component_range 1-2)/
LICENSE="QPL-1.0 LGPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="gdbm ncurses tk latex X"
DEPEND="tk? ( >=dev-lang/tk-3.3.3 )
@@ -69,6 +69,9 @@ src_compile() {
strip-flags
replace-flags "-O?" -O2
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
use tk || myconf="${myconf} -no-tk"
use ncurses || myconf="${myconf} -no-curses"
use X || myconf="${myconf} -no-graph"