summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-06-13 19:31:06 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-06-13 19:31:06 +0000
commit66a3b62c829e29576cf36d528845c9af573a1711 (patch)
treed9f8f037378ffd2d6d6262ba98d0844f05ee5814 /dev-lang
parentStable on alpha, bug #222085 (diff)
downloadgentoo-2-66a3b62c829e29576cf36d528845c9af573a1711.tar.gz
gentoo-2-66a3b62c829e29576cf36d528845c9af573a1711.tar.bz2
gentoo-2-66a3b62c829e29576cf36d528845c9af573a1711.zip
fix build failure with Glibc 2.8, see bug 226063, patch provided by Holger Hoffstätte <holger AT wizards DOT de>
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/ChangeLog7
-rw-r--r--dev-lang/erlang/erlang-12.2.3.ebuild5
-rw-r--r--dev-lang/erlang/files/erlang-12.2.3-glibc28.patch11
3 files changed, 21 insertions, 2 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index adcbbef2e561..75ae319d073c 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.122 2008/06/12 20:59:48 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.123 2008/06/13 19:31:06 opfer Exp $
+
+ 13 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
+ +files/erlang-12.2.3-glibc28.patch, erlang-12.2.3.ebuild:
+ fix build failure with Glibc 2.8, see bug 226063, patch provided by Holger
+ Hoffstätte <holger AT wizards DOT de>
12 Jun 2008; Brent Baude <ranger@gentoo.org> erlang-12.2.3.ebuild:
Marking erlang-12.2.3 ~ppc64 for bug 226085
diff --git a/dev-lang/erlang/erlang-12.2.3.ebuild b/dev-lang/erlang/erlang-12.2.3.ebuild
index d1f248845574..f15c49786fd9 100644
--- a/dev-lang/erlang/erlang-12.2.3.ebuild
+++ b/dev-lang/erlang/erlang-12.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.3.ebuild,v 1.2 2008/06/12 20:59:48 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.3.ebuild,v 1.3 2008/06/13 19:31:06 opfer Exp $
inherit autotools elisp-common eutils flag-o-matic multilib versionator
@@ -47,6 +47,9 @@ src_unpack() {
use odbc || sed -i 's: odbc : :' lib/Makefile
+ # fixes bug 226063, reported and accepted upstream for R12B-4
+ epatch "${FILESDIR}"/${P}-glibc28.patch
+
# make sure we only link ssl dynamically
# will not be integrated by upstream for various reasons
sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
diff --git a/dev-lang/erlang/files/erlang-12.2.3-glibc28.patch b/dev-lang/erlang/files/erlang-12.2.3-glibc28.patch
new file mode 100644
index 000000000000..d13053a8bb03
--- /dev/null
+++ b/dev-lang/erlang/files/erlang-12.2.3-glibc28.patch
@@ -0,0 +1,11 @@
+--- erts/emulator/hipe/hipe_x86_signal.c 2008-06-12 14:17:48.831373565 +0200
++++ erts/emulator/hipe/hipe_x86_signal_ok.c 2008-06-12 14:43:05.132064804 +0200
+@@ -34,7 +34,7 @@
+ #endif
+ #include "hipe_signal.h"
+
+-#if __GLIBC__ == 2 && (__GLIBC_MINOR__ >= 3 && __GLIBC_MINOR__ <= 7)
++#if __GLIBC__ == 2 && __GLIBC_MINOR__ >= 3
+ /* See comment below for glibc 2.2. */
+ #ifndef __USE_GNU
+ #define __USE_GNU /* to un-hide RTLD_NEXT */