summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-03-17 15:56:08 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-03-17 15:56:08 +0000
commit769bc1c3740e205f9c918a9c80c9d596357c3858 (patch)
tree598da89974b855e50fd94c3394b919541b08554e /dev-lang
parentAdded admin to cherokee 0.6.x (diff)
downloadgentoo-2-769bc1c3740e205f9c918a9c80c9d596357c3858.tar.gz
gentoo-2-769bc1c3740e205f9c918a9c80c9d596357c3858.tar.bz2
gentoo-2-769bc1c3740e205f9c918a9c80c9d596357c3858.zip
Fix quoting
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gforth/ChangeLog6
-rw-r--r--dev-lang/gforth/gforth-0.6.2-r1.ebuild27
2 files changed, 18 insertions, 15 deletions
diff --git a/dev-lang/gforth/ChangeLog b/dev-lang/gforth/ChangeLog
index b38ee0149082..b747927f9397 100644
--- a/dev-lang/gforth/ChangeLog
+++ b/dev-lang/gforth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/gforth
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.23 2008/01/11 21:56:14 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/ChangeLog,v 1.24 2008/03/17 15:56:08 coldwind Exp $
+
+ 17 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
+ gforth-0.6.2-r1.ebuild:
+ Fix quoting.
11 Jan 2008; Fabian Groffen <grobian@gentoo.org> gforth-0.6.2.ebuild,
gforth-0.6.2-r1.ebuild:
diff --git a/dev-lang/gforth/gforth-0.6.2-r1.ebuild b/dev-lang/gforth/gforth-0.6.2-r1.ebuild
index 77c4008394b4..6f79e7675c68 100644
--- a/dev-lang/gforth/gforth-0.6.2-r1.ebuild
+++ b/dev-lang/gforth/gforth-0.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2-r1.ebuild,v 1.4 2008/01/11 21:56:14 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gforth/gforth-0.6.2-r1.ebuild,v 1.5 2008/03/17 15:56:08 coldwind Exp $
inherit elisp-common eutils toolchain-funcs flag-o-matic
@@ -11,8 +11,7 @@ SRC_URI="http://www.complang.tuwien.ac.at/forth/gforth/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-# KEYWORDS="~amd64 ~ppc ~x86"
-KEYWORDS="~ppc ~x86 ~x86-fbsd" # dev-libs/ffcall needs to be keyworded for amd64
+KEYWORDS="~ppc ~x86 ~x86-fbsd"
IUSE="emacs force-reg"
DEPEND="virtual/libc
@@ -39,11 +38,11 @@ EOF
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-ppc-configure-gentoo.patch # Bug #131931
- epatch ${FILESDIR}/gforth.el-gentoo.patch
- epatch ${FILESDIR}/${PV}-c-to-forth-to-c.patch
- epatch ${DISTDIR}/${PV}-debug.diff
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-ppc-configure-gentoo.patch # Bug #131931
+ epatch "${FILESDIR}"/gforth.el-gentoo.patch
+ epatch "${FILESDIR}"/${PV}-c-to-forth-to-c.patch
+ epatch "${DISTDIR}"/${PV}-debug.diff
}
@@ -62,18 +61,18 @@ src_compile() {
src_install() {
make \
- libdir=${D}/usr/lib \
- infodir=${D}/usr/share/info \
- mandir=${D}/usr/share/man \
- datadir=${D}/usr/share \
- bindir=${D}/usr/bin \
+ libdir="${D}"/usr/lib \
+ infodir="${D}"/usr/share/info \
+ mandir="${D}"/usr/share/man \
+ datadir="${D}"/usr/share \
+ bindir="${D}"/usr/bin \
install || die
dodoc AUTHORS BUGS ChangeLog NEWS* README* ToDo doc/glossaries.doc doc/*.ps
if use emacs; then
elisp-install ${PN} *.el *.elc
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
fi
}