summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-06-07 17:38:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-06-07 17:38:51 +0000
commit7e17ea468d8d96c3bd17cf952162ad93cd9a50fb (patch)
treeb8770006f759e3f00bd6dc05d184a2618dd8cd85 /dev-lang
parentxine-lib: fix CVE-2008-1878 (diff)
downloadgentoo-2-7e17ea468d8d96c3bd17cf952162ad93cd9a50fb.tar.gz
gentoo-2-7e17ea468d8d96c3bd17cf952162ad93cd9a50fb.tar.bz2
gentoo-2-7e17ea468d8d96c3bd17cf952162ad93cd9a50fb.zip
Tune up a bit ocaml-rebuild.sh so that it does not give syntax errors on non integer slots.
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/files/ocaml-rebuild.sh10
2 files changed, 7 insertions, 9 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 873889f18ded..0f218959f565 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.143 2008/06/07 16:08:46 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.144 2008/06/07 17:38:51 aballier Exp $
+
+ 07 Jun 2008; Alexis Ballier <aballier@gentoo.org> files/ocaml-rebuild.sh:
+ Tune up a bit ocaml-rebuild.sh so that it does not give syntax errors on
+ non integer slots.
07 Jun 2008; nixnut <nixnut@gentoo.org> ocaml-3.10.2.ebuild:
Stable on ppc wrt bug 224893
diff --git a/dev-lang/ocaml/files/ocaml-rebuild.sh b/dev-lang/ocaml/files/ocaml-rebuild.sh
index 9a81033e9201..d0fc233c046e 100644
--- a/dev-lang/ocaml/files/ocaml-rebuild.sh
+++ b/dev-lang/ocaml/files/ocaml-rebuild.sh
@@ -35,14 +35,8 @@ do
toclean="=$category/$pkg $toclean"
tocleanstr="\"$category/$pkg\" $tocleanstr"
- if [ $slot -eq 0 ]
- then
- tobuild=">=$category/$pkg $tobuild"
- tobuildstr="\">=$category/$pkg\" $tobuildstr"
- else
- tobuild="=$category/$pkg $tobuild"
- tobuildstr="\"=$category/$pkg\" $tobuildstr"
- fi
+ tobuild=">=$category/$pkg:$slot $tobuild"
+ tobuildstr="\">=$category/$pkg:$slot\" $tobuildstr"
done
echo Cleaning $tocleanstr