summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2012-09-25 10:38:32 +0000
committerGeorge Shapovalov <george@gentoo.org>2012-09-25 10:38:32 +0000
commit7eaf8439b2bb46c796f007cd2f5f59ae391bf61c (patch)
treeb9e1faea376025d477290e6bdb30f239d937e449 /dev-lang
parentVersion bump (bug #433938). (diff)
downloadgentoo-2-7eaf8439b2bb46c796f007cd2f5f59ae391bf61c.tar.gz
gentoo-2-7eaf8439b2bb46c796f007cd2f5f59ae391bf61c.tar.bz2
gentoo-2-7eaf8439b2bb46c796f007cd2f5f59ae391bf61c.zip
minor update
(Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog7
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.4.7.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index 240ab62f9a11..ea90a863ad61 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/gnat-gcc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.52 2012/03/02 15:52:24 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.53 2012/09/25 10:38:32 george Exp $
+
+*gnat-gcc-4.4.7 (25 Sep 2012)
+
+ 25 Sep 2012; george <george@gentoo.org> +gnat-gcc-4.4.7.ebuild:
+ minor update
02 Mar 2012; george <george@gentoo.org> Manifest:
adjusted Manifest to correct reuploaded bootstrap for amd64 (#372179)
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.4.7.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.4.7.ebuild
new file mode 100644
index 000000000000..9395bf239350
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.4.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.4.7.ebuild,v 1.1 2012/09/25 10:38:32 george Exp $
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE=""
+
+BOOT_SLOT="4.3"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${SLOT}-amd64.tar.bz2 )
+ sparc? ( http://dev.gentoo.org/~george/src/gnatboot-${SLOT}-sparc.tar.bz2 )
+ x86? ( http://dev.gentoo.org/~george/src/gnatboot-${SLOT}-i686.tar.bz2 )"
+# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+
+KEYWORDS="~amd64 ~x86 ~sparc"
+
+# starting with 4.3.0 gnat needs these libs
+RDEPEND=">=dev-libs/mpfr-3.0.1
+ >=dev-libs/gmp-5.0
+ >=sys-libs/zlib-1.2
+ >=sys-libs/ncurses-5.7"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.875
+ >=sys-libs/glibc-2.8
+ >=sys-devel/binutils-2.20"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+# ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # gcc pretty much ignores --with-system-zlib. At least it still descends
+ # into zlib and does configure and build there (gcc bug@7125?). For whatever
+ # reason this conflicts with multilib in gcc-4.4..
+ sed -i -e "s:libgui zlib:libgui:" "${S}"/configure
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}