summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-11-21 10:39:00 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-11-21 10:39:00 +0000
commit97859a8bceed5c88c8408e5b0aa9b5b2a67e68f1 (patch)
tree2dc6b79eb11c9dbc6c24bd57a1e0e86021b60e36 /dev-lang
parentInitial import (bug #432688). (diff)
downloadgentoo-2-97859a8bceed5c88c8408e5b0aa9b5b2a67e68f1.tar.gz
gentoo-2-97859a8bceed5c88c8408e5b0aa9b5b2a67e68f1.tar.bz2
gentoo-2-97859a8bceed5c88c8408e5b0aa9b5b2a67e68f1.zip
add system-llvm USE and make it default; remove rust-0.12.0-libdir.patch from nightly, as it was merged into upstream
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/ChangeLog7
-rw-r--r--dev-lang/rust/metadata.xml2
-rw-r--r--dev-lang/rust/rust-999-r1.ebuild9
-rw-r--r--dev-lang/rust/rust-9999-r3.ebuild11
4 files changed, 23 insertions, 6 deletions
diff --git a/dev-lang/rust/ChangeLog b/dev-lang/rust/ChangeLog
index 9444f21e5dbc..8a9ea8879e20 100644
--- a/dev-lang/rust/ChangeLog
+++ b/dev-lang/rust/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/rust
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.5 2014/10/18 12:48:43 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.6 2014/11/21 10:39:00 jauhien Exp $
+
+ 21 Nov 2014; Jauhien Piatlicki <jauhien@gentoo.org> metadata.xml,
+ rust-999-r1.ebuild, rust-9999-r3.ebuild:
+ add system-llvm USE and make it default; remove rust-0.12.0-libdir.patch from
+ nightly, as it was merged into upstream
*rust-0.12.0 (18 Oct 2014)
*rust-999-r1 (18 Oct 2014)
diff --git a/dev-lang/rust/metadata.xml b/dev-lang/rust/metadata.xml
index d84b0f6f3efc..8a67abaf200a 100644
--- a/dev-lang/rust/metadata.xml
+++ b/dev-lang/rust/metadata.xml
@@ -12,5 +12,7 @@
<flag name="clang">Use <pkg>sys-devel/clang</pkg> for building</flag>
<flag name="libcxx">Use <pkg>sys-libs/libcxx</pkg> as standard
library when building with <pkg>sys-devel/clang</pkg></flag>
+ <flag name="system-llvm">Use system <pkg>sys-devel/llvm</pkg> in
+ place of the bundled one</flag>
</use>
</pkgmetadata>
diff --git a/dev-lang/rust/rust-999-r1.ebuild b/dev-lang/rust/rust-999-r1.ebuild
index 27f7da3e1ea1..9def1dff2fda 100644
--- a/dev-lang/rust/rust-999-r1.ebuild
+++ b/dev-lang/rust/rust-999-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-999-r1.ebuild,v 1.1 2014/10/18 12:48:43 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-999-r1.ebuild,v 1.2 2014/11/21 10:39:00 jauhien Exp $
EAPI="5"
@@ -18,7 +18,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="nightly"
KEYWORDS=""
-IUSE="clang debug emacs libcxx vim-syntax zsh-completion"
+IUSE="clang debug emacs libcxx +system-llvm vim-syntax zsh-completion"
REQUIRED_USE="libcxx? ( clang )"
CDEPEND="libcxx? ( sys-libs/libcxx )
@@ -30,6 +30,7 @@ DEPEND="${CDEPEND}
>=dev-lang/perl-5.0
net-misc/wget
clang? ( sys-devel/clang )
+ system-llvm? ( >=sys-devel/llvm-3.5.0[multitarget(-)] )
"
RDEPEND="${CDEPEND}
emacs? ( >=app-emacs/rust-mode-${PV} )
@@ -60,6 +61,9 @@ src_prepare() {
}
src_configure() {
+ local system_llvm
+ use system-llvm && system_llvm="--llvm-root=${EPREFIX}/usr"
+
"${ECONF_SOURCE:-.}"/configure \
--prefix="${EPREFIX}/usr" \
--libdir="${EPREFIX}/usr/lib/${P}" \
@@ -72,6 +76,7 @@ src_configure() {
$(use_enable !debug optimize-llvm) \
$(use_enable !debug optimize-tests) \
$(use_enable libcxx libcpp) \
+ ${system_llvm} \
--disable-manage-submodules \
--disable-verify-install \
--disable-docs \
diff --git a/dev-lang/rust/rust-9999-r3.ebuild b/dev-lang/rust/rust-9999-r3.ebuild
index 7318d4e66573..696c27a2d6f8 100644
--- a/dev-lang/rust/rust-9999-r3.ebuild
+++ b/dev-lang/rust/rust-9999-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-9999-r3.ebuild,v 1.1 2014/10/18 12:48:43 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-9999-r3.ebuild,v 1.2 2014/11/21 10:39:00 jauhien Exp $
EAPI="5"
@@ -16,7 +16,7 @@ LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
SLOT="git"
KEYWORDS=""
-IUSE="clang debug emacs libcxx vim-syntax zsh-completion"
+IUSE="clang debug emacs libcxx +system-llvm vim-syntax zsh-completion"
REQUIRED_USE="libcxx? ( clang )"
CDEPEND="libcxx? ( sys-libs/libcxx )
@@ -27,6 +27,7 @@ DEPEND="${CDEPEND}
${PYTHON_DEPS}
>=dev-lang/perl-5.0
clang? ( sys-devel/clang )
+ system-llvm? ( >=sys-devel/llvm-3.5.0[multitarget(-)] )
"
RDEPEND="${CDEPEND}
emacs? ( >=app-emacs/rust-mode-${PV} )
@@ -47,13 +48,16 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}/${PN}-0.12.0-no-ldconfig.patch" "${FILESDIR}/${PN}-0.12.0-libdir.patch"
+ epatch "${FILESDIR}/${PN}-0.12.0-no-ldconfig.patch"
local postfix="gentoo-${SLOT}"
sed -i -e "s/CFG_FILENAME_EXTRA=.*/CFG_FILENAME_EXTRA=${postfix}/" mk/main.mk || die
}
src_configure() {
+ local system_llvm
+ use system-llvm && system_llvm="--llvm-root=${EPREFIX}/usr"
+
"${ECONF_SOURCE:-.}"/configure \
--prefix="${EPREFIX}/usr" \
--libdir="${EPREFIX}/usr/lib/${P}" \
@@ -66,6 +70,7 @@ src_configure() {
$(use_enable !debug optimize-llvm) \
$(use_enable !debug optimize-tests) \
$(use_enable libcxx libcpp) \
+ ${system_llvm} \
--disable-manage-submodules \
--disable-verify-install \
--disable-docs \