summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-08-01 08:16:10 +0000
committerZac Medico <zmedico@gentoo.org>2009-08-01 08:16:10 +0000
commita659e331899855150488fc05aac05ac0c1d666aa (patch)
treef26e7f48a15ea2fa686f0b15aa9b4b8f4a899644 /dev-lang
parentSync package.use.mask and 2007.0/package.use.mask wrt #253361. (diff)
downloadgentoo-2-a659e331899855150488fc05aac05ac0c1d666aa.tar.gz
gentoo-2-a659e331899855150488fc05aac05ac0c1d666aa.tar.bz2
gentoo-2-a659e331899855150488fc05aac05ac0c1d666aa.zip
Bug #248081 - Fix tests not to assume that stdin is a tty.
(Portage version: 2.2_rc33_p13863/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog5
-rw-r--r--dev-lang/python/python-2.6.2-r1.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 9fb043a2fc58..fb2f62fc4f0e 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.396 2009/07/31 14:03:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.397 2009/08/01 08:16:10 zmedico Exp $
+
+ 01 Aug 2009; Zac Medico <zmedico@gentoo.org> python-2.6.2-r1.ebuild:
+ Bug #248081 - Fix tests not to assume that stdin is a tty.
31 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-2.5.4-r3.ebuild, python-2.6.2-r1.ebuild:
diff --git a/dev-lang/python/python-2.6.2-r1.ebuild b/dev-lang/python/python-2.6.2-r1.ebuild
index 086d11045b84..e80bd27cdb88 100644
--- a/dev-lang/python/python-2.6.2-r1.ebuild
+++ b/dev-lang/python/python-2.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r1.ebuild,v 1.3 2009/07/31 14:03:29 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r1.ebuild,v 1.4 2009/08/01 08:16:10 zmedico Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -190,9 +190,13 @@ src_test() {
mv "${S}"/Lib/test/test_${test}.py "${T}"
done
- # Redirect stdin from /dev/tty as a workaround for bug #248081.
+ # Fix OtherFileTests.testStdin() not to assume
+ # that stdin is a tty for bug #248081.
+ sed -e "s:'osf1V5':'osf1V5' and sys.stdin.isatty():" \
+ -i "${S}"/Lib/test/test_file.py || die "sed failed"
+
# Rerun failed tests in verbose mode (regrtest -w).
- EXTRATESTOPTS="-w" make test < /dev/tty || die "make test failed"
+ EXTRATESTOPTS="-w" make test || die "make test failed"
for test in ${skip_tests}; do
mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py