summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-03-28 14:08:40 +0000
committerFabian Groffen <grobian@gentoo.org>2014-03-28 14:08:40 +0000
commita749d4f3f4fe1762b609d8846cb0460f423ba8e0 (patch)
tree19d79435b12ca31111cf0c0c85f091b1e7885231 /dev-lang
parentStable for HPPA (bug #506042). (diff)
downloadgentoo-2-a749d4f3f4fe1762b609d8846cb0460f423ba8e0.tar.gz
gentoo-2-a749d4f3f4fe1762b609d8846cb0460f423ba8e0.tar.bz2
gentoo-2-a749d4f3f4fe1762b609d8846cb0460f423ba8e0.zip
Fix for Prefix, marked ~x64-macos
(Portage version: 2.2.8-prefix/cvs/SunOS i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog6
-rw-r--r--dev-lang/go/go-1.2.ebuild10
-rw-r--r--dev-lang/go/go-9999.ebuild8
3 files changed, 14 insertions, 10 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 7453f049d8c2..e042ca756159 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.32 2014/02/11 17:57:09 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.33 2014/03/28 14:08:40 grobian Exp $
+
+ 28 Mar 2014; Fabian Groffen <grobian@gentoo.org> go-1.2.ebuild,
+ go-9999.ebuild:
+ Fix for Prefix, marked ~x64-macos
11 Feb 2014; William Hubbs <williamh@gentoo.org> go-1.2.ebuild,
go-9999.ebuild:
diff --git a/dev-lang/go/go-1.2.ebuild b/dev-lang/go/go-1.2.ebuild
index b5413899c43c..02f16cd45c91 100644
--- a/dev-lang/go/go-1.2.ebuild
+++ b/dev-lang/go/go-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.2.ebuild,v 1.6 2014/02/11 17:57:09 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.2.ebuild,v 1.7 2014/03/28 14:08:40 grobian Exp $
EAPI=5
@@ -14,7 +14,7 @@ if [[ ${PV} = 9999 ]]; then
else
SRC_URI="http://go.googlecode.com/files/go${PV}.src.tar.gz"
# Upstream only supports go on amd64, arm and x86 architectures.
- KEYWORDS="-* amd64 arm x86 ~amd64-fbsd ~x86-fbsd"
+ KEYWORDS="-* amd64 arm x86 ~amd64-fbsd ~x86-fbsd ~x64-macos"
fi
DESCRIPTION="A concurrent garbage collected and typesafe programming language"
@@ -51,7 +51,7 @@ src_prepare()
src_compile()
{
- export GOROOT_FINAL=/usr/lib/go
+ export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
export GOROOT="$(pwd)"
export GOBIN="${GOROOT}/bin"
if [[ $CTARGET = armv5* ]]
@@ -126,8 +126,8 @@ pkg_postinst()
# linker are also checked - so we need to fix them too.
ebegin "fixing timestamps to avoid unnecessary rebuilds"
tref="usr/lib/go/pkg/*/runtime.a"
- find "${ROOT}"usr/lib/go -type f \
- -exec touch -r "${ROOT}"${tref} {} \;
+ find "${EROOT}"usr/lib/go -type f \
+ -exec touch -r "${EROOT}"${tref} {} \;
eend $?
if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} &&
diff --git a/dev-lang/go/go-9999.ebuild b/dev-lang/go/go-9999.ebuild
index 9cb630ae13f2..eb6a8d9c69ef 100644
--- a/dev-lang/go/go-9999.ebuild
+++ b/dev-lang/go/go-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.15 2014/02/11 17:57:09 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-9999.ebuild,v 1.16 2014/03/28 14:08:40 grobian Exp $
EAPI=5
@@ -51,7 +51,7 @@ src_prepare()
src_compile()
{
- export GOROOT_FINAL=/usr/lib/go
+ export GOROOT_FINAL="${EPREFIX}"/usr/lib/go
export GOROOT="$(pwd)"
export GOBIN="${GOROOT}/bin"
if [[ $CTARGET = armv5* ]]
@@ -126,8 +126,8 @@ pkg_postinst()
# linker are also checked - so we need to fix them too.
ebegin "fixing timestamps to avoid unnecessary rebuilds"
tref="usr/lib/go/pkg/*/runtime.a"
- find "${ROOT}"usr/lib/go -type f \
- -exec touch -r "${ROOT}"${tref} {} \;
+ find "${EROOT}"usr/lib/go -type f \
+ -exec touch -r "${EROOT}"${tref} {} \;
eend $?
if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} &&