summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-12-31 16:34:35 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-12-31 16:34:35 +0000
commitacb43bb8c36dd6c99480b38ff265ced172e5ef8c (patch)
treef275ddd6afc7a7c5fb93e5902834c1dd435dc9f0 /dev-lang
parentCall python_pkg_setup(). Update call to sed. (diff)
downloadgentoo-2-acb43bb8c36dd6c99480b38ff265ced172e5ef8c.tar.gz
gentoo-2-acb43bb8c36dd6c99480b38ff265ced172e5ef8c.tar.bz2
gentoo-2-acb43bb8c36dd6c99480b38ff265ced172e5ef8c.zip
Fix build, bug #349794 by flameeyes. Used patch by Mike Gilbert <floppymaster@gmail.com>.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/files/v8-gentoo-bug-349794-r0.patch13
-rw-r--r--dev-lang/v8/v8-2.4.9.13.ebuild79
-rw-r--r--dev-lang/v8/v8-2.4.9.14.ebuild5
-rw-r--r--dev-lang/v8/v8-2.5.9.1.ebuild5
-rw-r--r--dev-lang/v8/v8-3.0.0.1.ebuild5
-rw-r--r--dev-lang/v8/v8-9999.ebuild5
7 files changed, 36 insertions, 84 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 4c88966393f1..0ff9b4236c90 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.19 2010/12/18 08:58:50 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.20 2010/12/31 16:34:35 phajdan.jr Exp $
+
+ 31 Dec 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-2.4.9.13.ebuild,
+ v8-2.4.9.14.ebuild, v8-2.5.9.1.ebuild, v8-3.0.0.1.ebuild, v8-9999.ebuild,
+ +files/v8-gentoo-bug-349794-r0.patch:
+ Fix build, bug #349794 by flameeyes. Used patch by Mike Gilbert
+ <floppymaster@gmail.com>.
*v8-3.0.0.1 (18 Dec 2010)
diff --git a/dev-lang/v8/files/v8-gentoo-bug-349794-r0.patch b/dev-lang/v8/files/v8-gentoo-bug-349794-r0.patch
new file mode 100644
index 000000000000..4da1b5a79606
--- /dev/null
+++ b/dev-lang/v8/files/v8-gentoo-bug-349794-r0.patch
@@ -0,0 +1,13 @@
+Index: SConstruct
+===================================================================
+--- SConstruct (revision 6120)
++++ SConstruct (working copy)
+@@ -32,7 +32,7 @@
+ from os.path import join, dirname, abspath
+ from types import DictType, StringTypes
+ root_dir = dirname(File('SConstruct').rfile().abspath)
+-sys.path.append(join(root_dir, 'tools'))
++sys.path.insert(0, join(root_dir, 'tools'))
+ import js2c, utils
+
+ # ANDROID_TOP is the top of the Android checkout, fetched from the environment
diff --git a/dev-lang/v8/v8-2.4.9.13.ebuild b/dev-lang/v8/v8-2.4.9.13.ebuild
deleted file mode 100644
index b8628a56de23..000000000000
--- a/dev-lang/v8/v8-2.4.9.13.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.13.ebuild,v 1.1 2010/11/12 11:41:39 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}
diff --git a/dev-lang/v8/v8-2.4.9.14.ebuild b/dev-lang/v8/v8-2.4.9.14.ebuild
index 695b3da5f661..3e81add6fc9c 100644
--- a/dev-lang/v8/v8-2.4.9.14.ebuild
+++ b/dev-lang/v8/v8-2.4.9.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.14.ebuild,v 1.1 2010/12/10 17:08:38 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.14.ebuild,v 1.2 2010/12/31 16:34:35 phajdan.jr Exp $
EAPI="2"
@@ -34,6 +34,9 @@ src_prepare() {
# Respect the user's CFLAGS, including the optimization level.
epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
+ # Fix a compile error (bug #349794), to be upstreamed.
+ epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
+
# Remove a test that is known to fail:
# http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
rm test/mjsunit/debug-script.js || die
diff --git a/dev-lang/v8/v8-2.5.9.1.ebuild b/dev-lang/v8/v8-2.5.9.1.ebuild
index 477f72a3c1b8..71a138f30367 100644
--- a/dev-lang/v8/v8-2.5.9.1.ebuild
+++ b/dev-lang/v8/v8-2.5.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.9.1.ebuild,v 1.1 2010/12/02 10:09:16 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.9.1.ebuild,v 1.2 2010/12/31 16:34:35 phajdan.jr Exp $
EAPI="2"
@@ -34,6 +34,9 @@ src_prepare() {
# Respect the user's CFLAGS, including the optimization level.
epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
+ # Fix a compile error (bug #349794), to be upstreamed.
+ epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
+
# Remove a test that is known to fail:
# http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
rm test/mjsunit/debug-script.js || die
diff --git a/dev-lang/v8/v8-3.0.0.1.ebuild b/dev-lang/v8/v8-3.0.0.1.ebuild
index c6d31c17f89d..d89ab7e8160e 100644
--- a/dev-lang/v8/v8-3.0.0.1.ebuild
+++ b/dev-lang/v8/v8-3.0.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.0.1.ebuild,v 1.1 2010/12/18 08:58:50 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.0.1.ebuild,v 1.2 2010/12/31 16:34:35 phajdan.jr Exp $
EAPI="2"
@@ -34,6 +34,9 @@ src_prepare() {
# Respect the user's CFLAGS, including the optimization level.
epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
+ # Fix a compile error (bug #349794), to be upstreamed.
+ epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
+
# Remove a test that is known to fail:
# http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
rm test/mjsunit/debug-script.js || die
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
index 306e6f8e74df..98cdc75b7a3e 100644
--- a/dev-lang/v8/v8-9999.ebuild
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.1 2010/12/14 15:54:38 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.2 2010/12/31 16:34:35 phajdan.jr Exp $
EAPI="2"
@@ -34,6 +34,9 @@ src_prepare() {
# Respect the user's CFLAGS, including the optimization level.
epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
+ # Fix a compile error (bug #349794), to be upstreamed.
+ epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
+
# Remove a test that is known to fail:
# http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
rm test/mjsunit/debug-script.js || die