summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2008-06-09 17:55:03 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2008-06-09 17:55:03 +0000
commitadd767f5a6836ca5508740de2c314e3f6591330a (patch)
tree3925c5e948a2e9266f3c577a2b72202217f9cfab /dev-lang
parentNew Version (diff)
downloadgentoo-2-add767f5a6836ca5508740de2c314e3f6591330a.tar.gz
gentoo-2-add767f5a6836ca5508740de2c314e3f6591330a.tar.bz2
gentoo-2-add767f5a6836ca5508740de2c314e3f6591330a.zip
Adding new version. Solving bug #196984
(Portage version: 2.1.5.3)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/squeak/ChangeLog9
-rw-r--r--dev-lang/squeak/squeak-3.10.ebuild62
2 files changed, 69 insertions, 2 deletions
diff --git a/dev-lang/squeak/ChangeLog b/dev-lang/squeak/ChangeLog
index 0aae3c16fea9..acac76370388 100644
--- a/dev-lang/squeak/ChangeLog
+++ b/dev-lang/squeak/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/squeak
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/ChangeLog,v 1.25 2007/07/22 08:43:03 graaff Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/ChangeLog,v 1.26 2008/06/09 17:55:03 araujo Exp $
+
+*squeak-3.10 (09 Jun 2008)
+
+ 09 Jun 2008; Luis F. Araujo <araujo@gentoo.org> +squeak-3.10.ebuild:
+ Adding new version. Solving bug #196984
22 Jul 2007; Hans de Graaff <graaff@gentoo.org> squeak-3.4.1-r2.ebuild,
squeak-3.6_p3.ebuild, squeak-3.7.7-r1.ebuild, squeak-3.9.7.ebuild:
diff --git a/dev-lang/squeak/squeak-3.10.ebuild b/dev-lang/squeak/squeak-3.10.ebuild
new file mode 100644
index 000000000000..fd18309af5f0
--- /dev/null
+++ b/dev-lang/squeak/squeak-3.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.10.ebuild,v 1.1 2008/06/09 17:55:03 araujo Exp $
+
+inherit base fixheadtails eutils
+
+MY_PV="${PV}-1"
+
+DESCRIPTION="Highly-portable Smalltalk-80 implementation"
+HOMEPAGE="http://www.squeak.org/"
+SRC_URI="http://ftp.squeak.org/${PV}/unix-linux/Squeak-${MY_PV}.src.tar.gz "
+LICENSE="Apple"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X mmx threads iconv opengl"
+
+DEPEND="X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXt )
+ opengl? ( virtual/opengl )"
+RDEPEND="${DEPEND}
+ virtual/squeak-image"
+
+S="${WORKDIR}/Squeak-${MY_PV}"
+
+src_unpack() {
+ base_src_unpack
+ cd "${S}"
+ ht_fix_all
+ einfo "Patch for inisqueak"
+ sed -i s/\${MAJOR}/39/ "${S}/platforms/unix/config/inisqueak.in"
+ # ht_fix_all doesn't catch this because there's no number
+ sed -i -e 's/tail +/tail -n +/' platforms/unix/config/inisqueak.in
+}
+
+src_compile() {
+ local myconf=""
+ use X || myconf="--without-x --without-npsqueak"
+ use mmx && myconf="${myconf} --enable-mpg-mmx"
+ use threads && myconf="${myconf} --enable-mpg-pthread"
+ use opengl || myconf="${myconf} --without-gl"
+ use iconv || myconf="${myconf} --disable-iconv"
+ cd "${S}"
+ mkdir build
+ cd build
+ ../platforms/unix/config/configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ cd "${S}/build"
+ make ROOT="${D}" docdir="/usr/share/doc/${PF}" install || die
+ exeinto /usr/lib/squeak
+ doexe inisqueak
+ dosym /usr/lib/squeak/inisqueak /usr/bin/inisqueak
+}
+
+pkg_postinst() {
+ elog "Run 'inisqueak' to get a private copy of the squeak image."
+}