summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-08 09:35:06 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-08 09:35:06 +0000
commitb831ebdb68d995889f82758f4384245e95ae3031 (patch)
tree3a83e7e88d5b1b4e220a2b89c9b7d55cfcccc226 /dev-lang
parentMake repoman more happy (diff)
downloadgentoo-2-b831ebdb68d995889f82758f4384245e95ae3031.tar.gz
gentoo-2-b831ebdb68d995889f82758f4384245e95ae3031.tar.bz2
gentoo-2-b831ebdb68d995889f82758f4384245e95ae3031.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/closure-compiler-bin/ChangeLog11
-rw-r--r--dev-lang/closure-compiler-bin/closure-compiler-bin-20121212.ebuild30
2 files changed, 38 insertions, 3 deletions
diff --git a/dev-lang/closure-compiler-bin/ChangeLog b/dev-lang/closure-compiler-bin/ChangeLog
index 1cdc73ec5859..016a3037dd0b 100644
--- a/dev-lang/closure-compiler-bin/ChangeLog
+++ b/dev-lang/closure-compiler-bin/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-lang/closure-compiler-bin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/closure-compiler-bin/ChangeLog,v 1.1 2012/04/18 15:43:04 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/closure-compiler-bin/ChangeLog,v 1.2 2013/02/08 09:35:06 patrick Exp $
+
+*closure-compiler-bin-20121212 (08 Feb 2013)
+
+ 08 Feb 2013; Patrick Lauer <patrick@gentoo.org>
+ +closure-compiler-bin-20121212.ebuild:
+ Bump
*closure-compiler-bin-20120305 (18 Apr 2012)
18 Apr 2012; Mike Frysinger <vapier@gentoo.org>
+closure-compiler-bin-20120305.ebuild, +metadata.xml:
Initial ebuild for ChromiumOS.
-
diff --git a/dev-lang/closure-compiler-bin/closure-compiler-bin-20121212.ebuild b/dev-lang/closure-compiler-bin/closure-compiler-bin-20121212.ebuild
new file mode 100644
index 000000000000..774507b6ea4a
--- /dev/null
+++ b/dev-lang/closure-compiler-bin/closure-compiler-bin-20121212.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/closure-compiler-bin/closure-compiler-bin-20121212.ebuild,v 1.1 2013/02/08 09:35:06 patrick Exp $
+
+EAPI="4"
+
+inherit java-pkg-2
+
+DESCRIPTION="JavaScript optimizing compiler"
+HOMEPAGE="http://code.google.com/p/closure-compiler/"
+SRC_URI="http://closure-compiler.googlecode.com/files/compiler-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+
+S=${WORKDIR}
+
+src_install() {
+ java-pkg_jarinto /opt/${PN}-${SLOT}/lib
+ java-pkg_newjar compiler.jar ${PN}.jar
+ java-pkg_dolauncher \
+ ${PN%-bin} \
+ --jar /opt/${PN}-${SLOT}/lib/${PN}.jar \
+ -into /opt
+ dodoc README
+}