summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-03-16 16:18:48 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-03-16 16:18:48 +0000
commitd99a4cc86f17a3a516ebe1ac576195041b1ea7f3 (patch)
treeb7985ce835a23b160dab7c6c8f4845afa2ff2ce1 /dev-lang
parentFix doc useflag handling. (diff)
downloadgentoo-2-d99a4cc86f17a3a516ebe1ac576195041b1ea7f3.tar.gz
gentoo-2-d99a4cc86f17a3a516ebe1ac576195041b1ea7f3.tar.bz2
gentoo-2-d99a4cc86f17a3a516ebe1ac576195041b1ea7f3.zip
Version bump for dev channel release. Remove old.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-2.5.9.15.ebuild92
-rw-r--r--dev-lang/v8/v8-3.0.12.29.ebuild90
-rw-r--r--dev-lang/v8/v8-3.1.8.1.ebuild (renamed from dev-lang/v8/v8-3.1.6.1.ebuild)2
4 files changed, 8 insertions, 184 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 9fa0ca3c9da1..024093d30fa1 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.46 2011/03/12 13:13:10 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.47 2011/03/16 16:18:48 phajdan.jr Exp $
+
+*v8-3.1.8.1 (16 Mar 2011)
+
+ 16 Mar 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-2.5.9.15.ebuild,
+ -v8-3.0.12.29.ebuild, -v8-3.1.6.1.ebuild, +v8-3.1.8.1.ebuild:
+ Version bump for dev channel release. Remove old.
12 Mar 2011; Christian Faulhammer <fauli@gentoo.org> v8-3.0.12.30.ebuild:
stable x86, security bug 357963
diff --git a/dev-lang/v8/v8-2.5.9.15.ebuild b/dev-lang/v8/v8-2.5.9.15.ebuild
deleted file mode 100644
index 904b511295ec..000000000000
--- a/dev-lang/v8/v8-2.5.9.15.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.9.15.ebuild,v 1.1 2011/02/10 10:08:11 voyageur Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Fix a compile error (bug #349794), to be upstreamed.
- epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
-
- # Backport an upstream bugfix for symbol visibility,
- # see bug #348609.
- epatch "${FILESDIR}"/${PN}-upstream-bug-1016-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf+=" arch=arm"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}
diff --git a/dev-lang/v8/v8-3.0.12.29.ebuild b/dev-lang/v8/v8-3.0.12.29.ebuild
deleted file mode 100644
index b0a696b74cb5..000000000000
--- a/dev-lang/v8/v8-3.0.12.29.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.12.29.ebuild,v 1.1 2011/03/03 11:15:59 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-# To make tests work, we compile with sample=shell.
-# For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
-EXTRA_ESCONS="library=shared soname=on sample=shell importenv=\"LINKFLAGS\""
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf+=" arch=arm"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- # Make sure we use the libv8.so from our build directory,
- # and not the /usr/lib one (it may be missing if we are
- # installing for the first time or upgrading), see bug #352374.
- LD_LIBRARY_PATH="${S}" tools/test.py --no-build -p dots || die
-}
diff --git a/dev-lang/v8/v8-3.1.6.1.ebuild b/dev-lang/v8/v8-3.1.8.1.ebuild
index 34f726d3d55f..18b4c3fe8cac 100644
--- a/dev-lang/v8/v8-3.1.6.1.ebuild
+++ b/dev-lang/v8/v8-3.1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.1.6.1.ebuild,v 1.1 2011/03/01 14:41:00 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.1.8.1.ebuild,v 1.1 2011/03/16 16:18:48 phajdan.jr Exp $
EAPI="2"