summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-10-16 23:43:46 +0000
committerMike Gilbert <floppym@gentoo.org>2013-10-16 23:43:46 +0000
commite15ec4604a606259051dbc7ecdfd2fbd7e862ecb (patch)
tree50fcf9dc78e2cf2726c4ab05a4f1bf09a286ee6f /dev-lang
parentpyzor: fix python 2.6/2.7 deprecation warnings (diff)
downloadgentoo-2-e15ec4604a606259051dbc7ecdfd2fbd7e862ecb.tar.gz
gentoo-2-e15ec4604a606259051dbc7ecdfd2fbd7e862ecb.tar.bz2
gentoo-2-e15ec4604a606259051dbc7ecdfd2fbd7e862ecb.zip
Apply upstream fix for regression in Tkinter, bug 488208 by jlec.
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog11
-rw-r--r--dev-lang/python/files/python-2.7-issue16248.patch19
-rw-r--r--dev-lang/python/files/python-3.2-issue16248.patch19
-rw-r--r--dev-lang/python/python-2.7.5-r3.ebuild (renamed from dev-lang/python/python-2.7.5-r2.ebuild)3
-rw-r--r--dev-lang/python/python-3.2.5-r3.ebuild (renamed from dev-lang/python/python-3.2.5-r2.ebuild)3
5 files changed, 52 insertions, 3 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index ef979d7f9fde..2f35f98335f8 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.709 2013/10/10 08:06:30 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.710 2013/10/16 23:43:45 floppym Exp $
+
+*python-2.7.5-r3 (16 Oct 2013)
+*python-3.2.5-r3 (16 Oct 2013)
+
+ 16 Oct 2013; Mike Gilbert <floppym@gentoo.org>
+ +files/python-2.7-issue16248.patch, +files/python-3.2-issue16248.patch,
+ +python-2.7.5-r3.ebuild, +python-3.2.5-r3.ebuild, -python-2.7.5-r2.ebuild,
+ -python-3.2.5-r2.ebuild:
+ Apply upstream fix for regression in Tkinter, bug 488208 by jlec.
10 Oct 2013; Dirkjan Ochtman <djc@gentoo.org> -files/python-3.2.3-x32.patch,
-python-2.6.8-r1.ebuild, -python-2.6.8-r2.ebuild, -python-2.7.3-r2.ebuild,
diff --git a/dev-lang/python/files/python-2.7-issue16248.patch b/dev-lang/python/files/python-2.7-issue16248.patch
new file mode 100644
index 000000000000..ce9c654c565f
--- /dev/null
+++ b/dev-lang/python/files/python-2.7-issue16248.patch
@@ -0,0 +1,19 @@
+# HG changeset patch
+# User Antoine Pitrou <solipsis@pitrou.net>
+# Date 1375388712 -7200
+# Node ID 0f17aed78168e63ec058c219d03cea7240f83dd6
+# Parent bb546f6d8ab4f513804d7a420657963881e5b447
+Fix tkinter regression introduced by the security fix in #16248.
+
+diff --git a/Lib/lib-tk/Tkinter.py b/Lib/lib-tk/Tkinter.py
+--- a/Lib/lib-tk/Tkinter.py
++++ b/Lib/lib-tk/Tkinter.py
+@@ -1736,7 +1736,7 @@ class Tk(Misc, Wm):
+ # ensure that self.tk is always _something_.
+ self.tk = None
+ if baseName is None:
+- import sys, os
++ import os
+ baseName = os.path.basename(sys.argv[0])
+ baseName, ext = os.path.splitext(baseName)
+ if ext not in ('.py', '.pyc', '.pyo'):
diff --git a/dev-lang/python/files/python-3.2-issue16248.patch b/dev-lang/python/files/python-3.2-issue16248.patch
new file mode 100644
index 000000000000..d0e80cae7283
--- /dev/null
+++ b/dev-lang/python/files/python-3.2-issue16248.patch
@@ -0,0 +1,19 @@
+# HG changeset patch
+# User Georg Brandl <georg@python.org>
+# Date 1379142489 -7200
+# Node ID c18c18774e240377d47638fb23e8276c1ac2e606
+# Parent b9b521efeba385af0142988899a55de1c1c805c7
+Fix tkinter regression introduced by the security fix in #16248.
+
+diff --git a/Lib/tkinter/__init__.py b/Lib/tkinter/__init__.py
+--- a/Lib/tkinter/__init__.py
++++ b/Lib/tkinter/__init__.py
+@@ -1722,7 +1722,7 @@ class Tk(Misc, Wm):
+ # ensure that self.tk is always _something_.
+ self.tk = None
+ if baseName is None:
+- import sys, os
++ import os
+ baseName = os.path.basename(sys.argv[0])
+ baseName, ext = os.path.splitext(baseName)
+ if ext not in ('.py', '.pyc', '.pyo'):
diff --git a/dev-lang/python/python-2.7.5-r2.ebuild b/dev-lang/python/python-2.7.5-r3.ebuild
index ee85ac8b0bc6..cb7a81582145 100644
--- a/dev-lang/python/python-2.7.5-r2.ebuild
+++ b/dev-lang/python/python-2.7.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r2.ebuild,v 1.14 2013/09/26 19:17:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.5-r3.ebuild,v 1.1 2013/10/16 23:43:45 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -99,6 +99,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-library-path.patch" #474882
epatch "${FILESDIR}/${P}-re_unsigned_ptrdiff.patch" #476426
epatch "${FILESDIR}/CVE-2013-4238_py27.patch"
+ epatch "${FILESDIR}/python-2.7-issue16248.patch"
# Fix for cross-compiling.
epatch "${FILESDIR}/python-2.7.5-nonfatal-compileall.patch"
diff --git a/dev-lang/python/python-3.2.5-r2.ebuild b/dev-lang/python/python-3.2.5-r3.ebuild
index 077ade46cea7..87f51cae0010 100644
--- a/dev-lang/python/python-3.2.5-r2.ebuild
+++ b/dev-lang/python/python-3.2.5-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.5-r2.ebuild,v 1.13 2013/08/28 15:59:25 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.2.5-r3.ebuild,v 1.1 2013/10/16 23:43:45 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -79,6 +79,7 @@ src_prepare() {
epatch "${FILESDIR}/python-3.2-CVE-2013-2099.patch"
epatch "${FILESDIR}/CVE-2013-4238_py33.patch"
+ epatch "${FILESDIR}/python-3.2-issue16248.patch"
sed -i -e "s:@@GENTOO_LIBDIR@@:$(get_libdir):g" \
Lib/distutils/command/install.py \