summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-18 22:05:59 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-07-18 22:05:59 +0000
commitffabb164cbcfe296221f4a506d19ffe27bdbcdae (patch)
treebdb55847cdd2f46277fb792d7420904033a890da /dev-lang
parentcleaning out 1.998 Conflicted commit. OpenSSH is masked, still (diff)
downloadgentoo-2-ffabb164cbcfe296221f4a506d19ffe27bdbcdae.tar.gz
gentoo-2-ffabb164cbcfe296221f4a506d19ffe27bdbcdae.tar.bz2
gentoo-2-ffabb164cbcfe296221f4a506d19ffe27bdbcdae.zip
Clean 2.0.1 ; not finished
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/clean/ChangeLog38
-rw-r--r--dev-lang/clean/clean-2.0.1.ebuild45
-rw-r--r--dev-lang/clean/files/digest-clean-2.0.12
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-lang/clean/ChangeLog b/dev-lang/clean/ChangeLog
new file mode 100644
index 000000000000..f4bbcbe50a45
--- /dev/null
+++ b/dev-lang/clean/ChangeLog
@@ -0,0 +1,38 @@
+# ChangeLog for dev-lang/clean
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/clean/ChangeLog,v 1.1 2002/07/18 22:05:59 karltk Exp $
+
+*clean-2.0.1 (18 Jul 2002)
+
+ 18 Jul 2002; Karl Trygve Kalleberg <karltk@gentoo.org> clean-2.0.1.ebuild files/digest-clean-2.0.1 :
+
+ From the home page:
+
+ "
+ A Functional Programming Language like Clean is based on the concept
+ of mathematical functions. Clean is a pure functional language, there
+ is not such a thing as an assignment. This has a big advantage: a
+ function cannot have a side-effect. A Clean function is referential
+ transparent: the result of a function only depends on the value of
+ the function arguments and on nothing else.
+
+ This has important consequences:
+ o Once a function is working, it will always work. A functionwill
+ always react in the same way, regardless when and in which context
+ the function is used;
+ o One can reason about Clean functions and the Clean program as a
+ whole (which is a function application) by using traditional
+ mathematical reasoning: uniform substitution and mathematical
+ induction.
+
+ For making real world applications one needs of course to be able to
+ update a database, perform I/O, update an array destructively, pass a
+ message to another program. And, the application should run
+ efficiently enough. Although Clean does not have assignments, objects
+ can be updated destructively. Clean is the only functional language in
+ the world which has a special type system, uniqueness typing. This
+ type system is developed in Nijmegen. It enables to update function
+ arguments destructively retaining the purity of the language.
+ "
+
+ Initial import.
diff --git a/dev-lang/clean/clean-2.0.1.ebuild b/dev-lang/clean/clean-2.0.1.ebuild
new file mode 100644
index 000000000000..1bdaa956e766
--- /dev/null
+++ b/dev-lang/clean/clean-2.0.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/clean/clean-2.0.1.ebuild,v 1.1 2002/07/18 22:05:59 karltk Exp $
+
+DESCRIPTION="Clean"
+HOMEPAGE="http://foo.bar.com"
+SRC_URI="http://www.cs.kun.nl/~clean/download/Clean20/linux/Clean2.0.1.tar.gz http://www.cs.kun.nl/~clean/download/Clean20/source/Clean${PV}Sources.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/Clean 2.0.1 Sources"
+
+src_unpack() {
+ unpack Clean2.0.1.tar.gz
+ unpack Clean${PV}Sources.tar.gz
+
+ cd clean ; make
+}
+
+src_compile() {
+ cd "${S}"
+ export PATH=$PATH:${WORKDIR}/clean/bin
+ cd CleanTools/clm ; make -f Makefile.linux || die ; cd -
+ cd CodeGenerator ; make -f Makefile.linux || die ; cd -
+ cd Compiler ; sh make.linux.sh || die ; cd -
+}
+
+src_install () {
+ cd "${S}"
+
+ dodir /usr/share/clean/exe
+ exeinto /usr/share/clean/exe
+ doexe Compiler/cocl
+ doexe CodeGenerator/cg
+
+ dodir /usr/bin
+ dobin CleanTools/clm/clm
+
+ dodir /usr/share/clean/iolib
+ insinto /usr/share/clean/iolib
+
+ dodoc "Clean2.0.1LicenseConditions.txt"
+}
diff --git a/dev-lang/clean/files/digest-clean-2.0.1 b/dev-lang/clean/files/digest-clean-2.0.1
new file mode 100644
index 000000000000..95f1750690df
--- /dev/null
+++ b/dev-lang/clean/files/digest-clean-2.0.1
@@ -0,0 +1,2 @@
+MD5 649cd093a492df300c9aabf503127652 Clean2.0.1.tar.gz 2364424
+MD5 ae30bf5523d3012e945d3af4c3e24c9c Clean2.0.1Sources.tar.gz 3535423