summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-11-16 12:43:49 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-11-16 12:43:49 +0000
commit87a0cad3b51f15f1ee940a0b93526784f6194e9a (patch)
tree27853b3be4e5c227e2d1c48cd45a6c819e7b9313 /dev-libs/Ice/files
parentstable ppc ppc64, bug #441318 (diff)
downloadgentoo-2-87a0cad3b51f15f1ee940a0b93526784f6194e9a.tar.gz
gentoo-2-87a0cad3b51f15f1ee940a0b93526784f6194e9a.tar.bz2
gentoo-2-87a0cad3b51f15f1ee940a0b93526784f6194e9a.zip
Removed old versions
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'dev-libs/Ice/files')
-rw-r--r--dev-libs/Ice/files/Ice-3.2.0-Makefile.patch113
-rw-r--r--dev-libs/Ice/files/Ice-3.2.1-Makefile.patch113
-rw-r--r--dev-libs/Ice/files/Ice-3.2.1-gcc43.patch275
-rw-r--r--dev-libs/Ice/files/Ice-3.3.1-Makefile.patch68
-rw-r--r--dev-libs/Ice/files/Ice-3.3.1-openssl.patch12
5 files changed, 0 insertions, 581 deletions
diff --git a/dev-libs/Ice/files/Ice-3.2.0-Makefile.patch b/dev-libs/Ice/files/Ice-3.2.0-Makefile.patch
deleted file mode 100644
index d7df955c196c..000000000000
--- a/dev-libs/Ice/files/Ice-3.2.0-Makefile.patch
+++ /dev/null
@@ -1,113 +0,0 @@
---- config/Make.rules.orig 2007-03-13 09:07:05.000000000 -0400
-+++ config/Make.rules 2007-03-13 09:07:13.000000000 -0400
-@@ -11,13 +11,13 @@
- # Select an installation base directory. The directory will be created
- # if it does not exist.
- #
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /$(DESTDIR)/usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with
-@@ -125,9 +125,10 @@
- install_bindir = $(prefix)/bin
-
- install_includedir = $(prefix)/include
--install_slicedir = $(prefix)/slice
--install_schemadir = $(prefix)/schema
--install_docdir = $(prefix)/doc
-+install_slicedir = $(prefix)/share/Ice/slice
-+install_schemadir = $(prefix)/share/Ice/schema
-+install_configdir = $(prefix)/share/Ice/config
-+install_docdir = $(prefix)/share/doc/Ice-$(VERSION)
-
- INSTALL = cp -fp
- INSTALL_PROGRAM = ${INSTALL}
-@@ -179,18 +180,8 @@
- BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
- BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
-
--ifneq ($(DB_HOME),)
-- DB_FLAGS = -I$(DB_HOME)/include
-- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
-- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
--else
-- ifeq ($(shell if [ -d /usr/include/db45 -a -d /usr/$(libsubdir)/db45 ] ; then echo yes; fi), yes)
-- DB_FLAGS = -I/usr/include/db45
-- DB_LIBS = -L/usr/$(libsubdir)/db45 -ldb_cxx
-- else
-- DB_LIBS = -ldb_cxx
-- endif
--endif
-+DB_FLAGS = -I/usr/include/db4.5
-+DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.5
-
- EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
- EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
---- Makefile.orig 2007-03-13 09:07:20.000000000 -0400
-+++ Makefile 2007-03-13 09:08:44.000000000 -0400
-@@ -11,15 +11,15 @@
-
- include $(top_srcdir)/config/Make.rules
-
--SUBDIRS = config src include test demo slice doc
-+SUBDIRS = config src include slice doc
-
--INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
-+INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir) $(install_configdir)
-
- install::
- @if test ! -d $(prefix) ; \
- then \
- echo "Creating $(prefix)..." ; \
-- $(call mkdir,$(prefix)) ; \
-+ mkdir -p $(prefix) ; \
- fi
- ifneq ($(embedded_runpath_prefix),)
- @if test -h $(embedded_runpath_prefix) ; \
-@@ -55,8 +55,8 @@
- then \
- ( cd doc && $(MAKE) install ) || exit 1 ; \
- fi
-- $(call installdata,ICE_LICENSE,$(prefix))
-- $(call installdata,LICENSE,$(prefix))
-+ $(call installdata,ICE_LICENSE,$(install_docdir))
-+ $(call installdata,LICENSE,$(install_docdir))
-
- clean::
- @if test -d doc ; \
-@@ -65,4 +65,5 @@
- fi
-
- test::
-+ @( cd test && $(MAKE) ) || exit 1
- @python $(top_srcdir)/allTests.py
---- config/Makefile.orig 2007-03-13 10:05:05.000000000 -0400
-+++ config/Makefile 2007-03-13 10:05:43.000000000 -0400
-@@ -15,14 +15,9 @@
- echo ""
-
- install::
-- @if test ! -d $(prefix)/config ; \
-- then \
-- echo "Creating $(prefix)/config..." ; \
-- $(call mkdir,$(prefix)/config) ; \
-- fi
-- $(call installdata,templates.xml,$(prefix)/config)
-- $(call installdata,convertssl.py,$(prefix)/config)
-- $(call installdata,upgradeicegrid.py,$(prefix)/config)
-- $(call installdata,upgradeicestorm.py,$(prefix)/config)
-- $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/config)
-+ $(call installdata,templates.xml,$(install_configdir))
-+ $(call installdata,convertssl.py,$(install_configdir))
-+ $(call installdata,upgradeicegrid.py,$(install_configdir))
-+ $(call installdata,upgradeicestorm.py,$(install_configdir))
-+ $(call installdata,icegrid-slice.3.1.ice.gz,$(install_configdir))
-
diff --git a/dev-libs/Ice/files/Ice-3.2.1-Makefile.patch b/dev-libs/Ice/files/Ice-3.2.1-Makefile.patch
deleted file mode 100644
index d7df955c196c..000000000000
--- a/dev-libs/Ice/files/Ice-3.2.1-Makefile.patch
+++ /dev/null
@@ -1,113 +0,0 @@
---- config/Make.rules.orig 2007-03-13 09:07:05.000000000 -0400
-+++ config/Make.rules 2007-03-13 09:07:13.000000000 -0400
-@@ -11,13 +11,13 @@
- # Select an installation base directory. The directory will be created
- # if it does not exist.
- #
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /$(DESTDIR)/usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with
-@@ -125,9 +125,10 @@
- install_bindir = $(prefix)/bin
-
- install_includedir = $(prefix)/include
--install_slicedir = $(prefix)/slice
--install_schemadir = $(prefix)/schema
--install_docdir = $(prefix)/doc
-+install_slicedir = $(prefix)/share/Ice/slice
-+install_schemadir = $(prefix)/share/Ice/schema
-+install_configdir = $(prefix)/share/Ice/config
-+install_docdir = $(prefix)/share/doc/Ice-$(VERSION)
-
- INSTALL = cp -fp
- INSTALL_PROGRAM = ${INSTALL}
-@@ -179,18 +180,8 @@
- BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
- BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
-
--ifneq ($(DB_HOME),)
-- DB_FLAGS = -I$(DB_HOME)/include
-- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
-- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
--else
-- ifeq ($(shell if [ -d /usr/include/db45 -a -d /usr/$(libsubdir)/db45 ] ; then echo yes; fi), yes)
-- DB_FLAGS = -I/usr/include/db45
-- DB_LIBS = -L/usr/$(libsubdir)/db45 -ldb_cxx
-- else
-- DB_LIBS = -ldb_cxx
-- endif
--endif
-+DB_FLAGS = -I/usr/include/db4.5
-+DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.5
-
- EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
- EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
---- Makefile.orig 2007-03-13 09:07:20.000000000 -0400
-+++ Makefile 2007-03-13 09:08:44.000000000 -0400
-@@ -11,15 +11,15 @@
-
- include $(top_srcdir)/config/Make.rules
-
--SUBDIRS = config src include test demo slice doc
-+SUBDIRS = config src include slice doc
-
--INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
-+INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir) $(install_configdir)
-
- install::
- @if test ! -d $(prefix) ; \
- then \
- echo "Creating $(prefix)..." ; \
-- $(call mkdir,$(prefix)) ; \
-+ mkdir -p $(prefix) ; \
- fi
- ifneq ($(embedded_runpath_prefix),)
- @if test -h $(embedded_runpath_prefix) ; \
-@@ -55,8 +55,8 @@
- then \
- ( cd doc && $(MAKE) install ) || exit 1 ; \
- fi
-- $(call installdata,ICE_LICENSE,$(prefix))
-- $(call installdata,LICENSE,$(prefix))
-+ $(call installdata,ICE_LICENSE,$(install_docdir))
-+ $(call installdata,LICENSE,$(install_docdir))
-
- clean::
- @if test -d doc ; \
-@@ -65,4 +65,5 @@
- fi
-
- test::
-+ @( cd test && $(MAKE) ) || exit 1
- @python $(top_srcdir)/allTests.py
---- config/Makefile.orig 2007-03-13 10:05:05.000000000 -0400
-+++ config/Makefile 2007-03-13 10:05:43.000000000 -0400
-@@ -15,14 +15,9 @@
- echo ""
-
- install::
-- @if test ! -d $(prefix)/config ; \
-- then \
-- echo "Creating $(prefix)/config..." ; \
-- $(call mkdir,$(prefix)/config) ; \
-- fi
-- $(call installdata,templates.xml,$(prefix)/config)
-- $(call installdata,convertssl.py,$(prefix)/config)
-- $(call installdata,upgradeicegrid.py,$(prefix)/config)
-- $(call installdata,upgradeicestorm.py,$(prefix)/config)
-- $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/config)
-+ $(call installdata,templates.xml,$(install_configdir))
-+ $(call installdata,convertssl.py,$(install_configdir))
-+ $(call installdata,upgradeicegrid.py,$(install_configdir))
-+ $(call installdata,upgradeicestorm.py,$(install_configdir))
-+ $(call installdata,icegrid-slice.3.1.ice.gz,$(install_configdir))
-
diff --git a/dev-libs/Ice/files/Ice-3.2.1-gcc43.patch b/dev-libs/Ice/files/Ice-3.2.1-gcc43.patch
deleted file mode 100644
index fc1488b1e2db..000000000000
--- a/dev-libs/Ice/files/Ice-3.2.1-gcc43.patch
+++ /dev/null
@@ -1,275 +0,0 @@
-diff -ur Ice-3.2.1.orig/include/Ice/Outgoing.h Ice-3.2.1/include/Ice/Outgoing.h
---- Ice-3.2.1.orig/include/Ice/Outgoing.h 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/include/Ice/Outgoing.h 2008-02-22 15:24:56.000000000 +0100
-@@ -16,6 +16,7 @@
- #include <Ice/ReferenceF.h>
- #include <Ice/BasicStream.h>
- #include <Ice/Current.h>
-+#include <memory>
-
- namespace Ice
- {
-diff -ur Ice-3.2.1.orig/src/FreezeScript/AssignVisitor.cpp Ice-3.2.1/src/FreezeScript/AssignVisitor.cpp
---- Ice-3.2.1.orig/src/FreezeScript/AssignVisitor.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/FreezeScript/AssignVisitor.cpp 2008-02-22 15:26:34.000000000 +0100
-@@ -9,6 +9,7 @@
-
- #include <FreezeScript/AssignVisitor.h>
- #include <FreezeScript/Util.h>
-+#include <climits>
-
- using namespace std;
-
-diff -ur Ice-3.2.1.orig/src/FreezeScript/Data.cpp Ice-3.2.1/src/FreezeScript/Data.cpp
---- Ice-3.2.1.orig/src/FreezeScript/Data.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/FreezeScript/Data.cpp 2008-02-22 15:26:21.000000000 +0100
-@@ -12,6 +12,7 @@
- #include <FreezeScript/Util.h>
- #include <FreezeScript/Exception.h>
- #include <IceUtil/InputUtil.h>
-+#include <climits>
-
- using namespace std;
- using namespace IceUtil;
-diff -ur Ice-3.2.1.orig/src/FreezeScript/DumpDescriptors.cpp Ice-3.2.1/src/FreezeScript/DumpDescriptors.cpp
---- Ice-3.2.1.orig/src/FreezeScript/DumpDescriptors.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/FreezeScript/DumpDescriptors.cpp 2008-02-22 15:26:26.000000000 +0100
-@@ -15,6 +15,7 @@
- #include <FreezeScript/Util.h>
- #include <db_cxx.h>
- #include <set>
-+#include <climits>
-
- using namespace std;
-
-diff -ur Ice-3.2.1.orig/src/FreezeScript/Transformer.cpp Ice-3.2.1/src/FreezeScript/Transformer.cpp
---- Ice-3.2.1.orig/src/FreezeScript/Transformer.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/FreezeScript/Transformer.cpp 2008-02-22 15:26:16.000000000 +0100
-@@ -19,6 +19,7 @@
- #include <Freeze/Initialize.h>
- #include <IceXML/Parser.h>
- #include <db_cxx.h>
-+#include <climits>
-
- using namespace std;
-
-diff -ur Ice-3.2.1.orig/src/Ice/ConnectionI.h Ice-3.2.1/src/Ice/ConnectionI.h
---- Ice-3.2.1.orig/src/Ice/ConnectionI.h 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/Ice/ConnectionI.h 2008-02-22 15:24:56.000000000 +0100
-@@ -26,6 +26,7 @@
- #include <Ice/TraceLevelsF.h>
- #include <Ice/OutgoingAsyncF.h>
- #include <Ice/EventHandler.h>
-+#include <memory>
-
- namespace IceInternal
- {
-diff -ur Ice-3.2.1.orig/src/IceGrid/Activator.cpp Ice-3.2.1/src/IceGrid/Activator.cpp
---- Ice-3.2.1.orig/src/IceGrid/Activator.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/IceGrid/Activator.cpp 2008-02-22 15:27:13.000000000 +0100
-@@ -22,6 +22,7 @@
- #include <sys/types.h>
- #include <sys/stat.h>
- #include <fcntl.h>
-+#include <climits>
-
- #ifndef _WIN32
- # include <sys/wait.h>
-diff -ur Ice-3.2.1.orig/src/IceGrid/PlatformInfo.cpp Ice-3.2.1/src/IceGrid/PlatformInfo.cpp
---- Ice-3.2.1.orig/src/IceGrid/PlatformInfo.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/IceGrid/PlatformInfo.cpp 2008-02-22 15:27:05.000000000 +0100
-@@ -17,6 +17,7 @@
- #include <IceGrid/TraceLevels.h>
-
- #include <IcePatch2/Util.h>
-+#include <climits>
-
- #if defined(_WIN32)
- # include <direct.h> // For _getcwd
-diff -ur Ice-3.2.1.orig/src/IcePatch2/OS.cpp Ice-3.2.1/src/IcePatch2/OS.cpp
---- Ice-3.2.1.orig/src/IcePatch2/OS.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/IcePatch2/OS.cpp 2008-02-22 15:26:56.000000000 +0100
-@@ -10,6 +10,7 @@
- #include <IceUtil/DisableWarnings.h>
- #include <OS.h>
- #include <IceUtil/Unicode.h>
-+#include <climits>
-
- #ifdef __BCPLUSPLUS__
- # include <dir.h>
-diff -ur Ice-3.2.1.orig/src/IceUtil/ArgVector.cpp Ice-3.2.1/src/IceUtil/ArgVector.cpp
---- Ice-3.2.1.orig/src/IceUtil/ArgVector.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/IceUtil/ArgVector.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -9,6 +9,7 @@
-
- #include <IceUtil/ArgVector.h>
- #include <IceUtil/DisableWarnings.h>
-+#include <cstring>
-
- IceUtil::ArgVector::ArgVector(int argc, char *argv[])
- {
-diff -ur Ice-3.2.1.orig/src/IceUtil/MD5.cpp Ice-3.2.1/src/IceUtil/MD5.cpp
---- Ice-3.2.1.orig/src/IceUtil/MD5.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/IceUtil/MD5.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -9,6 +9,7 @@
-
- #include <IceUtil/MD5.h>
- #include <IceUtil/MD5I.h>
-+#include <cstring>
-
- using namespace std;
-
-diff -ur Ice-3.2.1.orig/src/IceUtil/OutputUtil.cpp Ice-3.2.1/src/IceUtil/OutputUtil.cpp
---- Ice-3.2.1.orig/src/IceUtil/OutputUtil.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/IceUtil/OutputUtil.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -8,6 +8,7 @@
- // **********************************************************************
-
- #include <IceUtil/OutputUtil.h>
-+#include <cstring>
-
- using namespace std;
- using namespace IceUtil;
-diff -ur Ice-3.2.1.orig/src/IceUtil/Random.cpp Ice-3.2.1/src/IceUtil/Random.cpp
---- Ice-3.2.1.orig/src/IceUtil/Random.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/IceUtil/Random.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -9,6 +9,7 @@
-
- #include <IceUtil/Random.h>
- #include <IceUtil/StaticMutex.h>
-+#include <cstring>
-
- #ifdef _WIN32
- # include <Wincrypt.h>
-diff -ur Ice-3.2.1.orig/src/IceUtil/ThreadException.cpp Ice-3.2.1/src/IceUtil/ThreadException.cpp
---- Ice-3.2.1.orig/src/IceUtil/ThreadException.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/IceUtil/ThreadException.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -8,6 +8,7 @@
- // **********************************************************************
-
- #include <IceUtil/ThreadException.h>
-+#include <cstring>
-
- using namespace std;
-
-diff -ur Ice-3.2.1.orig/src/Slice/CPlusPlusUtil.cpp Ice-3.2.1/src/Slice/CPlusPlusUtil.cpp
---- Ice-3.2.1.orig/src/Slice/CPlusPlusUtil.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/Slice/CPlusPlusUtil.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -8,6 +8,7 @@
- // **********************************************************************
-
- #include <Slice/CPlusPlusUtil.h>
-+#include <cstring>
-
- using namespace std;
- using namespace Slice;
-diff -ur Ice-3.2.1.orig/src/Slice/DotNetNames.cpp Ice-3.2.1/src/Slice/DotNetNames.cpp
---- Ice-3.2.1.orig/src/Slice/DotNetNames.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/Slice/DotNetNames.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -9,6 +9,7 @@
-
- #include <Slice/DotNetNames.h>
- #include <ctype.h>
-+#include <cstring>
-
- using namespace std;
-
-diff -ur Ice-3.2.1.orig/src/Slice/Grammar.cpp Ice-3.2.1/src/Slice/Grammar.cpp
---- Ice-3.2.1.orig/src/Slice/Grammar.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/Slice/Grammar.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -165,6 +165,7 @@
-
- #include <Slice/GrammarUtil.h>
- #include <IceUtil/UUID.h>
-+#include <cstring>
-
- #ifdef _MSC_VER
- // I get these warnings from some bison versions:
-diff -ur Ice-3.2.1.orig/src/Slice/Grammar.y Ice-3.2.1/src/Slice/Grammar.y
---- Ice-3.2.1.orig/src/Slice/Grammar.y 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/Slice/Grammar.y 2008-02-22 15:24:56.000000000 +0100
-@@ -11,6 +11,7 @@
-
- #include <Slice/GrammarUtil.h>
- #include <IceUtil/UUID.h>
-+#include <cstring>
-
- #ifdef _MSC_VER
- // I get these warnings from some bison versions:
-diff -ur Ice-3.2.1.orig/src/Slice/Parser.cpp Ice-3.2.1/src/Slice/Parser.cpp
---- Ice-3.2.1.orig/src/Slice/Parser.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/Slice/Parser.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -10,6 +10,7 @@
- #include <IceUtil/Functional.h>
- #include <Slice/Parser.h>
- #include <Slice/GrammarUtil.h>
-+#include <cstring>
- #ifdef __BCPLUSPLUS__
- # include <iterator>
- #endif
-diff -ur Ice-3.2.1.orig/src/Slice/Preprocessor.cpp Ice-3.2.1/src/Slice/Preprocessor.cpp
---- Ice-3.2.1.orig/src/Slice/Preprocessor.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/Slice/Preprocessor.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -11,6 +11,7 @@
- #include <IceUtil/StringUtil.h>
- #include <algorithm>
- #include <fstream>
-+#include <cstring>
- #include <sys/types.h>
- #include <sys/stat.h>
-
-diff -ur Ice-3.2.1.orig/src/Slice/PythonUtil.cpp Ice-3.2.1/src/Slice/PythonUtil.cpp
---- Ice-3.2.1.orig/src/Slice/PythonUtil.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/Slice/PythonUtil.cpp 2008-02-22 15:25:32.000000000 +0100
-@@ -13,6 +13,7 @@
- #ifdef __BCPLUSPLUS__
- # include <iterator>
- #endif
-+#include <climits>
-
- using namespace std;
- using namespace Slice;
-diff -ur Ice-3.2.1.orig/src/slice2docbook/Gen.cpp Ice-3.2.1/src/slice2docbook/Gen.cpp
---- Ice-3.2.1.orig/src/slice2docbook/Gen.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/slice2docbook/Gen.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -10,6 +10,7 @@
- #include <IceUtil/DisableWarnings.h>
- #include <IceUtil/Functional.h>
- #include <Gen.h>
-+#include <cstring>
-
- #ifdef __BCPLUSPLUS__
- # include <iterator>
-diff -ur Ice-3.2.1.orig/src/slice2freeze/Main.cpp Ice-3.2.1/src/slice2freeze/Main.cpp
---- Ice-3.2.1.orig/src/slice2freeze/Main.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/slice2freeze/Main.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -12,6 +12,7 @@
- #include <Slice/Preprocessor.h>
- #include <Slice/CPlusPlusUtil.h>
- #include <IceUtil/OutputUtil.h>
-+#include <cstring>
-
- using namespace std;
- using namespace IceUtil;
-diff -ur Ice-3.2.1.orig/src/slice2java/Gen.cpp Ice-3.2.1/src/slice2java/Gen.cpp
---- Ice-3.2.1.orig/src/slice2java/Gen.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/slice2java/Gen.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -15,6 +15,7 @@
- #include <IceUtil/Iterator.h>
-
- #include <limits>
-+#include <cstring>
-
- using namespace std;
- using namespace Slice;
-diff -ur Ice-3.2.1.orig/src/slice2py/Main.cpp Ice-3.2.1/src/slice2py/Main.cpp
---- Ice-3.2.1.orig/src/slice2py/Main.cpp 2008-02-22 15:24:43.000000000 +0100
-+++ Ice-3.2.1/src/slice2py/Main.cpp 2008-02-22 15:24:56.000000000 +0100
-@@ -13,6 +13,7 @@
- #include <Slice/PythonUtil.h>
-
- #include <fstream>
-+#include <cstring>
-
- #include <sys/types.h>
- #include <sys/stat.h>
diff --git a/dev-libs/Ice/files/Ice-3.3.1-Makefile.patch b/dev-libs/Ice/files/Ice-3.3.1-Makefile.patch
deleted file mode 100644
index ceeaab4fd48e..000000000000
--- a/dev-libs/Ice/files/Ice-3.3.1-Makefile.patch
+++ /dev/null
@@ -1,68 +0,0 @@
---- config/Make.rules.orig 2008-05-21 13:39:46.000000000 -0400
-+++ config/Make.rules 2008-05-21 13:43:35.000000000 -0400
-@@ -11,13 +11,13 @@
- # Select an installation base directory. The directory will be created
- # if it does not exist.
- #
--prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= /$(DESTDIR)/usr
-
- #
- # The "root directory" for runpath embedded in executables. Can be unset
- # to avoid adding a runpath to Ice executables.
- #
--embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-+#embedded_runpath_prefix ?= /opt/Ice-$(VERSION_MAJOR).$(VERSION_MINOR)
-
- #
- # Define OPTIMIZE as yes if you want to build with
-@@ -144,10 +144,10 @@
- include $(top_srcdir)/config/Make.rules.$(UNAME)
-
- install_includedir := $(prefix)/include
--install_docdir := $(prefix)/doc
-+install_docdir := $(prefix)/share/doc/Ice-$(VERSION)
- install_bindir := $(prefix)/$(binsubdir)
- install_libdir := $(prefix)/$(libsubdir)
--install_configdir := $(prefix)/config
-+install_configdir := $(prefix)/share/Ice/config
-
- ifneq ($(embedded_runpath_prefix),)
- runpath_libdir := $(embedded_runpath_prefix)/$(libsubdir)
-@@ -162,18 +162,8 @@
- BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
- BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
-
--ifneq ($(DB_HOME),)
-- DB_FLAGS = -I$(DB_HOME)/include
-- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
-- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
--else
-- ifeq ($(shell if [ -d /usr/include/db46 -a -d /usr/$(libsubdir)/db46 ] ; then echo yes; fi), yes)
-- DB_FLAGS = -I/usr/include/db46
-- DB_LIBS = -L/usr/$(libsubdir)/db46 -ldb_cxx
-- else
-- DB_LIBS = -ldb_cxx
-- endif
--endif
-+DB_FLAGS = -I/usr/include/db4.6
-+DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.6
-
- EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
- EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
---- Makefile.orig 2008-05-21 13:42:32.000000000 -0400
-+++ Makefile 2008-05-21 13:42:50.000000000 -0400
-@@ -11,11 +11,11 @@
-
- include $(top_srcdir)/config/Make.rules
-
--SUBDIRS = config src include test demo
-+SUBDIRS = config src include
-
- INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_configdir)
-
--install:: install-common
-+install::
- @for subdir in $(INSTALL_SUBDIRS); \
- do \
- if test ! -d $$subdir ; \
diff --git a/dev-libs/Ice/files/Ice-3.3.1-openssl.patch b/dev-libs/Ice/files/Ice-3.3.1-openssl.patch
deleted file mode 100644
index 28ba3babfccf..000000000000
--- a/dev-libs/Ice/files/Ice-3.3.1-openssl.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur Ice-3.3.1-orig/cpp/src/IceSSL/Instance.cpp Ice-3.3.1/cpp/src/IceSSL/Instance.cpp
---- Ice-3.3.1-orig/cpp/src/IceSSL/Instance.cpp 2009-03-20 19:52:14.000000000 +0200
-+++ Ice-3.3.1/cpp/src/IceSSL/Instance.cpp 2010-06-04 16:02:16.779755389 +0300
-@@ -989,7 +989,7 @@
- {
- Trace out(_logger, _securityTraceCategory);
- out << "SSL summary for " << (incoming ? "incoming" : "outgoing") << " connection\n";
-- SSL_CIPHER* cipher = SSL_get_current_cipher(ssl);
-+ const SSL_CIPHER* cipher = SSL_get_current_cipher(ssl);
- if(!cipher)
- {
- out << "unknown cipher\n";