summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-10-08 09:06:41 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-10-08 09:06:41 +0000
commitad9a8158f5582f6287bb254e0270d4ac9d479334 (patch)
tree4e15a1b7a24d121ca36d76f33ce5be4a1b04e9b4 /dev-libs/ace/ace-5.5-r1.ebuild
parentstable on ppc64 (diff)
downloadgentoo-2-ad9a8158f5582f6287bb254e0270d4ac9d479334.tar.gz
gentoo-2-ad9a8158f5582f6287bb254e0270d4ac9d479334.tar.bz2
gentoo-2-ad9a8158f5582f6287bb254e0270d4ac9d479334.zip
fix memory exhaustion on compile - bug #192768. Fix bad defines bug #192676 thanks Alin N?stac. added get_libdir and warning thanks Donnie. removed ace-5.5.8 because it was old.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-libs/ace/ace-5.5-r1.ebuild')
-rw-r--r--dev-libs/ace/ace-5.5-r1.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/dev-libs/ace/ace-5.5-r1.ebuild b/dev-libs/ace/ace-5.5-r1.ebuild
index be4920aac260..4520b2672171 100644
--- a/dev-libs/ace/ace-5.5-r1.ebuild
+++ b/dev-libs/ace/ace-5.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.5-r1.ebuild,v 1.9 2007/07/22 08:33:04 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.5-r1.ebuild,v 1.10 2007/10/08 09:06:40 dragonheart Exp $
inherit eutils
@@ -28,7 +28,10 @@ src_compile() {
export ACE_ROOT="${S}"
mkdir build
cd build
- ECONF_SOURCE="${S}"
+
+ export ace_cv_new_throws_bad_alloc_exception="yes"
+
+ ECONF_SOURCE=${S}
econf --enable-lib-all $(use_with X) $(use_enable ipv6) $(use_with tao) || \
die "econf died"
# --with-qos needs ACE_HAS_RAPI
@@ -36,14 +39,15 @@ src_compile() {
}
src_test() {
- cd ${S}/build
- make ACE_ROOT=${S} check || die "self test failed"
+ cd "${S}"/build
+ make ACE_ROOT="${S}" check || die "self test failed"
#einfo "src_test currently stalls after Process_Mutex_Test"
}
src_install() {
cd build
make ACE_ROOT="${S}" DESTDIR="${D}" install || die "failed to install"
+ sed -i -e "^#define PACKAGE_.*//g" /usr/include/ace/config.h
# punt gperf stuff
rm -rf "${D}"/usr/bin/gperf "${D}"/usr/share
}
@@ -54,8 +58,12 @@ pkg_postinst() {
local CC_MACHINE=`gcc -dumpmachine`
local CC_VERSION=`gcc -dumpversion`
- if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
- mv "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
- "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
+ if [ -d "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
+ ewarn "moving /usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/$(gcc-fullversion)/include/ace to"
+ ewarn "ace.old"
+ ewarn "This is required, as anything trying to compile against ACE will"
+ ewarn "have problems with conflicting OS.h files if this is not done."
+ mv "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
+ "/usr/$(get_libdir)/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
fi
}