summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-10-27 11:19:26 +0000
committerMichael Imhof <tantive@gentoo.org>2004-10-27 11:19:26 +0000
commite2ceaf0447ac3baf125ce5df661df9d4dc903489 (patch)
tree16dd7afa05f574f2188f26c6d846f523f01e55ec /dev-libs/ace
parentadd fam virtual (#67170) (diff)
downloadgentoo-2-e2ceaf0447ac3baf125ce5df661df9d4dc903489.tar.gz
gentoo-2-e2ceaf0447ac3baf125ce5df661df9d4dc903489.tar.bz2
gentoo-2-e2ceaf0447ac3baf125ce5df661df9d4dc903489.zip
New revision which adds some missing links. Closes #60881.
Diffstat (limited to 'dev-libs/ace')
-rw-r--r--dev-libs/ace/ChangeLog7
-rw-r--r--dev-libs/ace/Manifest4
-rw-r--r--dev-libs/ace/ace-5.4-r1.ebuild81
-rw-r--r--dev-libs/ace/files/digest-ace-5.4-r11
4 files changed, 91 insertions, 2 deletions
diff --git a/dev-libs/ace/ChangeLog b/dev-libs/ace/ChangeLog
index a49ea64e54a6..562d04688958 100644
--- a/dev-libs/ace/ChangeLog
+++ b/dev-libs/ace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/ace
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.19 2004/07/02 04:33:25 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ChangeLog,v 1.20 2004/10/27 11:19:26 tantive Exp $
+
+*ace-5.4-r1 (27 Oct 2004)
+
+ 27 Oct 2004; Michael Imhof <tantive@gentoo.org> +ace-5.4-r1.ebuild:
+ New revision which adds some missing links. Closes #60881.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> ace-5.3.ebuild,
ace-5.4.ebuild:
diff --git a/dev-libs/ace/Manifest b/dev-libs/ace/Manifest
index bc212774adbf..8c25cfe4007a 100644
--- a/dev-libs/ace/Manifest
+++ b/dev-libs/ace/Manifest
@@ -1,5 +1,7 @@
-MD5 fee570821359ebb20a4c36a0ad7279e1 ChangeLog 2085
MD5 a202d56fd3622b28877ec98d87c14273 ace-5.3.ebuild 2036
MD5 4621efd43833273d01025f6118adef0f ace-5.4.ebuild 2182
+MD5 fee570821359ebb20a4c36a0ad7279e1 ChangeLog 2085
+MD5 84bb97121c5a8d546c5ad1f2079f816c ace-5.4-r1.ebuild 2510
MD5 b88f6bda8016adf15d1660b3f1e0312e files/digest-ace-5.3 60
MD5 3e3d835be64fd3d448525a09dec99bba files/digest-ace-5.4 61
+MD5 3e3d835be64fd3d448525a09dec99bba files/digest-ace-5.4-r1 61
diff --git a/dev-libs/ace/ace-5.4-r1.ebuild b/dev-libs/ace/ace-5.4-r1.ebuild
new file mode 100644
index 000000000000..fb01bce1c2e6
--- /dev/null
+++ b/dev-libs/ace/ace-5.4-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ace/ace-5.4-r1.ebuild,v 1.1 2004/10/27 11:19:26 tantive Exp $
+
+S=${WORKDIR}/ACE_wrappers
+DESCRIPTION="The Adaptive Communications Environment"
+SRC_URI="http://deuce.doc.wustl.edu/old_distribution/ACE-${PV}.tar.bz2"
+HOMEPAGE="http://www.cs.wustl.edu/~schmidt/ACE.html"
+
+SLOT="0"
+LICENSE="BSD as-is"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64"
+IUSE="ipv6"
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/ace
+ use ipv6 && sed -e "s/#define ACE_HAS_PTHREADS$/#define ACE_HAS_PTHREADS\n#define ACE_HAS_IPV6/" config-linux.h >config.h
+ use ipv6 || cp config-linux.h config.h
+ cd ${S}/include/makeinclude
+ sed -e "s:-O3:${CFLAGS}:" platform_linux.GNU >platform_macros.GNU
+}
+
+src_compile() {
+ export ACE_ROOT=${S}
+ cd ${S}/ace
+ emake static_libs=1 || die
+}
+
+src_install() {
+ dodir /usr/include/ace /usr/lib /usr/share/man/man3
+ cd ${S}/ace
+ cp libACE.so ${D}/usr/lib/libACE.so.${PV}
+ cp libACE.a ${D}/usr/lib/libACE.a
+ cp libACE_RMCast.so ${D}/usr/lib/libACE_RMCast.so.${PV}
+ cp libACE_RMCast.a ${D}/usr/lib/libACE_RMCast.a
+ cd ${D}/usr/lib
+# ln -s libACE.so.${PV} libACE.so.`echo ${PV} | cut -f1 -d.`
+ ln -s libACE.so.${PV} libACE.so
+ ln -s libACE.so.${PV} libACE.so.${PV}.0
+# ln -s libACE_RMCast.so.${PV} libACE_RMCast.so.`echo ${PV} | cut -f1 -d.`
+ ln -s libACE_RMCast.so.${PV} libACE_RMCast.so
+ ln -s libACE_RMCast.so.${PV} libACE_RMCast.so.${PV}.0
+
+ cd ${S}/ace
+ #don't really need the .cpp's after it's built
+ cp -r *.{h,hpp,i,inl} ${D}/usr/include/ace
+# cp -r * ${D}/usr/include/ace/
+ chmod -R 644 ${D}/usr/include/ace/*
+ cd ${D}/usr/include/ace/
+ find -type d -exec chmod 755 \{\} \;
+
+ cd ${S}/man
+ cp -r man? ${D}/usr/share/man
+ chmod 644 ${D}/usr/share/man/man?/*
+ gzip -q ${D}/usr/share/man/man?/*
+
+ cd ${S}
+ dodoc ACE-INSTALL* AUTHORS COPYING FAQ PROBLEM-REPORT-FORM README
+ dodoc THANKS TODO VERSION
+ cd ${S}/docs
+ dodoc *
+ cd ${S}
+ docinto ChangeLogs
+ dodoc ChangeLog
+ cd ${S}/ChangeLogs
+ dodoc *
+}
+
+pkg_postinst() {
+ # This is required, as anything trying to compile against ACE will have
+ # problems with conflicting OS.h files if this is not done.
+
+ local CC_MACHINE=`gcc -dumpmachine`
+ local CC_VERSION=`gcc -dumpversion`
+ if [ -d "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" ]; then
+ mv "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace" \
+ "/usr/lib/gcc-lib/${CC_MACHINE}/${CC_VERSION}/include/ace.old"
+ fi
+}
diff --git a/dev-libs/ace/files/digest-ace-5.4-r1 b/dev-libs/ace/files/digest-ace-5.4-r1
new file mode 100644
index 000000000000..5af8e0d0bdcd
--- /dev/null
+++ b/dev-libs/ace/files/digest-ace-5.4-r1
@@ -0,0 +1 @@
+MD5 51e997b07ea8a9cf38361cc9f2b6fede ACE-5.4.tar.bz2 5934471