summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-04-14 11:44:10 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-04-14 11:44:10 +0000
commit521cb6347f9c6a0bd8e0399d04369b01c8797432 (patch)
tree523662f9647104c90e9e7ecd016cfae7f6983f10 /dev-libs/boost/boost-1.37.0-r1.ebuild
parentVersion bump (diff)
downloadgentoo-2-521cb6347f9c6a0bd8e0399d04369b01c8797432.tar.gz
gentoo-2-521cb6347f9c6a0bd8e0399d04369b01c8797432.tar.bz2
gentoo-2-521cb6347f9c6a0bd8e0399d04369b01c8797432.zip
Correct non-mt symlink creation for debug libs (bug #256697)
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost/boost-1.37.0-r1.ebuild')
-rw-r--r--dev-libs/boost/boost-1.37.0-r1.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/dev-libs/boost/boost-1.37.0-r1.ebuild b/dev-libs/boost/boost-1.37.0-r1.ebuild
index 912b6842685d..8d4085afc59a 100644
--- a/dev-libs/boost/boost-1.37.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.37.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.37.0-r1.ebuild,v 1.1 2009/04/07 09:43:13 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.37.0-r1.ebuild,v 1.2 2009/04/14 11:44:10 dev-zero Exp $
EAPI="2"
@@ -259,17 +259,29 @@ src_install () {
# The threading libs obviously always gets the "-mt" (multithreading) tag
# some packages seem to have a problem with it. Creating symlinks...
- for lib in libboost_thread-mt-${MAJOR_PV}{,-debug}{.a,.so} ; do
+ for lib in libboost_thread-mt-${MAJOR_PV}{.a,.so} ; do
dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
done
# The same goes for the mpi libs
if use mpi ; then
- for lib in libboost_mpi-mt-${MAJOR_PV}{,-debug}{.a,.so} ; do
+ for lib in libboost_mpi-mt-${MAJOR_PV}{.a,.so} ; do
dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
done
fi
+ if use debug ; then
+ for lib in libboost_thread-mt-${MAJOR_PV}-debug{.a,.so} ; do
+ dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
+ done
+
+ if use mpi ; then
+ for lib in libboost_mpi-mt-${MAJOR_PV}-debug{.a,.so} ; do
+ dosym ${lib} "/usr/$(get_libdir)/$(sed -e 's/-mt//' <<< ${lib})"
+ done
+ fi
+ fi
+
# Create a subdirectory with completely unversioned symlinks
# and store the names in the profiles-file for eselect
dodir /usr/$(get_libdir)/boost-${MAJOR_PV}