summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-01-06 16:36:40 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-01-06 16:36:40 +0000
commit47774f9a698e13be6b05ff2438b48ebce743cb86 (patch)
treef3671efb223fdb4e82ad62977fdefdda5c70a8e9 /dev-libs/boost
parentUpdated alpha-sources-2.4.19 as a different patch is needed for the RTC fix. (diff)
downloadgentoo-2-47774f9a698e13be6b05ff2438b48ebce743cb86.tar.gz
gentoo-2-47774f9a698e13be6b05ff2438b48ebce743cb86.tar.bz2
gentoo-2-47774f9a698e13be6b05ff2438b48ebce743cb86.zip
Adding amd64 keyword. Closing #34232
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/Manifest2
-rw-r--r--dev-libs/boost/boost-1.31.0_alpha1.ebuild17
2 files changed, 13 insertions, 6 deletions
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 31903f8f7184..fde8989472bc 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,5 +1,5 @@
MD5 4537d46888da386ec78522e8def821c7 boost-1.29.0.ebuild 1437
-MD5 c3fd5e326973a985b9257fddbbd34590 boost-1.31.0_alpha1.ebuild 3217
+MD5 39c7409613061ed84642f66f0f44df39 boost-1.31.0_alpha1.ebuild 3303
MD5 47cc0eb1fd0be0e7b300c2433f3da645 boost-1.30.0.ebuild 2997
MD5 3a8c0f9e33aa84a1e756da799b78642a ChangeLog 1823
MD5 226122b504f12a7caf065d543b5218ed boost-1.30.2.ebuild 2980
diff --git a/dev-libs/boost/boost-1.31.0_alpha1.ebuild b/dev-libs/boost/boost-1.31.0_alpha1.ebuild
index e858a6d34b91..b80eac4019f4 100644
--- a/dev-libs/boost/boost-1.31.0_alpha1.ebuild
+++ b/dev-libs/boost/boost-1.31.0_alpha1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0_alpha1.ebuild,v 1.1 2003/12/19 16:44:07 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.31.0_alpha1.ebuild,v 1.2 2004/01/06 16:36:23 aliz Exp $
MyPV="2003d18"
@@ -12,7 +12,7 @@ SRC_URI="mirror://gentoo/${PN}-${MyPV}.tar.bz2"
S=${WORKDIR}/${PN}
LICENSE="freedist"
-KEYWORDS="~x86 ~ppc"
+KEYWORDS="~x86 ~ppc ~amd64"
SLOT="1"
IUSE="icc"
@@ -27,6 +27,7 @@ RDEPEND=">=dev-util/yacc-1.9.1-r1
src_compile() {
local PYTHON_VERSION=$(/usr/bin/python -V 2>&1 | sed 's/Python \([0-9][0-9]*\.[0-9][0-9]*\)\..*/\1/')
local BOOST_TOOLSET
+ local arch
if [ "`use icc`" ] ; then
BOOST_TOOLSET="intel-linux"
@@ -39,15 +40,21 @@ src_compile() {
./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
cd ${S}
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
if [ "`use icc`" ] ; then
- ./tools/build/jam_src/bin.linux${ARCH}/bjam -j2 \
+ ./tools/build/jam_src/bin.linux${arch}/bjam -j2 \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYTHON_VERSION} \
-sTOOLS=${BOOST_TOOLSET} \
-sINTEL_LINUX_VERSION="70" || die "Failed to build boost libraries."
else
- ./tools/build/jam_src/bin.linux${ARCH}/bjam ${MAKEOPTS} \
+ ./tools/build/jam_src/bin.linux${arch}/bjam ${MAKEOPTS} \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYTHON_VERSION} \
@@ -56,7 +63,7 @@ src_compile() {
einfo "Don't worry if there are a few (probably 6) failures above."
einfo "Some targets merely need to be combined. Here goes:"
- ./tools/build/jam_src/bin.linux${ARCH}/bjam \
+ ./tools/build/jam_src/bin.linux${arch}/bjam \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYTHON_VERSION} \