summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2004-12-23 06:10:40 +0000
committerDaniel Goller <morfic@gentoo.org>2004-12-23 06:10:40 +0000
commit95c0c30051ce4da15134aed78ca2a8bf7a005f82 (patch)
tree42907ae092b47acc1bbf1d8416bccf11a7300606 /dev-libs/boost
parentwe punted broken sdl-mixer ebuilds already (diff)
downloadgentoo-2-95c0c30051ce4da15134aed78ca2a8bf7a005f82.tar.gz
gentoo-2-95c0c30051ce4da15134aed78ca2a8bf7a005f82.tar.bz2
gentoo-2-95c0c30051ce4da15134aed78ca2a8bf7a005f82.zip
Installing build tools too
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog5
-rw-r--r--dev-libs/boost/boost-1.32.0.ebuild16
2 files changed, 18 insertions, 3 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 59c4525b3931..0d180961764b 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.32 2004/12/14 15:34:22 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.33 2004/12/23 06:10:40 morfic Exp $
+
+ 23 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
+ Install build tools too
14 Dec 2004; Daniel Goller <morfic@gentoo.org> boost-1.32.0.ebuild:
Add symlink for version independent location
diff --git a/dev-libs/boost/boost-1.32.0.ebuild b/dev-libs/boost/boost-1.32.0.ebuild
index 7966ded6dbee..6ea4fe1c6917 100644
--- a/dev-libs/boost/boost-1.32.0.ebuild
+++ b/dev-libs/boost/boost-1.32.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.9 2004/12/14 15:34:22 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0.ebuild,v 1.10 2004/12/23 06:10:40 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
inherit python
@@ -35,10 +35,15 @@ BOOSTJAM=./tools/build/jam_src/bin.linux${arch}/bjam
src_compile() {
python_version
+ # Build bjam, a jam variant, which is used instead of make
cd ${S}/tools/build/jam_src
- ./build.sh || die "Failed to build bjam"
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
cd ${S}
+ #cd ${S}/tools/build/jam_src
+ #./build.sh || die "Failed to build bjam"
+ #cd ${S}
+
# actual build
${BOOSTJAM} \
-sBOOST_ROOT=${S} \
@@ -51,6 +56,13 @@ src_compile() {
}
src_install () {
+ # install build tools
+ cd tools/build
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ dodir /usr/share/${PN}
+ cp -a b* c* index.html v1/ v2/ ${D}/usr/share/${PN}
+ cd ${S}
+
${BOOSTJAM} ${MAKEOPTS} \
-sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \