summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2009-10-21 13:58:13 +0000
committerDirkjan Ochtman <djc@gentoo.org>2009-10-21 13:58:13 +0000
commitc0b2064c65fe9432ddabe1abcd049caa2edd13c2 (patch)
tree48630e0f61fba5dcffe2f3cb09b3d7f865155896 /dev-libs/boost
parentRemove old freedist license from Boost ebuilds (#215129). (diff)
downloadgentoo-2-c0b2064c65fe9432ddabe1abcd049caa2edd13c2.tar.gz
gentoo-2-c0b2064c65fe9432ddabe1abcd049caa2edd13c2.tar.bz2
gentoo-2-c0b2064c65fe9432ddabe1abcd049caa2edd13c2.zip
Fix use of FEATURES in boost ebuilds (#278753).
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog8
-rw-r--r--dev-libs/boost/boost-1.33.1-r1.ebuild6
-rw-r--r--dev-libs/boost/boost-1.34.1-r2.ebuild8
-rw-r--r--dev-libs/boost/boost-1.35.0-r1.ebuild8
-rw-r--r--dev-libs/boost/boost-1.35.0-r2.ebuild4
-rw-r--r--dev-libs/boost/boost-1.35.0-r3.ebuild4
-rw-r--r--dev-libs/boost/boost-1.35.0-r5.ebuild4
-rw-r--r--dev-libs/boost/boost-1.36.0-r1.ebuild4
-rw-r--r--dev-libs/boost/boost-1.37.0-r1.ebuild4
-rw-r--r--dev-libs/boost/boost-1.39.0.ebuild4
-rw-r--r--dev-libs/boost/boost-1.40.0.ebuild4
11 files changed, 32 insertions, 26 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 5bc0fe09c5d4..08e8ab96baa5 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.169 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.170 2009/10/21 13:58:13 djc Exp $
+
+ 21 Oct 2009; Dirkjan Ochtman <djc@gentoo.org> boost-1.33.1-r1.ebuild,
+ boost-1.34.1-r2.ebuild, boost-1.35.0-r1.ebuild, boost-1.35.0-r2.ebuild,
+ boost-1.35.0-r3.ebuild, boost-1.35.0-r5.ebuild, boost-1.36.0-r1.ebuild,
+ boost-1.37.0-r1.ebuild, boost-1.39.0.ebuild, boost-1.40.0.ebuild:
+ Use test use flag instead of checking FEATURES, #278753.
21 Oct 2009; Dirkjan Ochtman <djc@gentoo.org> boost-1.33.1-r1.ebuild,
boost-1.34.1-r2.ebuild, boost-1.35.0-r1.ebuild, boost-1.35.0-r2.ebuild,
diff --git a/dev-libs/boost/boost-1.33.1-r1.ebuild b/dev-libs/boost/boost-1.33.1-r1.ebuild
index b4446a511b74..1996a5c65e7b 100644
--- a/dev-libs/boost/boost-1.33.1-r1.ebuild
+++ b/dev-libs/boost/boost-1.33.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.1-r1.ebuild,v 1.20 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.1-r1.ebuild,v 1.21 2009/10/21 13:58:13 djc Exp $
inherit eutils distutils multilib python versionator check-reqs
@@ -41,7 +41,7 @@ src_unpack() {
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="2048"
check_reqs
fi
@@ -220,7 +220,7 @@ src_install () {
dobin bjam || die "bjam install failed"
fi
- if has test ${FEATURES} ; then
+ if use test ; then
cd "${S}/status"
elog "Tests enabled, installing the output to:"
elog " ${ROOT}usr/share/doc/${PF}/status"
diff --git a/dev-libs/boost/boost-1.34.1-r2.ebuild b/dev-libs/boost/boost-1.34.1-r2.ebuild
index 32d225e415c6..5757180e683f 100644
--- a/dev-libs/boost/boost-1.34.1-r2.ebuild
+++ b/dev-libs/boost/boost-1.34.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.1-r2.ebuild,v 1.10 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34.1-r2.ebuild,v 1.11 2009/10/21 13:58:13 djc Exp $
inherit distutils flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -30,7 +30,7 @@ S=${WORKDIR}/${MY_P}
# - write a patch to support /dev/urandom on FreeBSD and OSX (see below)
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
@@ -156,7 +156,7 @@ src_compile() {
|| die "building tools failed"
fi
- if has test ${FEATURES} ; then
+ if use test ; then
cd "${S}/tools/regression/build"
bjam -q \
${OPTIONS} \
@@ -226,7 +226,7 @@ src_install () {
doins -r share
fi
- if has test ${FEATURES} ; then
+ if use test ; then
cd "${S}/status"
docinto status
dohtml *.{html,gif} ../boost.png
diff --git a/dev-libs/boost/boost-1.35.0-r1.ebuild b/dev-libs/boost/boost-1.35.0-r1.ebuild
index 14c74265926b..3b5d848e0558 100644
--- a/dev-libs/boost/boost-1.35.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r1.ebuild,v 1.5 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r1.ebuild,v 1.6 2009/10/21 13:58:13 djc Exp $
inherit python flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -32,7 +32,7 @@ S=${WORKDIR}/${MY_P}
# - write a patch to support /dev/urandom on FreeBSD and OSX (see below)
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
@@ -151,7 +151,7 @@ src_compile() {
|| die "building tools failed"
fi
- if has test ${FEATURES} ; then
+ if use test ; then
cd "${S}/tools/regression/build"
bjam -q \
${OPTIONS} \
@@ -220,7 +220,7 @@ src_install () {
doins -r share
fi
- if has test ${FEATURES} ; then
+ if use test ; then
cd "${S}/status"
docinto status
dohtml *.{html,gif} ../boost.png
diff --git a/dev-libs/boost/boost-1.35.0-r2.ebuild b/dev-libs/boost/boost-1.35.0-r2.ebuild
index 85897e1bb05b..adc99dda9ae8 100644
--- a/dev-libs/boost/boost-1.35.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.12 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.13 2009/10/21 13:58:13 djc Exp $
inherit python flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -32,7 +32,7 @@ S=${WORKDIR}/${MY_P}
# - write a patch to support /dev/urandom on FreeBSD and OSX (see below)
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
diff --git a/dev-libs/boost/boost-1.35.0-r3.ebuild b/dev-libs/boost/boost-1.35.0-r3.ebuild
index 335dc568443b..a766d90e6a4a 100644
--- a/dev-libs/boost/boost-1.35.0-r3.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r3.ebuild,v 1.3 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r3.ebuild,v 1.4 2009/10/21 13:58:13 djc Exp $
EAPI="2"
@@ -40,7 +40,7 @@ MAJOR_PV=1_35
BJAM="bjam-${MAJOR_PV}"
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
diff --git a/dev-libs/boost/boost-1.35.0-r5.ebuild b/dev-libs/boost/boost-1.35.0-r5.ebuild
index efcf03cba5bf..135d5565bd9e 100644
--- a/dev-libs/boost/boost-1.35.0-r5.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r5.ebuild,v 1.7 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r5.ebuild,v 1.8 2009/10/21 13:58:13 djc Exp $
EAPI="2"
@@ -55,7 +55,7 @@ _add_line() {
}
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
diff --git a/dev-libs/boost/boost-1.36.0-r1.ebuild b/dev-libs/boost/boost-1.36.0-r1.ebuild
index ef74b373d848..5eda7549c65b 100644
--- a/dev-libs/boost/boost-1.36.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.36.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.36.0-r1.ebuild,v 1.7 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.36.0-r1.ebuild,v 1.8 2009/10/21 13:58:13 djc Exp $
EAPI="2"
@@ -55,7 +55,7 @@ _add_line() {
}
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
diff --git a/dev-libs/boost/boost-1.37.0-r1.ebuild b/dev-libs/boost/boost-1.37.0-r1.ebuild
index eba013752394..3fdd5dff0951 100644
--- a/dev-libs/boost/boost-1.37.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.37.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.37.0-r1.ebuild,v 1.10 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.37.0-r1.ebuild,v 1.11 2009/10/21 13:58:13 djc Exp $
EAPI="2"
@@ -56,7 +56,7 @@ _add_line() {
}
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
diff --git a/dev-libs/boost/boost-1.39.0.ebuild b/dev-libs/boost/boost-1.39.0.ebuild
index f0a2750b2848..bbe52df317db 100644
--- a/dev-libs/boost/boost-1.39.0.ebuild
+++ b/dev-libs/boost/boost-1.39.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.39.0.ebuild,v 1.4 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.39.0.ebuild,v 1.5 2009/10/21 13:58:13 djc Exp $
EAPI="2"
@@ -52,7 +52,7 @@ _add_line() {
}
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs
diff --git a/dev-libs/boost/boost-1.40.0.ebuild b/dev-libs/boost/boost-1.40.0.ebuild
index 1b9862391a6e..64561e8ba957 100644
--- a/dev-libs/boost/boost-1.40.0.ebuild
+++ b/dev-libs/boost/boost-1.40.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.40.0.ebuild,v 1.3 2009/10/21 13:42:37 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.40.0.ebuild,v 1.4 2009/10/21 13:58:13 djc Exp $
EAPI="2"
@@ -49,7 +49,7 @@ _add_line() {
}
pkg_setup() {
- if has test ${FEATURES} ; then
+ if use test ; then
CHECKREQS_DISK_BUILD="1024"
check_reqs