summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-07 01:34:19 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-07 01:34:19 +0000
commitcfb2357b80dc141adb23cb83a0e2459cfaf94e72 (patch)
tree07c16c8986c9f5696bcd1227790f1561734e1f65 /dev-libs/boost
parentNew revision, adds the 'static' USE flag. Removed old ebuilds. (diff)
downloadgentoo-2-cfb2357b80dc141adb23cb83a0e2459cfaf94e72.tar.gz
gentoo-2-cfb2357b80dc141adb23cb83a0e2459cfaf94e72.tar.bz2
gentoo-2-cfb2357b80dc141adb23cb83a0e2459cfaf94e72.zip
Multilib fix.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/boost-1.32.0-r1.ebuild5
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 164bf3b8b17d..28012124d73c 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.40 2005/03/06 08:48:54 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.41 2005/03/07 01:34:19 eradicator Exp $
+
+ 06 Mar 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ boost-1.32.0-r1.ebuild:
+ Multilib fix.
06 Mar 2005; Daniel Goller <morfic@gentoo.org> boost-1.32.0-r1.ebuild:
fixed issue with links ending up in / if the target does not exist
diff --git a/dev-libs/boost/boost-1.32.0-r1.ebuild b/dev-libs/boost/boost-1.32.0-r1.ebuild
index 8b8ece0fdbf9..82953cb8a888 100644
--- a/dev-libs/boost/boost-1.32.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.32.0-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.3 2005/03/06 08:48:54 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.4 2005/03/07 01:34:19 eradicator Exp $
# This ebuild was generated by Ebuilder v0.4.
-inherit python
+inherit python multilib
BOOST_PV1=${PV/./_}
BOOST_PV=${BOOST_PV1/./_}
@@ -120,4 +120,5 @@ src_install () {
fi
done
+ [[ $(get_libdir) == "lib" ]] || mv ${D}/usr/lib ${D}/usr/$(get_libdir)
}