summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-04-12 18:08:53 +0000
committerMike Gilbert <floppym@gentoo.org>2012-04-12 18:08:53 +0000
commite0b6c559227242dd5c37eaa2d5681752251c3ae6 (patch)
treea715eac71139399ecdc6423594bef7d34f1bb628 /dev-libs/boost
parentRemove unused revisions. (diff)
downloadgentoo-2-e0b6c559227242dd5c37eaa2d5681752251c3ae6.tar.gz
gentoo-2-e0b6c559227242dd5c37eaa2d5681752251c3ae6.tar.bz2
gentoo-2-e0b6c559227242dd5c37eaa2d5681752251c3ae6.zip
Delete call to ebeep() (bug #409309). Fix paths to commands in src_test() (bug #406467). Backported from Progress Overlay. Patch by Arfrever.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.48.0-r1.ebuild11
-rw-r--r--dev-libs/boost/boost-1.49.0.ebuild11
3 files changed, 16 insertions, 13 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index f1605532deec..87289530c32c 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.240 2012/04/02 01:06:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.241 2012/04/12 18:08:53 floppym Exp $
+
+ 12 Apr 2012; Mike Gilbert <floppym@gentoo.org> boost-1.48.0-r1.ebuild,
+ boost-1.49.0.ebuild:
+ Delete call to ebeep() (bug #409309). Fix paths to commands in src_test() (bug
+ #406467). Backported from Progress Overlay. Patch by Arfrever.
*boost-1.49.0 (02 Apr 2012)
diff --git a/dev-libs/boost/boost-1.48.0-r1.ebuild b/dev-libs/boost/boost-1.48.0-r1.ebuild
index a375c4680f9d..2d2447e78af4 100644
--- a/dev-libs/boost/boost-1.48.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.48.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.48.0-r1.ebuild,v 1.4 2012/04/02 00:53:01 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.48.0-r1.ebuild,v 1.5 2012/04/12 18:08:53 floppym Exp $
EAPI="4"
PYTHON_DEPEND="python? *"
@@ -93,12 +93,11 @@ pkg_pretend() {
ewarn "The tests may take several hours on a recent machine"
ewarn "but they will not fail (unless something weird happens ;-)"
- ewarn "This is because the tests depend on the used compiler/-version"
+ ewarn "This is because the tests depend on the used compiler version"
ewarn "and the platform and upstream says that this is normal."
ewarn "If you are interested in the results, please take a look at the"
ewarn "generated results page:"
ewarn " ${ROOT}usr/share/doc/${PF}/status/cs-$(uname).html"
- ebeep 5
fi
}
@@ -570,7 +569,7 @@ src_test() {
--dump-tests 2>&1 | tee regress.log || die
# Postprocessing
- cat regress.log | tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/process_jam_log --v2
+ cat regress.log | ../tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/process_jam_log --v2
if test $? != 0; then
die "Postprocessing the build log failed"
fi
@@ -580,8 +579,8 @@ src_test() {
__EOF__
# Generate the build log html summary page
- tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/compiler_status --v2 \
- --comment comment.html .. \
+ ../tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/compiler_status --v2 \
+ --comment comment.html "${S}" \
cs-$(uname).html cs-$(uname)-links.html
if test $? != 0; then
die "Generating the build log html summary page failed"
diff --git a/dev-libs/boost/boost-1.49.0.ebuild b/dev-libs/boost/boost-1.49.0.ebuild
index 32b6ccc7b722..03ed20acd87c 100644
--- a/dev-libs/boost/boost-1.49.0.ebuild
+++ b/dev-libs/boost/boost-1.49.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.49.0.ebuild,v 1.1 2012/04/02 01:06:18 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.49.0.ebuild,v 1.2 2012/04/12 18:08:53 floppym Exp $
EAPI="4"
PYTHON_DEPEND="python? *"
@@ -93,12 +93,11 @@ pkg_pretend() {
ewarn "The tests may take several hours on a recent machine"
ewarn "but they will not fail (unless something weird happens ;-)"
- ewarn "This is because the tests depend on the used compiler/-version"
+ ewarn "This is because the tests depend on the used compiler version"
ewarn "and the platform and upstream says that this is normal."
ewarn "If you are interested in the results, please take a look at the"
ewarn "generated results page:"
ewarn " ${ROOT}usr/share/doc/${PF}/status/cs-$(uname).html"
- ebeep 5
fi
}
@@ -569,7 +568,7 @@ src_test() {
--dump-tests 2>&1 | tee regress.log || die
# Postprocessing
- cat regress.log | tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/process_jam_log --v2
+ cat regress.log | ../tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/process_jam_log --v2
if test $? != 0; then
die "Postprocessing the build log failed"
fi
@@ -579,8 +578,8 @@ src_test() {
__EOF__
# Generate the build log html summary page
- tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/compiler_status --v2 \
- --comment comment.html .. \
+ ../tools/regression/build/bin/gcc-$(gcc-version)/gentoorelease/pch-off/compiler_status --v2 \
+ --comment comment.html "${S}" \
cs-$(uname).html cs-$(uname)-links.html
if test $? != 0; then
die "Generating the build log html summary page failed"