summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-10-26 00:31:06 +0000
committerDaniel Goller <morfic@gentoo.org>2005-10-26 00:31:06 +0000
commitedd0d50d14c8d868971e64145e9bfb3cb134d671 (patch)
tree292b70c1ed57e7b38814d63d83f41f9433dc7c19 /dev-libs/boost
parentinitial version of quake3-from-source #103591 (diff)
downloadgentoo-2-edd0d50d14c8d868971e64145e9bfb3cb134d671.tar.gz
gentoo-2-edd0d50d14c8d868971e64145e9bfb3cb134d671.tar.bz2
gentoo-2-edd0d50d14c8d868971e64145e9bfb3cb134d671.zip
Don't check icc path unless we have USE=icc
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.33.0-r1.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/dev-libs/boost/boost-1.33.0-r1.ebuild b/dev-libs/boost/boost-1.33.0-r1.ebuild
index 97ffcf8236cd..77510c63df34 100644
--- a/dev-libs/boost/boost-1.33.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.33.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.0-r1.ebuild,v 1.2 2005/10/25 20:10:35 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.0-r1.ebuild,v 1.3 2005/10/26 00:31:06 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
inherit python distutils multilib eutils
@@ -45,19 +45,20 @@ pkg_setup() {
SOSUFFIX="so"
fi
#Check ICC path and use this instead of hardcoding it, thanks to Peter Koeleman
- if [ "X${IA32ROOT}" == "X" ]; then
- # try IA64ROOT
- if [ "X${IA64ROOT}" == "X" ]; then
- # this shouldn't happen when icc is properly installed
- eerror "Could not find path to Intel compiler"
+ if use icc; then
+ if [ "X${IA32ROOT}" == "X" ]; then
+ # try IA64ROOT
+ if [ "X${IA64ROOT}" == "X" ]; then
+ # this shouldn't happen when icc is properly installed
+ eerror "Could not find path to Intel compiler"
+ else
+ INTEL_PATH="${IA64ROOT}"
+ fi
else
- INTEL_PATH="${IA64ROOT}"
+ INTEL_PATH="${IA32ROOT}"
fi
- else
- INTEL_PATH="${IA32ROOT}"
fi
-
if use static ; then
BUILD="release <runtime-link>static"
else
@@ -126,7 +127,6 @@ src_compile() {
-sBUILD="${BUILD}" \
--prefix=${D}/usr \
--layout=system
-
else
${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
-sPYTHON_ROOT=/usr \
@@ -143,7 +143,6 @@ src_compile() {
-sBUILD="${BUILD}" \
--prefix=${D}/usr \
--layout=system
-
fi
if use pyste; then