summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-28 15:31:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-02-28 15:31:35 +0000
commit5f2285b8eebb1d71ecb3dcf8c0c0d7aded35e7f8 (patch)
tree123df0eedd26622c9994cd5938acfc7b20b1a55a /dev-libs/botan
parentDelete older ebuild. (diff)
downloadgentoo-2-5f2285b8eebb1d71ecb3dcf8c0c0d7aded35e7f8.tar.gz
gentoo-2-5f2285b8eebb1d71ecb3dcf8c0c0d7aded35e7f8.tar.bz2
gentoo-2-5f2285b8eebb1d71ecb3dcf8c0c0d7aded35e7f8.zip
Delete older ebuild.
(Portage version: 2.2.0_alpha25_p10/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/ChangeLog7
-rw-r--r--dev-libs/botan/botan-1.8.10.ebuild93
-rw-r--r--dev-libs/botan/files/botan-1.8.8-darwin-install_name-fix.patch13
-rw-r--r--dev-libs/botan/files/botan-1.8.8-use_negative_lea_displacement.patch29
4 files changed, 6 insertions, 136 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index cbc37a59ac8b..5b5b164eeacb 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.68 2011/02/28 01:02:11 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.69 2011/02/28 15:31:34 arfrever Exp $
+
+ 28 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -files/botan-1.8.8-darwin-install_name-fix.patch,
+ -files/botan-1.8.8-use_negative_lea_displacement.patch, -botan-1.8.10.ebuild:
+ Delete.
28 Feb 2011; Brent Baude <ranger@gentoo.org> botan-1.8.11.ebuild:
stable ppc, bug 353858
diff --git a/dev-libs/botan/botan-1.8.10.ebuild b/dev-libs/botan/botan-1.8.10.ebuild
deleted file mode 100644
index 97015299a9c7..000000000000
--- a/dev-libs/botan/botan-1.8.10.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.8.10.ebuild,v 1.4 2011/01/06 23:03:18 ranger Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-inherit eutils multilib python toolchain-funcs
-
-MY_PN="Botan"
-MY_P="${MY_PN}-${PV}"
-DESCRIPTION="A C++ crypto library"
-HOMEPAGE="http://botan.randombit.net/"
-SRC_URI="http://files.randombit.net/botan/${MY_P}.tbz"
-
-KEYWORDS="amd64 ~ia64 ppc ~sparc x86 ~ppc-macos"
-SLOT="0"
-LICENSE="BSD"
-IUSE="bzip2 gmp ssl threads zlib"
-
-S="${WORKDIR}/${MY_P}"
-
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
- zlib? ( >=sys-libs/zlib-1.2.3 )
- gmp? ( >=dev-libs/gmp-4.2.2 )
- ssl? ( >=dev-libs/openssl-0.9.8g )"
-
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- python_set_active_version 2
-}
-
-src_prepare() {
- # Install documentation in /usr/share/doc/${PF}.
- sed -e "/^DOCDIR *=/s/Botan-\$(VERSION)/${PF}/" -i src/build-data/makefile/unix_shr.in || die "sed failed"
-}
-
-src_configure() {
- local disable_modules="proc_walk,unix_procs,cpu_counter"
-
- if ! useq threads; then
- disable_modules="${disable_modules},pthreads"
- fi
-
- # Enable v9 instructions for sparc64
- if [[ "${PROFILE_ARCH}" = "sparc64" ]]; then
- CHOSTARCH="sparc32-v9"
- else
- CHOSTARCH="${CHOST%%-*}"
- fi
-
- cd "${S}"
- elog "Disabling modules: ${disable_modules}"
-
- local myos=
- case ${CHOST} in
- *-darwin*) myos=darwin ;;
- *) myos=linux ;;
- esac
-
- # foobared buildsystem, --prefix translates into DESTDIR, see also make
- # install in src_install, we need the correct live-system prefix here on
- # Darwin for a shared lib with correct install_name
- ./configure.py \
- --prefix="${EPREFIX}/usr" \
- --libdir=$(get_libdir) \
- --docdir=share/doc \
- --cc=gcc \
- --os=${myos} \
- --cpu=${CHOSTARCH} \
- --with-endian="$(tc-endian)" \
- --with-tr1=system \
- $(use_with bzip2) \
- $(use_with gmp gnump) \
- $(use_with ssl openssl) \
- $(use_with zlib) \
- --disable-modules=${disable_modules} \
- || die "configure.py failed"
-}
-
-src_compile() {
- emake CXX="$(tc-getCXX)" AR="$(tc-getAR) crs" LIB_OPT="${CXXFLAGS}" MACH_OPT="" || die "emake failed"
-}
-
-src_test() {
- chmod -R ugo+rX "${S}"
- emake CXX="$(tc-getCXX)" CHECK_OPT="${CXXFLAGS}" check || die "emake check failed"
- LD_LIBRARY_PATH="${S}" ./check --validate || die "Validation tests failed"
-}
-
-src_install() {
- emake DESTDIR="${ED}usr" install || die "emake install failed"
-}
diff --git a/dev-libs/botan/files/botan-1.8.8-darwin-install_name-fix.patch b/dev-libs/botan/files/botan-1.8.8-darwin-install_name-fix.patch
deleted file mode 100644
index d749ea08e5d2..000000000000
--- a/dev-libs/botan/files/botan-1.8.8-darwin-install_name-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-install_names (sonames) on Darwin are absolute
-
---- src/build-data/cc/gcc.txt
-+++ src/build-data/cc/gcc.txt
-@@ -31,7 +31,7 @@
- # AIX doesn't seem to have soname support (weird...)
- aix -> "$(CXX) -shared -fPIC"
-
--darwin -> "$(CXX) -dynamiclib -fPIC -install_name $(SONAME)"
-+darwin -> "$(CXX) -dynamiclib -fPIC -install_name $(LIBDIR)/$(SONAME)"
- hpux -> "$(CXX) -shared -fPIC -Wl,+h,$(SONAME)"
- solaris -> "$(CXX) -shared -fPIC -Wl,-h,$(SONAME)"
- # Gotta use ld directly on BeOS, their GCC is busted
diff --git a/dev-libs/botan/files/botan-1.8.8-use_negative_lea_displacement.patch b/dev-libs/botan/files/botan-1.8.8-use_negative_lea_displacement.patch
deleted file mode 100644
index 50faa56bdca3..000000000000
--- a/dev-libs/botan/files/botan-1.8.8-use_negative_lea_displacement.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-#
-# old_revision [a101c8c86b755a666c72baf03154230e09e0667e]
-#
-# patch "src/hash/sha1_amd64/sha1_amd64_imp.S"
-# from [dd263db10309950dec501dd9257a8df43cf6c6aa]
-# to [ab1db7a394b41a1d3b9a63a6e8e1571e4671b962]
-#
-============================================================
---- src/hash/sha1_amd64/sha1_amd64_imp.S dd263db10309950dec501dd9257a8df43cf6c6aa
-+++ src/hash/sha1_amd64/sha1_amd64_imp.S ab1db7a394b41a1d3b9a63a6e8e1571e4671b962
-@@ -103,10 +103,16 @@ ALIGN;
-
- subq $320, W
-
-+/*
-+* Using negative values for SHA-1 constants > 2^31 to work around
-+* a bug in binutils not accepting large lea displacements.
-+* -0x70E44324 == 0x8F1BBCDC
-+* -0x359D3E2A == 0xCA62C1D6
-+*/
- #define MAGIC1 0x5A827999
- #define MAGIC2 0x6ED9EBA1
--#define MAGIC3 0x8F1BBCDC
--#define MAGIC4 0xCA62C1D6
-+#define MAGIC3 -0x70E44324
-+#define MAGIC4 -0x359D3E2A
-
- #define T %esi
- #define T2 %eax