summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-09-13 19:57:25 +0000
committerMamoru Komachi <usata@gentoo.org>2004-09-13 19:57:25 +0000
commit714480fa84a3af05e2263beaadc38f385d15ee8d (patch)
tree4d340fc7b71a8fc5ad1229378ebd5ba9e0d560db /dev-libs/csconv/csconv-11.4_p1467.ebuild
parentAdded a snapshot. Renamed previous ebuild and marked it stable. (Manifest rec... (diff)
downloadgentoo-2-714480fa84a3af05e2263beaadc38f385d15ee8d.tar.gz
gentoo-2-714480fa84a3af05e2263beaadc38f385d15ee8d.tar.bz2
gentoo-2-714480fa84a3af05e2263beaadc38f385d15ee8d.zip
Added a snapshot. Renamed previous ebuild and marked it stable.
Diffstat (limited to 'dev-libs/csconv/csconv-11.4_p1467.ebuild')
-rw-r--r--dev-libs/csconv/csconv-11.4_p1467.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/csconv/csconv-11.4_p1467.ebuild b/dev-libs/csconv/csconv-11.4_p1467.ebuild
new file mode 100644
index 000000000000..7c1bd0f52937
--- /dev/null
+++ b/dev-libs/csconv/csconv-11.4_p1467.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/csconv/csconv-11.4_p1467.ebuild,v 1.1 2004/09/13 19:55:11 usata Exp $
+
+inherit iiimf eutils
+
+DESCRIPTION="A code conversion library for IIIMF"
+
+LICENSE="IBM"
+KEYWORDS="x86"
+IUSE="debug"
+
+S="${WORKDIR}/${IMSDK}/lib/CSConv"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P%_*}-gentoo.diff
+}
+
+src_compile() {
+ econf --prefix=/usr/lib/im \
+ --enable-optimize \
+ `use_enable debug` || die
+ # emake doesn't work
+ make || die
+}
+
+src_install() {
+ einstall prefix=${D}/usr/lib/im || die
+
+ cd ${WORKDIR}/${IMSDK}/doc/conv
+ doman *.[1-9]
+ dodoc ChangeLog INSTALL README*
+}