summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-12-05 09:40:37 +0000
committerEray Aslan <eras@gentoo.org>2012-12-05 09:40:37 +0000
commit0f2b7bc431b928cdf4fb685a09366df389f3ca4e (patch)
tree211b620612a1787355fd02b967661f88682d2df8 /dev-libs/cyrus-sasl
parentVersion bump. (diff)
downloadgentoo-2-0f2b7bc431b928cdf4fb685a09366df389f3ca4e.tar.gz
gentoo-2-0f2b7bc431b928cdf4fb685a09366df389f3ca4e.tar.bz2
gentoo-2-0f2b7bc431b928cdf4fb685a09366df389f3ca4e.zip
Service keytabs should work with mit-krb5 now - bug #445932
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'dev-libs/cyrus-sasl')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog8
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild220
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.25-service_keytabs.patch27
3 files changed, 254 insertions, 1 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 572d742334c4..8f2caee5b0a0 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.251 2012/12/01 14:45:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.252 2012/12/05 09:40:37 eras Exp $
+
+*cyrus-sasl-2.1.25-r4 (05 Dec 2012)
+
+ 05 Dec 2012; Eray Aslan <eras@gentoo.org> +cyrus-sasl-2.1.25-r4.ebuild,
+ +files/cyrus-sasl-2.1.25-service_keytabs.patch:
+ Service keytabs should work with mit-krb5 now - bug #445932
01 Dec 2012; Anthony G. Basile <blueness@gentoo.org>
cyrus-sasl-2.1.25-r3.ebuild:
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild
new file mode 100644
index 000000000000..d8b17b45cd55
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild
@@ -0,0 +1,220 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild,v 1.1 2012/12/05 09:40:37 eras Exp $
+
+EAPI=4
+inherit eutils flag-o-matic multilib autotools pam java-pkg-opt-2 db-use
+
+SASLAUTHD_CONF_VER="2.1.21"
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)."
+HOMEPAGE="http://cyrusimap.web.cmu.edu/"
+SRC_URI="ftp://ftp.cyrusimap.org/cyrus-sasl/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="authdaemond berkdb gdbm kerberos ldapdb openldap mysql pam postgres sample sqlite
+srp ssl static-libs urandom"
+
+DEPEND="authdaemond? ( || ( net-mail/courier-imap mail-mta/courier ) )
+ berkdb? ( >=sys-libs/db-3.2 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ kerberos? ( virtual/krb5 )
+ openldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? ( dev-libs/openssl )
+ java? ( >=virtual/jdk-1.4 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sasldb_al.patch
+ epatch "${FILESDIR}"/${P}-saslauthd_libtool.patch
+ epatch "${FILESDIR}"/${P}-avoid_pic_overwrite.patch
+ epatch "${FILESDIR}"/${P}-autotools_fixes.patch
+ epatch "${FILESDIR}"/${P}-as_needed.patch
+ epatch "${FILESDIR}"/${P}-missing_header.patch
+ epatch "${FILESDIR}"/${P}-gssapi.patch
+ epatch "${FILESDIR}"/${P}-lib_before_plugin.patch
+ epatch "${FILESDIR}"/${P}-fix_heimdal.patch
+ epatch "${FILESDIR}"/${P}-auxprop.patch
+ epatch "${FILESDIR}"/${PN}-2.1.23-gss_c_nt_hostbased_service.patch
+ epatch "${FILESDIR}"/${PN}-2.1.23+db-5.0.patch
+ epatch "${FILESDIR}"/${P}-get_fqhostname.patch
+ epatch "${FILESDIR}"/${P}-service_keytabs.patch
+
+ # Get rid of the -R switch (runpath_switch for Sun)
+ # >=gcc-4.6 errors out with unknown option
+ sed -i -e '/LIB_SQLITE.*-R/s/ -R[^"]*//' configure.in
+
+ # Use plugindir for sasldir
+ sed -i '/^sasldir =/s:=.*:= $(plugindir):' \
+ "${S}"/plugins/Makefile.{am,in} || die "sed failed"
+
+ AT_M4DIR="${S}/cmulocal ${S}/config" eautoreconf
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ append-cppflags -D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED -D_BSD_SOURCE -DLDAP_DEPRECATED
+
+ # Java support.
+ use java && export JAVAC="${JAVAC} ${JAVACFLAGS}"
+
+ local myconf
+
+ # Add authdaemond support (bug #56523).
+ if use authdaemond ; then
+ myconf="${myconf} --with-authdaemond=/var/lib/courier/authdaemon/socket"
+ fi
+
+ # Fix for bug #59634.
+ if ! use ssl ; then
+ myconf="${myconf} --without-des"
+ fi
+
+ if use mysql || use postgres || use sqlite ; then
+ myconf="${myconf} --enable-sql"
+ else
+ myconf="${myconf} --disable-sql"
+ fi
+
+ # Default to GDBM if both 'gdbm' and 'berkdb' are present.
+ if use gdbm ; then
+ einfo "Building with GNU DB as database backend for your SASLdb"
+ myconf="${myconf} --with-dblib=gdbm"
+ elif use berkdb ; then
+ einfo "Building with BerkeleyDB as database backend for your SASLdb"
+ myconf="${myconf} --with-dblib=berkeley --with-bdb-incdir=$(db_includedir)"
+ else
+ einfo "Building without SASLdb support"
+ myconf="${myconf} --with-dblib=none"
+ fi
+
+ # Use /dev/urandom instead of /dev/random (bug #46038).
+ if use urandom ; then
+ myconf="${myconf} --with-devrandom=/dev/urandom"
+ fi
+
+ econf \
+ --enable-login \
+ --enable-ntlm \
+ --enable-auth-sasldb \
+ --disable-cmulocal \
+ --disable-krb4 \
+ --enable-otp \
+ --without-sqlite \
+ --with-saslauthd=/var/lib/sasl2 \
+ --with-pwcheck=/var/lib/sasl2 \
+ --with-configdir=/etc/sasl2 \
+ --with-plugindir=/usr/$(get_libdir)/sasl2 \
+ --with-dbpath=/etc/sasl2/sasldb2 \
+ $(use_with ssl openssl) \
+ $(use_with pam) \
+ $(use_with openldap ldap) \
+ $(use_enable ldapdb) \
+ $(use_enable sample) \
+ $(use_enable kerberos gssapi) \
+ $(use_enable java) \
+ $(use_with java javahome ${JAVA_HOME}) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite3 /usr/$(get_libdir)) \
+ $(use_enable srp) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ emake
+
+ # Default location for java classes breaks OpenOffice (bug #60769).
+ # Thanks to axxo@gentoo.org for the solution.
+ cd "${S}"
+ if use java ; then
+ jar -cvf ${PN}.jar -C java $(find java -name "*.class")
+ fi
+
+ # Add testsaslauthd (bug #58768).
+ cd "${S}/saslauthd"
+ emake testsaslauthd
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /var/lib/sasl2 /etc/sasl2
+
+ if use sample ; then
+ docinto sample
+ dodoc sample/*.c
+ exeinto /usr/share/doc/${P}/sample
+ doexe sample/client sample/server
+ fi
+
+ # Default location for java classes breaks OpenOffice (bug #60769).
+ if use java ; then
+ java-pkg_dojar ${PN}.jar
+ java-pkg_regso "${D}/usr/$(get_libdir)/libjavasasl.so"
+ # hackish, don't wanna dig through makefile
+ rm -Rf "${D}/usr/$(get_libdir)/java"
+ docinto "java"
+ dodoc "${S}/java/README" "${FILESDIR}/java.README.gentoo" "${S}"/java/doc/*
+ dodir "/usr/share/doc/${PF}/java/Test"
+ insinto "/usr/share/doc/${PF}/java/Test"
+ doins "${S}"/java/Test/*.java
+ fi
+
+ docinto ""
+ dodoc AUTHORS ChangeLog NEWS README doc/TODO doc/*.txt
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*.html
+
+ docinto "saslauthd"
+ dodoc saslauthd/{AUTHORS,ChangeLog,LDAP_SASLAUTHD,NEWS,README}
+
+ newpamd "${FILESDIR}/saslauthd.pam-include" saslauthd
+
+ newinitd "${FILESDIR}/pwcheck.rc6" pwcheck
+
+ newinitd "${FILESDIR}/saslauthd2.rc6" saslauthd
+ newconfd "${FILESDIR}/saslauthd-${SASLAUTHD_CONF_VER}.conf" saslauthd
+
+ newsbin "${S}/saslauthd/testsaslauthd" testsaslauthd
+
+ use static-libs || find "${D}"/usr/lib*/sasl2 -name 'lib*.la' -delete
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libsasl2.so.2.0.23
+}
+
+pkg_postinst () {
+ # Generate an empty sasldb2 with correct permissions.
+ if ( use berkdb || use gdbm ) && [[ ! -f "${ROOT}/etc/sasl2/sasldb2" ]] ; then
+ einfo "Generating an empty sasldb2 with correct permissions ..."
+ echo "p" | "${ROOT}/usr/sbin/saslpasswd2" -f "${ROOT}/etc/sasl2/sasldb2" -p login \
+ || die "Failed to generate sasldb2"
+ "${ROOT}/usr/sbin/saslpasswd2" -f "${ROOT}/etc/sasl2/sasldb2" -d login \
+ || die "Failed to delete temp user"
+ chown root:mail "${ROOT}/etc/sasl2/sasldb2" \
+ || die "Failed to chown ${ROOT}/etc/sasl2/sasldb2"
+ chmod 0640 "${ROOT}/etc/sasl2/sasldb2" \
+ || die "Failed to chmod ${ROOT}/etc/sasl2/sasldb2"
+ fi
+
+ if use authdaemond ; then
+ elog "You need to add a user running a service using Courier's"
+ elog "authdaemon to the 'mail' group. For example, do:"
+ elog " gpasswd -a postfix mail"
+ elog "to add the 'postfix' user to the 'mail' group."
+ fi
+
+ preserve_old_lib_notify /usr/$(get_libdir)/libsasl2.so.2.0.23
+}
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.25-service_keytabs.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.25-service_keytabs.patch
new file mode 100644
index 000000000000..117e8eb88802
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.25-service_keytabs.patch
@@ -0,0 +1,27 @@
+Bug #445932
+--- cmulocal/sasl2.m4 2011-09-02 12:58:00.000000000 +0000
++++ cmulocal/sasl2.m4 2012-12-05 08:37:16.425811319 +0000
+@@ -268,7 +268,11 @@
+
+ cmu_save_LIBS="$LIBS"
+ LIBS="$LIBS $GSSAPIBASE_LIBS"
+- AC_CHECK_FUNCS(gsskrb5_register_acceptor_identity)
++ AC_CHECK_FUNCS([gsskrb5_register_acceptor_identity], [],
++ [AC_CHECK_FUNCS([krb5_gss_register_acceptor_identity],
++ [AC_CHECK_HEADERS([gssapi/gssapi_krb5.h],
++ [AC_DEFINE([HAVE_GSSKRB5_REGISTER_ACCEPTOR_IDENTITY], [1])]
++ )])])
+ AC_CHECK_FUNCS(gss_decapsulate_token)
+ AC_CHECK_FUNCS(gss_encapsulate_token)
+ AC_CHECK_FUNCS(gss_oid_equal)
+--- plugins/gssapi.c 2012-12-05 09:03:31.000220161 +0000
++++ plugins/gssapi.c 2012-12-05 09:01:55.043380204 +0000
+@@ -50,7 +50,7 @@
+ #else
+ #include <gssapi/gssapi.h>
+ #endif
+-#ifdef KRB5_HEIMDAL
++#if defined (KRB5_HEIMDAL) || defined (HAVE_GSSAPI_GSSAPI_KRB5_H)
+ #include <gssapi/gssapi_krb5.h>
+ #endif
+