summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-15 18:17:12 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-15 18:17:12 +0000
commit603725a1eb92c9d48e19d50a075991ab3ab5be6b (patch)
tree77117cd5e49776d3a96f0a5142e26efb59695b41 /dev-libs/dmalloc/dmalloc-5.5.2-r3.ebuild
parentFixed manifest (contained a .rej file) (diff)
downloadgentoo-2-603725a1eb92c9d48e19d50a075991ab3ab5be6b.tar.gz
gentoo-2-603725a1eb92c9d48e19d50a075991ab3ab5be6b.tar.bz2
gentoo-2-603725a1eb92c9d48e19d50a075991ab3ab5be6b.zip
Respect AR. Clean up patches.
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs/dmalloc/dmalloc-5.5.2-r3.ebuild')
-rw-r--r--dev-libs/dmalloc/dmalloc-5.5.2-r3.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/dev-libs/dmalloc/dmalloc-5.5.2-r3.ebuild b/dev-libs/dmalloc/dmalloc-5.5.2-r3.ebuild
deleted file mode 100644
index d679c1c779cc..000000000000
--- a/dev-libs/dmalloc/dmalloc-5.5.2-r3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.5.2-r3.ebuild,v 1.9 2013/02/07 21:50:56 ulm Exp $
-
-EAPI="3"
-
-inherit autotools eutils multilib
-
-DESCRIPTION="A Debug Malloc Library"
-HOMEPAGE="http://dmalloc.com"
-SRC_URI="http://dmalloc.com/releases/${P}.tgz"
-
-LICENSE="CC-BY-SA-3.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="threads"
-
-DEPEND="sys-apps/texinfo"
-RDEPEND=""
-
-src_prepare() {
- # - Build objects twice, once -fPIC for shared.
- # - Use DESTDIR.
- # - Fix SONAME and NEEDED.
- epatch "${FILESDIR}"/${P}-Makefile.in.patch
- # - Broken test, always returns false.
- epatch "${FILESDIR}"/${P}-cxx.patch
- # - Add threads support.
- use threads && epatch "${FILESDIR}"/${P}-threads.patch
- # Respect CFLAGS/LDFLAGS. #337429
- sed -i Makefile.in \
- -e '/libdmalloc/ s:$(CC):& $(CFLAGS) $(LDFLAGS):g' \
- || die "sed Makefile.in"
- # - Run autoconf for -cxx.patch.
- eautoconf
-}
-
-src_configure() {
- econf --enable-cxx --enable-shlib \
- $(use_enable threads) || die "econf failed!"
-}
-
-src_compile() {
- emake || die "emake failed!"
- cd docs && makeinfo dmalloc.texi
-}
-
-src_test() {
- emake heavy || die "emake check failed!"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed!"
-
- newdoc ChangeLog.1 ChangeLog
- dodoc NEWS README docs/NOTES docs/TODO
- insinto /usr/share/doc/${PF}
- doins docs/dmalloc.pdf
- dohtml RELEASE.html docs/dmalloc.html
- doinfo docs/dmalloc.info
-
- # add missing symlinks, lazy
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so
- for lib in cxx th thcxx; do
- dosym lib${PN}${lib}.so.${PV} /usr/$(get_libdir)/lib${PN}${lib}.so
- done
-}