summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 02:37:59 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 02:37:59 +0000
commit182ab02b5e996b73cb7f154ba81a1e32baa5862e (patch)
treef5e432a9ecaeb8c1a3d65ef528493bba55a77a88 /dev-libs/ffcall
parentadd inherit eutils (diff)
downloadgentoo-2-182ab02b5e996b73cb7f154ba81a1e32baa5862e.tar.gz
gentoo-2-182ab02b5e996b73cb7f154ba81a1e32baa5862e.tar.bz2
gentoo-2-182ab02b5e996b73cb7f154ba81a1e32baa5862e.zip
add inherit eutils
Diffstat (limited to 'dev-libs/ffcall')
-rw-r--r--dev-libs/ffcall/ffcall-1.8d.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-libs/ffcall/ffcall-1.8d.ebuild b/dev-libs/ffcall/ffcall-1.8d.ebuild
index 27c3f67e18f6..f1bc470ccfcf 100644
--- a/dev-libs/ffcall/ffcall-1.8d.ebuild
+++ b/dev-libs/ffcall/ffcall-1.8d.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.12 2004/02/15 12:08:52 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.13 2004/04/16 02:35:35 vapier Exp $
+
+inherit eutils
DESCRIPTION="foreign function call libraries"
-SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/directory/ffcall.html"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${P}.tar.gz"
# "Ffcall is under GNU GPL. As a special exception, if used in GNUstep
# or in derivate works of GNUstep, the included parts of ffcall are
@@ -15,12 +17,10 @@ KEYWORDS="x86 sparc ~hppa ~alpha ~ppc"
DEPEND="virtual/glibc"
-
src_unpack() {
unpack ${A}
- #Fix hppa asm
- use hppa && (cd ${S}; epatch ${FILESDIR}/ffcall_hppa_1.8-4.2.diff.gz)
-
+ cd ${S}
+ use hppa && epatch ${FILESDIR}/ffcall_hppa_1.8-4.2.diff.gz
}
src_compile() {
@@ -28,13 +28,13 @@ src_compile() {
# alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
# doesn't work in the Makefile (29 Jan 2004 agriffis)
local cpu_setting
- [[ $ARCH == alpha ]] && cpu_setting='CPU=alpha'
+ [ "${ARCH}" == "alpha" ] && cpu_setting='CPU=alpha'
econf || die "./configure failed"
make ${cpu_setting} || die
}
-src_install () {
+src_install() {
dodoc ChangeLog NEWS README
dohtml avcall/avcall.html \
callback/callback.html \