summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-29 00:53:10 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-29 00:53:10 +0000
commit7c2a32916f7e6a93a02b8d18c651261cbeba1e5a (patch)
treea5995347a8d91977607fc797fe61741b4e31a96b /dev-libs/glib
parentfix aclocal warnings (diff)
downloadgentoo-2-7c2a32916f7e6a93a02b8d18c651261cbeba1e5a.tar.gz
gentoo-2-7c2a32916f7e6a93a02b8d18c651261cbeba1e5a.tar.bz2
gentoo-2-7c2a32916f7e6a93a02b8d18c651261cbeba1e5a.zip
fix m4 warnings
(Portage version: 2.0.51.20-r5)
Diffstat (limited to 'dev-libs/glib')
-rw-r--r--dev-libs/glib/files/glib-1.2.10-m4.patch9
-rw-r--r--dev-libs/glib/glib-1.2.10-r5.ebuild30
2 files changed, 20 insertions, 19 deletions
diff --git a/dev-libs/glib/files/glib-1.2.10-m4.patch b/dev-libs/glib/files/glib-1.2.10-m4.patch
new file mode 100644
index 000000000000..f57ecf7c11f9
--- /dev/null
+++ b/dev-libs/glib/files/glib-1.2.10-m4.patch
@@ -0,0 +1,9 @@
+Fix aclocal warning:
+/usr/share/aclocal/glib.m4:8: warning: underquoted definition of AM_PATH_GLIB
+--- glib-1.2.10/glib.m4
++++ glib-1.2.10/glib.m4
+@@ -7,3 +7,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_GLIB,
++AC_DEFUN([AM_PATH_GLIB],
+ [dnl
diff --git a/dev-libs/glib/glib-1.2.10-r5.ebuild b/dev-libs/glib/glib-1.2.10-r5.ebuild
index 25993a7f1edf..904789fab629 100644
--- a/dev-libs/glib/glib-1.2.10-r5.ebuild
+++ b/dev-libs/glib/glib-1.2.10-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.41 2005/04/07 19:09:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-1.2.10-r5.ebuild,v 1.42 2005/04/29 00:53:10 vapier Exp $
-inherit libtool flag-o-matic eutils gnuconfig
+inherit libtool flag-o-matic eutils
DESCRIPTION="The GLib library of C routines"
HOMEPAGE="http://www.gtk.org/"
@@ -11,32 +11,24 @@ SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="1"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 ppc-macos s390 sh sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc x86"
IUSE="hardened"
-DEPEND="virtual/libc"
+DEPEND=""
src_unpack() {
unpack ${A}
+ cd "${S}"
- # Allow glib to build with gcc-3.4.x #47047
- epatch ${FILESDIR}/${P}-gcc34-fix.patch
+ epatch "${FILESDIR}"/${P}-m4.patch
- use ppc64 && gnuconfig_update
+ # Allow glib to build with gcc-3.4.x #47047
+ epatch "${FILESDIR}"/${P}-gcc34-fix.patch
uclibctoolize
-
- if use ppc-macos; then
- darwintoolize
- gnuconfig_update
- fi
-
- if use ppc64 && use hardened; then
- replace-flags -O[2-3] -O1
- fi
-
+ use ppc-macos && darwintoolize
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
append-ldflags -ldl
-
}
src_compile() {
@@ -60,7 +52,7 @@ src_install() {
dodoc AUTHORS ChangeLog README* INSTALL NEWS
dohtml -r docs
- cd ${D}/usr/$(get_libdir) || die
+ cd "${D}"/usr/$(get_libdir) || die
if use ppc-macos ; then
chmod 755 libgmodule-1.2.*.dylib
else