summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2012-12-21 16:40:50 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2012-12-21 16:40:50 +0000
commit442ec3cae34d7a81da8054e772f9f5d67d2c9884 (patch)
treecff18b77d23f62b581dec27b4a2b43c3c169385b /dev-libs/icu
parentMask >=dev-libs/icu-50.1.1 for testing to avoid drama like bug #439892. (diff)
downloadgentoo-2-442ec3cae34d7a81da8054e772f9f5d67d2c9884.tar.gz
gentoo-2-442ec3cae34d7a81da8054e772f9f5d67d2c9884.tar.bz2
gentoo-2-442ec3cae34d7a81da8054e772f9f5d67d2c9884.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 30427902)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog7
-rw-r--r--dev-libs/icu/icu-50.1.1.ebuild119
2 files changed, 125 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 8f7b8154f154..f77d835c0fc1 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.220 2012/12/10 17:24:54 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.221 2012/12/21 16:40:50 phajdan.jr Exp $
+
+*icu-50.1.1 (21 Dec 2012)
+
+ 21 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> +icu-50.1.1.ebuild:
+ Version bump.
10 Dec 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> -icu-50.1.ebuild:
Remove version with known C++11 problems.
diff --git a/dev-libs/icu/icu-50.1.1.ebuild b/dev-libs/icu/icu-50.1.1.ebuild
new file mode 100644
index 000000000000..428c7152d013
--- /dev/null
+++ b/dev-libs/icu/icu-50.1.1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-50.1.1.ebuild,v 1.1 2012/12/21 16:40:50 phajdan.jr Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs base autotools
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+RDEPEND="!dev-libs/icu:0/50"
+DEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ )
+"
+
+S="${WORKDIR}/${PN}/source"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
+ "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
+)
+
+src_prepare() {
+ local variable
+
+ base_src_prepare
+
+ # Do not hardcode flags in icu-config and icu-*.pc files.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed \
+ -e "/^${variable} =.*/s: *@${variable}@\( *$\)\?::" \
+ -i config/icu.pc.in \
+ -i config/Makefile.inc.in \
+ || die
+ done
+
+ # Disable renaming as it is stupind thing to do
+ sed -i \
+ -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
+ common/unicode/uconfig.h || die
+
+ # Fix linking of icudata
+ sed -i \
+ -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
+ config/mh-linux || die
+
+ # Append doxygen configuration to configure
+ sed -i \
+ -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
+ configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ local cross_opts
+
+ # bootstrap for cross compilation
+ if tc-is-cross-compiler; then
+ CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
+ CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
+ RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
+ ./configure --disable-renaming --disable-debug \
+ --disable-samples --enable-static || die
+ emake
+ mkdir -p "${WORKDIR}/host/"
+ cp -a {bin,lib,config,tools} "${WORKDIR}/host/"
+ emake clean
+
+ cross_opts="--with-cross-build=${WORKDIR}/host"
+ fi
+
+ econf \
+ --disable-renaming \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static) \
+ ${cross_opts}
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen -u Doxyfile || die
+ doxygen Doxyfile || die
+ fi
+}
+
+src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 VERBOSE="1" check
+}
+
+src_install() {
+ default
+
+ dohtml ../readme.html
+
+ use doc && dohtml -p api -r doc/html/
+}