summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-02 22:31:41 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-02 22:31:41 +0000
commitc32682b2d0acc6007ce455f0fc0ec85b9aa3ee4d (patch)
tree83988624c8cff859924a8e881b7d6859f728506b /dev-libs/icu
parentDelete older ebuilds. (diff)
downloadgentoo-2-c32682b2d0acc6007ce455f0fc0ec85b9aa3ee4d.tar.gz
gentoo-2-c32682b2d0acc6007ce455f0fc0ec85b9aa3ee4d.tar.bz2
gentoo-2-c32682b2d0acc6007ce455f0fc0ec85b9aa3ee4d.zip
Version bump.
(Portage version: 2.2_rc88_p72/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/icu')
-rw-r--r--dev-libs/icu/ChangeLog13
-rw-r--r--dev-libs/icu/icu-4.4.2.ebuild80
2 files changed, 92 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 13994075bbe5..97b3b274b9c4 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.121 2010/09/30 20:35:42 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.122 2010/10/02 22:31:41 arfrever Exp $
+
+*icu-4.4.2 (02 Oct 2010)
+
+ 02 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -icu-4.0.1.ebuild, -files/icu-4.0.1-TestDisplayNamesMeta.patch,
+ -files/icu-4.0.1-fix_parallel_building.patch, -icu-4.2.1.ebuild,
+ -files/icu-4.2.1-fix_misoptimizations.patch,
+ -files/icu-4.2.1-pkgdata.patch,
+ -files/icu-4.2.1-pkgdata-build_data_without_assembly.patch,
+ +icu-4.4.2.ebuild:
+ Version bump.
30 Sep 2010; Brent Baude <ranger@gentoo.org> icu-4.4.1.ebuild:
stable ppc64, bug 322297
diff --git a/dev-libs/icu/icu-4.4.2.ebuild b/dev-libs/icu/icu-4.4.2.ebuild
new file mode 100644
index 000000000000..18c453d1c706
--- /dev/null
+++ b/dev-libs/icu/icu-4.4.2.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.4.2.ebuild,v 1.1 2010/10/02 22:31:41 arfrever Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic versionator
+
+MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
+MICRO_VERSION="$(get_version_component_range 3)"
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+
+BASE_URI="http://download.icu-project.org/files/icu4c/${PV}"
+DOCS_BASE_URI="http://download.icu-project.org/files/icu4c/${MAJOR_MINOR_VERSION}"
+SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
+DOCS_ARCHIVE="icu4c-${MAJOR_MINOR_VERSION//./_}-docs.zip"
+
+SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
+ doc? ( ${DOCS_BASE_URI}/${DOCS_ARCHIVE} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+QA_DT_NEEDED="/usr/lib.*/libicudata.so.${MAJOR_MINOR_VERSION/./}.${MICRO_VERSION:-0}"
+
+src_unpack() {
+ unpack "${SRC_ARCHIVE}"
+ if use doc; then
+ mkdir docs
+ pushd docs > /dev/null
+ unpack "${DOCS_ARCHIVE}"
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
+ # Bug 202059
+ # https://bugs.icu-project.org/trac/ticket/6102
+ for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" || die "sed failed"
+ done
+
+ epatch "${FILESDIR}/${PN}-4.4.1-pkgdata.patch"
+ epatch "${FILESDIR}/${PN}-4.4.1-et_EE.patch"
+ epatch "${FILESDIR}/${PN}-4.4.1-arm.patch"
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static)
+}
+
+src_test() {
+ emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/api
+ doins -r "${WORKDIR}/docs/"*
+ fi
+}