summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2011-04-13 11:03:41 +0000
committerRyan Hill <dirtyepic@gentoo.org>2011-04-13 11:03:41 +0000
commit3f8bdc0af1084262f21ed032a74358f573d0d5f3 (patch)
treef91d289a9c3e1e060614a8c6a4a9ae71a7d52c68 /dev-libs/isl
parentAdd missing liboil dependency to older version, bug 363183. Remove ancient ve... (diff)
downloadgentoo-2-3f8bdc0af1084262f21ed032a74358f573d0d5f3.tar.gz
gentoo-2-3f8bdc0af1084262f21ed032a74358f573d0d5f3.tar.bz2
gentoo-2-3f8bdc0af1084262f21ed032a74358f573d0d5f3.zip
Version bump.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/isl')
-rw-r--r--dev-libs/isl/ChangeLog8
-rw-r--r--dev-libs/isl/files/isl-0.06-parallel-py.patch35
-rw-r--r--dev-libs/isl/isl-0.06.ebuild23
3 files changed, 65 insertions, 1 deletions
diff --git a/dev-libs/isl/ChangeLog b/dev-libs/isl/ChangeLog
index aa32a35b2f0a..6d040a18389f 100644
--- a/dev-libs/isl/ChangeLog
+++ b/dev-libs/isl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/isl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/isl/ChangeLog,v 1.2 2011/01/07 23:53:27 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/isl/ChangeLog,v 1.3 2011/04/13 11:03:41 dirtyepic Exp $
+
+*isl-0.06 (13 Apr 2011)
+
+ 13 Apr 2011; Ryan Hill <dirtyepic@gentoo.org> +isl-0.06.ebuild,
+ +files/isl-0.06-parallel-py.patch:
+ Version bump.
*isl-0.05.1 (07 Jan 2011)
diff --git a/dev-libs/isl/files/isl-0.06-parallel-py.patch b/dev-libs/isl/files/isl-0.06-parallel-py.patch
new file mode 100644
index 000000000000..725f02b45e86
--- /dev/null
+++ b/dev-libs/isl/files/isl-0.06-parallel-py.patch
@@ -0,0 +1,35 @@
+Fix parallel install and move gdb python module out of libdir.
+
+http://groups.google.com/group/isl-development/browse_thread/thread/4fd13c45d3fd321e
+
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1814,7 +1814,8 @@ all-am: Makefile $(LTLIBRARIES) $(PROGRAMS) $(DATA) $(HEADERS) \
+ isl_config.h
+ installdirs: installdirs-recursive
+ installdirs-am:
+- for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(pkgincludedir)" "$(DESTDIR)$(pkgincludedir)"; do \
++ for dir in "$(DESTDIR)$(libdir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(pkgincludedir)" \
++ "$(DESTDIR)$(pkgincludedir)" "$(DESTDIR)usr/share/gdb/auto-load$(libdir)" ; do \
+ test -z "$$dir" || $(MKDIR_P) "$$dir"; \
+ done
+ install: install-recursive
+@@ -1954,14 +1955,14 @@ dist-hook:
+ gitversion.h: @GIT_HEAD@
+ echo '#define GIT_HEAD_ID "'@GIT_HEAD_VERSION@'"' > $@
+
+-install-data-local: $(srcdir)/isl.py
++install-data-local: $(srcdir)/isl.py installdirs
+ @libisl=`sed -ne "/^library_names=/{s/.*='//;s/'$$//;s/ .*//;p}" \
+ $(builddir)/libisl.la`; \
+ case $$libisl in \
+ '') echo Cannot find isl library name. GDB bindings not installed.;; \
+ *) echo $(INSTALL_DATA) $(srcdir)/isl.py \
+- $(DESTDIR)$(libdir)/$$libisl-gdb.py; \
+- $(INSTALL_DATA) $(srcdir)/isl.py $(DESTDIR)$(libdir)/$$libisl-gdb.py; esac
++ $(DESTDIR)usr/share/gdb/auto-load$(libdir)/$$libisl-gdb.py; \
++ $(INSTALL_DATA) $(srcdir)/isl.py $(DESTDIR)usr/share/gdb/auto-load$(libdir)/$$libisl-gdb.py; esac
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/dev-libs/isl/isl-0.06.ebuild b/dev-libs/isl/isl-0.06.ebuild
new file mode 100644
index 000000000000..22d5201ad180
--- /dev/null
+++ b/dev-libs/isl/isl-0.06.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/isl/isl-0.06.ebuild,v 1.1 2011/04/13 11:03:40 dirtyepic Exp $
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="A library for manipulating integer points bounded by affine constraints."
+HOMEPAGE="http://www.kotnet.org/~skimo/isl/"
+SRC_URI="http://www.kotnet.org/~skimo/isl/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="dev-libs/gmp"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog AUTHORS doc/manual.pdf )
+PATCHES=( "${FILESDIR}"/${P}-parallel-py.patch )
+AUTOTOOLS_IN_SOURCE_BUILD="1"