summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2012-04-19 18:49:14 +0000
committerIan Whyman <thev00d00@gentoo.org>2012-04-19 18:49:14 +0000
commit447258641f70fe2107a80ca2d30b818ac2e651e4 (patch)
treec5931ed04bc925a6acbb8f8cfa34616469cc6d22 /dev-libs/libcec
parentCleaning out old version. (diff)
downloadgentoo-2-447258641f70fe2107a80ca2d30b818ac2e651e4.tar.gz
gentoo-2-447258641f70fe2107a80ca2d30b818ac2e651e4.tar.bz2
gentoo-2-447258641f70fe2107a80ca2d30b818ac2e651e4.zip
Bump to latest
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libcec')
-rw-r--r--dev-libs/libcec/ChangeLog7
-rw-r--r--dev-libs/libcec/libcec-1.6.1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-libs/libcec/ChangeLog b/dev-libs/libcec/ChangeLog
index 2731ff76c2ec..c0499f03e717 100644
--- a/dev-libs/libcec/ChangeLog
+++ b/dev-libs/libcec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libcec
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcec/ChangeLog,v 1.2 2012/04/01 22:04:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcec/ChangeLog,v 1.3 2012/04/19 18:49:14 thev00d00 Exp $
+
+*libcec-1.6.1 (19 Apr 2012)
+
+ 19 Apr 2012; Ian Whyman <thev00d00@gentoo.org> +libcec-1.6.1.ebuild:
+ Bump to latest
01 Apr 2012; Mike Frysinger <vapier@gentoo.org> libcec-1.5.2.ebuild:
Add IUSE=static-libs, fix linux config checking to not die, drop incorrect
diff --git a/dev-libs/libcec/libcec-1.6.1.ebuild b/dev-libs/libcec/libcec-1.6.1.ebuild
new file mode 100644
index 000000000000..38c815070385
--- /dev/null
+++ b/dev-libs/libcec/libcec-1.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libcec/libcec-1.6.1.ebuild,v 1.1 2012/04/19 18:49:14 thev00d00 Exp $
+
+EAPI="4"
+
+inherit autotools linux-info vcs-snapshot
+
+DESCRIPTION="Library for communicating with the Pulse-Eight USB HDMI-CEC Adaptor"
+HOMEPAGE="http://libcec.pulse-eight.com"
+SRC_URI="http://github.com/Pulse-Eight/${PN}/tarball/${P} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=sys-fs/udev-151"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+CONFIG_CHECK="~USB_ACM"
+
+src_prepare() {
+ sed -i '/^CXXFLAGS/s:-fPIC::' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -delete
+}