summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-03-31 16:40:34 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-03-31 16:40:34 +0000
commit75c456e66494828703040a443760b8d46d4632a2 (patch)
treeb2e9df1435ed8a4cfd5595df1926f3b1457d902e /dev-libs/libdbusmenu
parentstable x86, bug 309693 (diff)
downloadgentoo-2-75c456e66494828703040a443760b8d46d4632a2.tar.gz
gentoo-2-75c456e66494828703040a443760b8d46d4632a2.tar.bz2
gentoo-2-75c456e66494828703040a443760b8d46d4632a2.zip
Initial commit, moved from kde overlay, thanks to Dennis Schridde
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libdbusmenu')
-rw-r--r--dev-libs/libdbusmenu/ChangeLog12
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-1-optional-gtk.patch37
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch44
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-no-gobject-introspection.patch10
-rw-r--r--dev-libs/libdbusmenu/libdbusmenu-0.2.8.ebuild53
-rw-r--r--dev-libs/libdbusmenu/metadata.xml5
6 files changed, 161 insertions, 0 deletions
diff --git a/dev-libs/libdbusmenu/ChangeLog b/dev-libs/libdbusmenu/ChangeLog
new file mode 100644
index 000000000000..aa31c449a01a
--- /dev/null
+++ b/dev-libs/libdbusmenu/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-libs/libdbusmenu
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu/ChangeLog,v 1.1 2010/03/31 16:40:34 tampakrap Exp $
+
+*libdbusmenu-0.2.8 (31 Mar 2010)
+
+ 31 Mar 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +libdbusmenu-0.2.8.ebuild, +files/libdbusmenu-0.2.8-1-optional-gtk.patch,
+ +files/libdbusmenu-0.2.8-2-optional-tests.patch,
+ +files/libdbusmenu-0.2.8-no-gobject-introspection.patch, +metadata.xml:
+ Initial commit, moved from kde overlay, thanks to Dennis Schridde
+
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-1-optional-gtk.patch b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-1-optional-gtk.patch
new file mode 100644
index 000000000000..2eb0eedcb870
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-1-optional-gtk.patch
@@ -0,0 +1,37 @@
+--- configure.ac.orig 2010-03-31 12:56:17.483842274 +0200
++++ configure.ac 2010-03-31 12:57:25.783592956 +0200
+@@ -42,10 +42,17 @@
+
+ GTK_REQUIRED_VERSION=2.16
+
++AC_ARG_ENABLE([gtk],
++ AC_HELP_STRING([--disable-gtk], [Disable libindicate-gtk library]),
++ [enable_gtk=$enableval], enable_gtk=auto)
++AM_CONDITIONAL([WANT_LIBDBUSMENUGTK], [test "x$enable_gtk" != "xno"])
++
++if test "x$enable_gtk" != "xno"; then
+ PKG_CHECK_MODULES(DBUSMENUGTK, gtk+-2.0 >= $GTK_REQUIRED_VERSION
+ glib-2.0 >= $GLIB_REQUIRED_VERSION
+ dbus-glib-1 >= $DBUS_REQUIRED_VERSION
+ libxml-2.0 >= $XML_REQUIRED_VERSION)
++fi
+
+ AC_SUBST(DBUSMENUGTK_CFLAGS)
+ AC_SUBST(DBUSMENUGTK_LIBS)
+--- Makefile.am.orig 2010-03-31 13:01:21.871844609 +0200
++++ Makefile.am 2010-03-31 13:19:34.896594837 +0200
+@@ -5,10 +5,13 @@
+
+ SUBDIRS = \
+ libdbusmenu-glib \
+- libdbusmenu-gtk \
+ tools \
+ tests \
+ po
+
++if WANT_LIBDBUSMENUGTK
++SUBDIRS += libdbusmenu-gtk
++endif
++
+ DISTCHECK_CONFIGURE_FLAGS = --enable-introspection
+
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch
new file mode 100644
index 000000000000..1733c0576a4e
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-2-optional-tests.patch
@@ -0,0 +1,44 @@
+--- configure.ac.orig 2010-03-31 12:56:17.483842274 +0200
++++ configure.ac 2010-03-31 13:08:36.291843605 +0200
+@@ -56,7 +56,14 @@
+
+ JSON_GLIB_REQUIRED_VERSION=0.6.0
+
++AC_ARG_ENABLE([tests],
++ AC_HELP_STRING([--disable-tests], [Disable tests]),
++ [enable_tests=$enableval], enable_tests=auto)
++AM_CONDITIONAL([WANT_TESTS], [test "x$enable_tests" != "xno"])
++
++if test "x$enable_tests" != "xno"; then
+ PKG_CHECK_MODULES(DBUSMENUTESTS, json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION)
++fi
+
+ AC_SUBST(DBUSMENUTESTS_CFLAGS)
+ AC_SUBST(DBUSMENUTESTS_LIBS)
+--- Makefile.am.orig 2010-03-31 13:01:21.871844609 +0200
++++ Makefile.am 2010-03-31 13:33:03.953843279 +0200
+@@ -7,7 +7,10 @@
+ libdbusmenu-glib \
+ tools \
+- tests \
+ po
+
++if WANT_TESTS
++SUBDIRS += tests
++endif
++
+ DISTCHECK_CONFIGURE_FLAGS = --enable-introspection
+
+--- tools/Makefile.am.orig 2010-03-31 13:44:57.924843955 +0200
++++ tools/Makefile.am 2010-03-31 13:47:19.073593832 +0200
+@@ -1,5 +1,9 @@
+
+-SUBDIRS = testapp
++SUBDIRS =
++
++if WANT_TESTS
++SUBDIRS += testapp
++endif
+
+ libexec_PROGRAMS = dbusmenu-dumper
+
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-no-gobject-introspection.patch b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-no-gobject-introspection.patch
new file mode 100644
index 000000000000..8e76ca8da47d
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-0.2.8-no-gobject-introspection.patch
@@ -0,0 +1,10 @@
+--- configure.ac.orig 2010-03-31 12:42:16.497596552 +0200
++++ configure.ac 2010-03-31 12:42:47.001595062 +0200
+@@ -74,6 +74,6 @@
+ ###########################
+
+-GOBJECT_INTROSPECTION_CHECK([0.6.7])
++AM_CONDITIONAL([HAVE_INTROSPECTION], [false])
+
+ ###########################
+ # GTK Doc
diff --git a/dev-libs/libdbusmenu/libdbusmenu-0.2.8.ebuild b/dev-libs/libdbusmenu/libdbusmenu-0.2.8.ebuild
new file mode 100644
index 000000000000..94699620977d
--- /dev/null
+++ b/dev-libs/libdbusmenu/libdbusmenu-0.2.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdbusmenu/libdbusmenu-0.2.8.ebuild,v 1.1 2010/03/31 16:40:34 tampakrap Exp $
+
+EAPI=2
+
+inherit autotools eutils versionator
+
+DESCRIPTION="Library to pass menu structure across DBus"
+HOMEPAGE="https://launchpad.net/libdbusmenu/"
+SRC_URI="http://launchpad.net/dbusmenu/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk test"
+
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/dbus-glib
+ dev-libs/libxml2:2
+ gtk? ( x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/json-glib )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Make libdbusmenu-gtk library optional, launchpad-bug #552530
+ epatch "${FILESDIR}/${P}-1-optional-gtk.patch"
+ # Make tests optional, launchpad-bug #552526
+ epatch "${FILESDIR}/${P}-2-optional-tests.patch"
+ # Fixup undeclared HAVE_INTROSPECTION, launchpad-bug #552538
+ epatch "${FILESDIR}/${P}-no-gobject-introspection.patch"
+ # Drop -Werror in a release
+ sed -e 's:-Werror::g' -i libdbusmenu-glib/Makefile.am libdbusmenu-gtk/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gtk) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ emake check || die "testsuite failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS || die "dodoc failed"
+}
diff --git a/dev-libs/libdbusmenu/metadata.xml b/dev-libs/libdbusmenu/metadata.xml
new file mode 100644
index 000000000000..8d36d5b01cd2
--- /dev/null
+++ b/dev-libs/libdbusmenu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>