summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-06-22 13:27:18 +0000
committerJeroen Roovers <jer@gentoo.org>2013-06-22 13:27:18 +0000
commit8a1e8b82e3cab071826b9e21cc65aed7987b41fd (patch)
tree49b95d3a8e76bcaddf082c4c30e12496f27b7b75 /dev-libs/libdnet
parentMask lotus-notes on multilib (diff)
downloadgentoo-2-8a1e8b82e3cab071826b9e21cc65aed7987b41fd.tar.gz
gentoo-2-8a1e8b82e3cab071826b9e21cc65aed7987b41fd.tar.bz2
gentoo-2-8a1e8b82e3cab071826b9e21cc65aed7987b41fd.zip
Fix building with system python3 (bug #473924 again). Remove unneeded variables.
(Portage version: 2.2.0_alpha183/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-libs/libdnet')
-rw-r--r--dev-libs/libdnet/ChangeLog6
-rw-r--r--dev-libs/libdnet/libdnet-1.12.ebuild15
2 files changed, 14 insertions, 7 deletions
diff --git a/dev-libs/libdnet/ChangeLog b/dev-libs/libdnet/ChangeLog
index 51edce883741..ea38714bdd18 100644
--- a/dev-libs/libdnet/ChangeLog
+++ b/dev-libs/libdnet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libdnet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/ChangeLog,v 1.64 2013/06/20 15:46:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/ChangeLog,v 1.65 2013/06/22 13:27:18 jer Exp $
+
+ 22 Jun 2013; Jeroen Roovers <jer@gentoo.org> libdnet-1.12.ebuild:
+ Fix building with system python3 (bug #473924 again). Remove unneeded
+ variables.
20 Jun 2013; Jeroen Roovers <jer@gentoo.org> libdnet-1.12.ebuild:
Fix building with python3 (bug #473924 by Willard Dawson).
diff --git a/dev-libs/libdnet/libdnet-1.12.ebuild b/dev-libs/libdnet/libdnet-1.12.ebuild
index d3b36480ff54..7e248ae04bec 100644
--- a/dev-libs/libdnet/libdnet-1.12.ebuild
+++ b/dev-libs/libdnet/libdnet-1.12.ebuild
@@ -1,15 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.12.ebuild,v 1.8 2013/06/20 15:46:40 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libdnet/libdnet-1.12.ebuild,v 1.9 2013/06/22 13:27:18 jer Exp $
EAPI=5
AT_M4DIR="config"
-AUTOTOOLS_AUTORECONF=1
-AUTOTOOLS_IN_SOURCE_BUILD=1
PYTHON_DEPEND="python? 2"
PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
-DISTUTILS_SINGLE_IMPL=true
inherit autotools distutils-r1 eutils
@@ -24,6 +21,7 @@ KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="ipv6 python static-libs test"
#DEPEND="test? ( dev-libs/check )"
+DEPEND="${PYTHON_DEPS}"
RESTRICT="test"
DOCS=( README THANKS TODO )
@@ -38,8 +36,12 @@ src_prepare() {
configure.in || die
sed -i -e 's|-L@libdir@ ||g' dnet-config.in || die
use ipv6 && epatch "${WORKDIR}/${P}.ipv6-1.patch"
+ sed -i -e '/^SUBDIRS/s|python||g' Makefile.am || die
eautoreconf
- use python && distutils-r1_src_prepare
+ if use python; then
+ cd python
+ distutils-r1_src_prepare
+ fi
}
src_configure() {
@@ -60,7 +62,8 @@ src_install() {
default
if use python; then
cd python
- distutils-r1_src_compile
+ unset DOCS
+ distutils-r1_src_install
fi
prune_libtool_files
}