summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-03-21 02:48:36 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-03-21 02:48:36 +0000
commitb0b68a3ca826c803aadda763f24fbbd5f4c546e3 (patch)
tree9f59e97682c533f867a125c732bc8c387e477335 /dev-libs/libev/libev-4.04.ebuild
parentdrop sparc keywords (diff)
downloadgentoo-2-b0b68a3ca826c803aadda763f24fbbd5f4c546e3.tar.gz
gentoo-2-b0b68a3ca826c803aadda763f24fbbd5f4c546e3.tar.bz2
gentoo-2-b0b68a3ca826c803aadda763f24fbbd5f4c546e3.zip
Version bumped, bug #355261.
(Portage version: 2.1.9.43/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libev/libev-4.04.ebuild')
-rw-r--r--dev-libs/libev/libev-4.04.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/libev/libev-4.04.ebuild b/dev-libs/libev/libev-4.04.ebuild
new file mode 100644
index 000000000000..eae055a0f859
--- /dev/null
+++ b/dev-libs/libev/libev-4.04.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-4.04.ebuild,v 1.1 2011/03/21 02:48:36 matsuu Exp $
+
+EAPI="3"
+
+inherit autotools eutils multilib
+
+MY_P="${P}"
+
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${MY_P}.tar.gz
+ http://dist.schmorp.de/libev/Attic/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="elibc_glibc static-libs"
+
+# Bug #283558
+DEPEND="elibc_glibc? ( >=sys-libs/glibc-2.9_p20081201 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/4.01-gentoo.patch"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README || die
+}
+
+pkg_preinst() {
+ preserve_old_lib /usr/$(get_libdir)/libev.so.3.0.0
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /usr/$(get_libdir)/libev.so.3.0.0
+}