summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-08 23:55:42 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-08 23:55:42 +0000
commit6c8ac9a3895c3cf189fbcf14be70c0c2a756c3c0 (patch)
tree8df6b4c9ccec9a122b1c19cef77d46299b4d4d70 /dev-libs/libexplain
parentRemove old. (diff)
downloadgentoo-2-6c8ac9a3895c3cf189fbcf14be70c0c2a756c3c0.tar.gz
gentoo-2-6c8ac9a3895c3cf189fbcf14be70c0c2a756c3c0.tar.bz2
gentoo-2-6c8ac9a3895c3cf189fbcf14be70c0c2a756c3c0.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-libs/libexplain')
-rw-r--r--dev-libs/libexplain/ChangeLog7
-rw-r--r--dev-libs/libexplain/libexplain-1.4.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-libs/libexplain/ChangeLog b/dev-libs/libexplain/ChangeLog
index b9de0cc05273..86114b3c51aa 100644
--- a/dev-libs/libexplain/ChangeLog
+++ b/dev-libs/libexplain/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libexplain
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.27 2014/02/27 12:52:34 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/ChangeLog,v 1.28 2014/03/08 23:55:42 radhermit Exp $
+
+*libexplain-1.4 (08 Mar 2014)
+
+ 08 Mar 2014; Tim Harder <radhermit@gentoo.org> +libexplain-1.4.ebuild:
+ Version bump.
27 Feb 2014; Chema Alonso <nimiux@gentoo.org> libexplain-1.3.ebuild:
Stable for amd64 wrt bug #499534
diff --git a/dev-libs/libexplain/libexplain-1.4.ebuild b/dev-libs/libexplain/libexplain-1.4.ebuild
new file mode 100644
index 000000000000..66a85a76856e
--- /dev/null
+++ b/dev-libs/libexplain/libexplain-1.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libexplain/libexplain-1.4.ebuild,v 1.1 2014/03/08 23:55:42 radhermit Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library which may be used to explain Unix and Linux system call errors"
+HOMEPAGE="http://libexplain.sourceforge.net/"
+SRC_URI="http://libexplain.sourceforge.net/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3 LGPL-3"
+IUSE="doc static-libs"
+
+RDEPEND="
+ sys-libs/libcap
+ >=sys-libs/glibc-2.11
+ sys-process/lsof"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.35
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+"
+
+DOCS=( README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.45-configure.patch
+)
+
+src_prepare() {
+ # Portage incompatible test
+ sed \
+ -e '/t0524a/d' \
+ -e '/t0363a/d' \
+ -i Makefile.in || die
+
+ cp "${S}"/etc/configure.ac "${S}" || die
+
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && autotools-utils_src_compile all-doc
+}