summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-11-25 16:25:19 +0000
committerRémi Cardona <remi@gentoo.org>2008-11-25 16:25:19 +0000
commit8453910d79db7cb669bc57d6ccd7392380ed4393 (patch)
tree8813a4c30c3546698c4de92bb3cdf13aadea4ac7 /dev-libs/libgamin
parentAdd patch to fix linking order, closes bug #246862. (diff)
downloadgentoo-2-8453910d79db7cb669bc57d6ccd7392380ed4393.tar.gz
gentoo-2-8453910d79db7cb669bc57d6ccd7392380ed4393.tar.bz2
gentoo-2-8453910d79db7cb669bc57d6ccd7392380ed4393.zip
dev-libs/libgamin: fix python installation (see bug #248737)
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'dev-libs/libgamin')
-rw-r--r--dev-libs/libgamin/ChangeLog7
-rw-r--r--dev-libs/libgamin/libgamin-0.1.10-r1.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/dev-libs/libgamin/ChangeLog b/dev-libs/libgamin/ChangeLog
index 3a3813c488cf..c6597d29263a 100644
--- a/dev-libs/libgamin/ChangeLog
+++ b/dev-libs/libgamin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libgamin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/ChangeLog,v 1.1 2008/11/24 23:07:56 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/ChangeLog,v 1.2 2008/11/25 16:25:19 remi Exp $
+
+*libgamin-0.1.10-r1 (25 Nov 2008)
+
+ 25 Nov 2008; Rémi Cardona <remi@gentoo.org> +libgamin-0.1.10-r1.ebuild:
+ fix python installation (see bug #248737)
*libgamin-0.1.10 (24 Nov 2008)
diff --git a/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild b/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild
new file mode 100644
index 000000000000..f8fb59e15a7a
--- /dev/null
+++ b/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild,v 1.1 2008/11/25 16:25:19 remi Exp $
+
+inherit autotools eutils flag-o-matic libtool python
+
+MY_PN=${PN//lib/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/${MY_PN}/sources/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug kernel_linux python"
+
+RESTRICT="test" # need gam-server
+
+RDEPEND="python? ( virtual/python )
+ !<app-admin/gamin-0.1.10"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix compile warnings; bug #188923
+ epatch "${FILESDIR}/${MY_PN}-0.1.9-freebsd.patch"
+
+ # Fix collision problem due to intermediate library, upstream bug #530635
+ epatch "${FILESDIR}/${P}-noinst-lib.patch"
+
+ # autoconf is required as the user-cflags patch modifies configure.in
+ # however, elibtoolize is also required, so when the above patch is
+ # removed, replace the following call with a call to elibtoolize
+ eautoreconf
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_compile() {
+ # fixes bug #225403
+ #append-flags "-D_GNU_SOURCE"
+
+ econf --disable-debug \
+ --disable-server \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable debug debug-api) \
+ $(use_with python)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "installation failed"
+
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
+ dohtml doc/*
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages
+ fi
+}