summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2014-08-08 16:19:32 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2014-08-08 16:19:32 +0000
commit579c286afc0135bbef809c4573915caa22bc4745 (patch)
tree61032d928d8828c2b6d3cd5f00b60edfe620c074 /dev-libs/libgcrypt
parentVersion bump. (diff)
downloadgentoo-2-579c286afc0135bbef809c4573915caa22bc4745.tar.gz
gentoo-2-579c286afc0135bbef809c4573915caa22bc4745.tar.bz2
gentoo-2-579c286afc0135bbef809c4573915caa22bc4745.zip
Defer multilib changes, bug#513718
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'dev-libs/libgcrypt')
-rw-r--r--dev-libs/libgcrypt/ChangeLog8
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.5.4-r100.ebuild57
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.5.4.ebuild26
3 files changed, 72 insertions, 19 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
index dd3361927de2..0d7977364511 100644
--- a/dev-libs/libgcrypt/ChangeLog
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libgcrypt
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.209 2014/08/08 08:57:41 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.210 2014/08/08 16:19:32 alonbl Exp $
+
+*libgcrypt-1.5.4-r100 (08 Aug 2014)
+
+ 08 Aug 2014; Alon Bar-Lev <alonbl@gentoo.org> +libgcrypt-1.5.4-r100.ebuild,
+ libgcrypt-1.5.4.ebuild:
+ Defer multilib changes, bug#513718
*libgcrypt-1.5.4 (08 Aug 2014)
diff --git a/dev-libs/libgcrypt/libgcrypt-1.5.4-r100.ebuild b/dev-libs/libgcrypt/libgcrypt-1.5.4-r100.ebuild
new file mode 100644
index 000000000000..8319a5e121d6
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.5.4-r100.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.5.4-r100.ebuild,v 1.1 2014/08/08 16:19:32 alonbl Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-multilib
+
+DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 MIT"
+SLOT="11/11" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/libgpg-error-1.12[${MULTILIB_USEDEP}]
+ !dev-libs/libgcrypt:0/11
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
+ )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-uscore.patch
+ "${FILESDIR}"/${PN}-multilib-syspath.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --disable-padlock-support # bug 201917
+ --disable-dependency-tracking
+ --enable-noexecstack
+ --disable-O-flag-munging
+
+ # disabled due to various applications requiring privileges
+ # after libgcrypt drops them (bug #468616)
+ --without-capabilities
+
+ # http://trac.videolan.org/vlc/ticket/620
+ # causes bus-errors on sparc64-solaris
+ $([[ ${CHOST} == *86*-darwin* ]] && echo "--disable-asm")
+ $([[ ${CHOST} == sparcv9-*-solaris* ]] && echo "--disable-asm")
+ )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ rm -r "${ED%/}"/usr/{bin,include,lib*/*.so,share} || die
+}
diff --git a/dev-libs/libgcrypt/libgcrypt-1.5.4.ebuild b/dev-libs/libgcrypt/libgcrypt-1.5.4.ebuild
index b95b8dbf7405..593eb6a6f753 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.5.4.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.5.4.ebuild
@@ -1,27 +1,22 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.5.4.ebuild,v 1.1 2014/08/08 08:57:41 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.5.4.ebuild,v 1.2 2014/08/08 16:19:32 alonbl Exp $
EAPI=5
AUTOTOOLS_AUTORECONF=1
-inherit autotools-multilib
+inherit autotools-utils
DESCRIPTION="General purpose crypto library based on the code used in GnuPG"
HOMEPAGE="http://www.gnupg.org/"
SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
LICENSE="LGPL-2.1 MIT"
-SLOT="11/11" # subslot = soname major version
+SLOT="0/11" # subslot = soname major version
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RDEPEND=">=dev-libs/libgpg-error-1.12[${MULTILIB_USEDEP}]
- !dev-libs/libgcrypt:0/11
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20131008-r19
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32]
- )"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/libgpg-error-1.8"
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
@@ -37,6 +32,7 @@ src_configure() {
--disable-dependency-tracking
--enable-noexecstack
--disable-O-flag-munging
+ $(use_enable static-libs static)
# disabled due to various applications requiring privileges
# after libgcrypt drops them (bug #468616)
@@ -47,11 +43,5 @@ src_configure() {
$([[ ${CHOST} == *86*-darwin* ]] && echo "--disable-asm")
$([[ ${CHOST} == sparcv9-*-solaris* ]] && echo "--disable-asm")
)
- autotools-multilib_src_configure
-}
-
-src_install() {
- autotools-multilib_src_install
-
- rm -r "${ED%/}"/usr/{bin,include,lib*/*.so,share} || die
+ autotools-utils_src_configure
}