summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-11-12 10:45:38 +0000
committerPeter Volkov <pva@gentoo.org>2009-11-12 10:45:38 +0000
commit3298274fa5a60de9ea333d70b26b0448e3b3eeac (patch)
treec357e02648dbc8f66a572ec6e3c76220f1171e05 /dev-libs/libical
parentFix init script for 2.0.1 (bug 271882), thanks to Tim O'Kelly (diff)
downloadgentoo-2-3298274fa5a60de9ea333d70b26b0448e3b3eeac.tar.gz
gentoo-2-3298274fa5a60de9ea333d70b26b0448e3b3eeac.tar.bz2
gentoo-2-3298274fa5a60de9ea333d70b26b0448e3b3eeac.zip
Version bump. Addes improvements, Gilles Dartiguelongue suggested in bug #268350. Drops -lpthread hack since upstream fixed sources. Got another confirmation that tests are supposed to fail.
(Portage version: 2.1.7.4/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libical')
-rw-r--r--dev-libs/libical/ChangeLog11
-rw-r--r--dev-libs/libical/libical-0.44.ebuild45
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-libs/libical/ChangeLog b/dev-libs/libical/ChangeLog
index f9c5cb49eb10..ee447ddf0711 100644
--- a/dev-libs/libical/ChangeLog
+++ b/dev-libs/libical/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/libical
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libical/ChangeLog,v 1.53 2009/11/05 20:23:50 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libical/ChangeLog,v 1.54 2009/11/12 10:45:38 pva Exp $
+
+*libical-0.44 (12 Nov 2009)
+
+ 12 Nov 2009; Peter Volkov <pva@gentoo.org> +libical-0.44.ebuild:
+ Version bump. Addes improvements, Gilles Dartiguelongue suggested in bug
+ #268350. Drops -lpthread hack since upstream fixed sources. Got another
+ confirmation that tests are supposed to fail.
05 Nov 2009; Markus Meier <maekke@gentoo.org> libical-0.43.ebuild:
arm stable, bug #281427
@@ -23,7 +30,7 @@
29 Apr 2009; Jeroen Roovers <jer@gentoo.org> libical-0.43.ebuild:
Stable for HPPA (bug #238625).
- 281 Apr 2009; Michele Noberasco <s4t4n@gentoo.org> libical-0.33-r1.ebuild:
+ 28 Apr 2009; Michele Noberasco <s4t4n@gentoo.org> libical-0.33-r1.ebuild:
Added 'test' to RESTRICT for this version. Closes bugs #238625 and #257280.
libical-0.43.ebuild:
Stable for x86.
diff --git a/dev-libs/libical/libical-0.44.ebuild b/dev-libs/libical/libical-0.44.ebuild
new file mode 100644
index 000000000000..ec129343fb2d
--- /dev/null
+++ b/dev-libs/libical/libical-0.44.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libical/libical-0.44.ebuild,v 1.1 2009/11/12 10:45:38 pva Exp $
+
+EAPI="2"
+
+DESCRIPTION="An implementation of basic iCAL protocols from citadel, previously known as aurore"
+HOMEPAGE="http://freeassociation.sourceforge.net"
+SRC_URI="mirror://sourceforge/freeassociation/files/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="|| ( MPL-1.1 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# https://sourceforge.net/tracker2/index.php?func=detail&aid=2196790&group_id=16077&atid=116077
+# Upstream states that tests are supposed to fail (I hope sf updates archives
+# and answer became visible):
+# http://sourceforge.net/mailarchive/forum.php?thread_name=1257441040.20584.3431.camel%40tablet&forum_name=freeassociation-devel
+RESTRICT="test"
+
+src_prepare() {
+ # Do not waste time building examples
+ sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ -i Makefile.am Makefile.in || die "sed failed"
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TEST THANKS TODO \
+ doc/{AddingOrModifyingComponents,UsingLibical}.txt || die "dodoc failed"
+
+ if use examples; then
+ rm examples/Makefile* examples/CMakeLists.txt
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}